Becky!FAQ & Tips について

Becky! Ver.2 FAQ & Tips について

はじめに

既にご存知のように Becky! Internet Mail はとても高機能なメールソフトです。「こんなことができれば便利なのに」と思ったら、あちこち機能を探してみましょう。たいていの要望はかなえてくれるはずです。また、Becky!は使い勝手が優れたメールソフトです。直感的に使えるようにという作者さんの細やかな心づかいが、あちらこちらに感じ取れます。

しかし人の感性は千差万別。探してみても、ヘルプを読んでみても、実現方法に気付くことができないことだってあります。ちょっと違った形で実現できることもあります。あるいは、残念ながらご要望に応えてくれないこともあるでしょう。

また、Becky!を使っているうちに、時には困ったことも起きてしまいます。それは設定の問題だったり、環境の問題だったり、勘違いだったりします。あるいは Becky!そのものの問題かもしれません。

私たちは、そんな「やりたいこと」「困ったこと」とその実現・解決方法を実際に経験し、見聞きしてきました。また「知ってると便利なこと」も少しずつたくわえてきました。

そのような情報を求めているユーザーは次々と現れます。何度となく質問と応答が繰り返されてきました。「せっかくの情報をひとところにまとめ、多くのユーザーが便利にBecky!を使えるようにしたい。」そのように考えていたユーザー有志が集い、このFAQを作りました。

少しでも貴方のお役に立てば幸いです。

Becky! Ver.2 FAQ Working Group

概要

本文書は、有)RimArtsによる高機能メールソフト「Becky! Internet Mail Ver.2」に関する「よくある質問とその答え(Frequency Answered Questions : FAQ)」および「知っていると便利なこと(Tips!)」を集積し、ユーザーがそれらの情報を簡単に入手できるようにすることを目的として、ユーザー有志「Becky!Ver.2 FAQ Working Group(B2-FAQ-WG)」が編纂したものです。

これによって頻出質問を減らすことで、以下のような効果を狙っています。

  • Becky!作者の乗松さんの負担を減らし、Becky!およびDanaの開発に専念してもらう
  • BBSやメーリングリストで回答している物好きユーザー有志が楽できる(笑)

本文書の第１次配布サイトは http://www.becky-users.net/faq.html とします。ここより各FAQ関連サイトへのリンクなども予定しています。ただし公開場所は変更になることがありますのでご注意ください。

また本文書はBecky!Ver.2のためのものであり、旧版であるVer.1には当てはまらない事項も多々あります。Ver.1に関する情報は、しまやさんの「Becky!非公式ホームページ」をご参照ください。

著作権および免責

  • この文書全体の著作権は、「Becky!Ver.2 FAQ Working Group」が保持するものとします。
  • ただし内容に間違いがあった場合、あるいは記述に従った結果ユーザーが損害を被った場合でも、B2-FAQ-WGは一切責任を負うものとはしません。
  • この文書の作成にあたってはBecky!開発元のRimArtsの関与はありません。従って一切の責任はRimArtsにはありません。またRimArtsにこの文書に関連した問い合わせは行わないでください。

リンク、配布条件

  • この文書中のすべてのページへのリンクは自由です。
  • 出典（著作者(B2-FAQ-WG)と引用時の元URL）を明記した引用は自由に行なって下さって結構です。
  • 配布版（HTML版、ヘルプ版を予定）の転載は自由です。

連絡先など

本文書の内容の記述にあたっては正確さとわかりやすさに努めましたが、間違いや不十分な箇所もあると思われます。そのような箇所のご報告やご意見・ご感想は、B2-FAQ-WG（b2-faq-wg@becky-users.net：メンバー全員に届きます）へメールでお寄せください。

ただし、我々はあくまでも「ユーザー有志」であり、Becky!のサポート担当ではありません。Becky!Ver.2本体に関する質問などは、公式サポートBBSやメーリングリストへ投稿してください。

[目次]


Becky! Ver.2 FAQ & Tips：目次

Becky! Ver.2 FAQ & Tips について

第１部：Becky! Q & A

  • インストール
    • [01001] Becky!Ver.1.xxからのバージョンアップ
    • [01002] 他のメールソフトからのデータの移行
      • [01003] Outlook Express 4/5/6からの移行
      • [01004] Outlook 97/98/2000からの移行
      • [01005] Netscape Messenger 4.xx からの移行
      • [01006] Eudoraからの移行
      • [01007] AL-Mailからの移行
      • [01011] Datulaからの移行
      • [01012] EdMaxからの移行
      • [01013] PostPetからの移行
    • その他
      • [01008] １台のパソコンを複数のユーザーで共有したい
      • [01009] 他のパソコンにBecky!を移すには
      • [01010] Becky!をバージョンアップするには
      • [01014] Becky!の動作環境は？Windowsのバージョンに依存しますか？
  • トラブルシューティング
    • 送信／受信関係
      • [02001] サーバーへの接続に失敗して送受信できません
      • [02002] IDまたはパスワードが違うといわれてしまいます
      • [02004] サーバーにメールが残ってしまっているようなのですが
      • [02005] 定期チェックの間隔を変更しても反映されない
      • [02007] 送信できません
      • [02034] 開封確認メールを送信できない
      • [02038] 送受信時にBecky!がエラーを起こしてしまう
    • 受信メールの表示・編集
      • [02012] 本文が文字化けしている
      • [02013] メール文中にじゃまな文字列が表示される
      • [02024] 文字で書かれたイラストや地図がズレて表示される
      • [02027] 直接編集モードでヘッダが編集できない
      • [02042] 未開封ジャンプが効かなくなる時がある
    • ツリー・リストビュー
      • [02020] スレッドがつながらない
      • [02029] ツリービューの未開封メール数表示がおかしい
      • [02041] 開封済みメールが未開封に戻ってしまう
      • [02048] フォルダを開く時に時間がかかる
    • メール作成
      • [02026] 日本語入力中にウィンドウ表示がおかしくなってしまう
      • [02028] ニックネームの展開がうまくいかない時がある
      • [02030] 署名の前の一行が削除できない
      • [02036] 文章の一部の色が変わってしまう
      • [02037] HTMLメール作成時にMS Office 2000のCD-ROMを要求されてしまう
      • [02039] 外部編集ツールの起動を検知できない
      • [02043] 返信メール作成時に引用部分が文字化けしてしまう
    • 添付ファイル
      • [02023] 送信時に添付したはずのないファイルが添付されてしまう
      • [02025] Macからの添付ファイルが開けない
      • [02031] 添付ファイルを読み取り専用で開いてしまう
      • [02045] 送信した添付ファイルが壊れてしまう
    • 印刷
      • [02044] 印刷時に文字化けしてしまう
    • コンピュータウィルス
      • [02046] 受信したメールを開かず捨てるには
      • [02049] アンチウィルスソフト利用時にメールが消失してしまう
    • その他
      • [02014] 起動できない
      • [02006] Becky!が強制終了されてしまいます
      • [02015] メールが消えてしまった
      • [02016] データフォルダがどこかにいってしまった
      • [02017] ツールバーの表示がおかしい
      • [02018] 起動パスワードを受け付けられず、Becky!を使えない
      • [02019] メールサーバーのパスワードを忘れた
      • [02021] ウィンドウが最大と最小でしか表示できなくなった
      • [02022] クリッカブルURLを使うとBecky!がフリーズする
      • [02010] 勝手にダイヤルアップされてしまう
      • [02032] クリッカブルURLでNetscape 6が２つ開いてしまう
      • [02033] 設定を変更しても保存されない
      • [02035] エクスポートしたメールの日本語が化ける
      • [02040] 未送信メールがないのに終了時に警告が出てしまう
      • [02047] Becky!の起動に時間がかかる
  • メール作成
    • [03001] 宛先毎に署名や名乗り、Fromアドレスを変更したい
    • [03002] 文字の大きさ・色の変更や画像貼り付けの方法は？
    • [03003] メールにBGMを添付したい
    • [03004] 署名を固定ピッチフォントで作りたい
    • [03005] 「全員に返信」の時、元の差出人以外もTo:に入れたい
    • [03006] 宛先に敬称を付けたい
    • [03007] Outlook Expressの「ひな形」を使う方法
  • メール送受信
    • [04001] 複数のプロファイルで同時にメールチェックしたい
    • [04002] PostPetからのメールをサーバーに残すには
    • [04003] Hotmail/MSN/AOLのメールアカウントで送受信できますか？
    • [04004] 広告メールなどを読まずに自動削除したい
    • [04005] 受信の後に送信したい
    • [04006] メールを受信せずに削除するには？
  • 受信メールの表示・操作・編集
    • [13001] HTMLメールのHTMLパートを削除するには
    • [13002] メールをキー操作で他のフォルダに移動/コピーするには
    • [13003] ヘッダを編集するには
    • [13004] メールを別ウィンドウで表示したい
    • [13005] HTMLメールを表示したくない
  • 添付ファイル
    • [05001] BASE64以外のエンコード方法で送信したい
    • [05002] 添付ファイルの保管場所はどこ？
    • [05003] 添付ファイルを探すには
  • リストビュー（メール一覧）
    • [06001] 日付・時刻表記を変更したい
    • [06002] 日付が前後したメール間でもスレッドをつなげたい
    • [06003] リストビューの表示項目を変更したい
  • ツリービュー（フォルダ・メールボックス）
    • [07001] フォルダの並び順を変えたい
    • [07002] メールボックスの並び順を変えたい
    • [07003] メールボックスを削除するには？
  • アドレス帳
    • [08001] アドレス帳のグループの並び順を変えたい
    • [08003] アドレス帳のグループを移動したい
    • [08004] アドレス帳を印刷したい
    • [08005] アドレス帳をコピーしたい
  • カスタマイズ・動作変更
    • [09001] 起動時の絵（スプラッシュ）を変更or非表示にしたい
    • [09002] 右上の封筒アニメーションアイコンを変更したい
    • [09003] 英語メニューで使いたい
    • [09004] 起動時にメールボックスを指定したい
    • [09005] 画面の配色を変更したい
    • [09006] URLクリック時にブラウザを新しいウィンドウで開きたい
    • [09007] 各部のフォントを変更したい
  • プラグイン
    • [10001] 「プラグイン」とは何ですか？
    • [10002] どんなプラグインを、どこで入手できますか？
    • [10003] プラグインの組み込み方
    • [10004] プラグインを作成するには
  • データの保守
    • [11001] データフォルダの容量を節約したいのですが
    • [11002] メールボックスフォルダの中の日付が名前のファイルは何？
    • [11003] データおよび設定のバックアップと復旧
    • [11004] CD-R/RWにバックアップしたときの注意
    • [11005] 複数のデータフォルダをひとつにまとめたい
  • 印刷
    • [12002] 添付ファイル名も印刷したい
    • [12003] HTMLメールを印刷したい
  • その他
    • [19001] Ver.2ではまた登録料を払わなくてはいけない？
    • [19002] Ver.1にあった機能が見当たらないのですが
    • [19003] 複数のパソコンのメールデータを同期させて使いたい
    • [19004] Becky!でNetNewsを読みたい
    • [19005] Windows CEでBecky!を使いたい
    • [19006] 他のOSで動くBecky!が登場する予定は？
    • [19007] 他のメールソフトへデータを移行するには
    • [19008] PalmOS搭載機と連携させるには
    • [19009] 相手がメールを読んだか確認したい
    • [19010] Internet ExplorerからBecky!を起動したい
    • [19011] NetscapeからBecky!を起動したい

第２部：知っていると便利なこと

  • [20001] Becky!のデータ保管形式
  • [20002] スレッド表示と修復
  • 【作成中】[20003] メールの整理と活用
  • [20004] キー操作でBecky!を使う
  • 【作成中】[20005] 言語とフォントの対応
  • [20006] ドラッグアンドドロップでできること

第３部：初心者向けE-Mail講座

  • 【作成中】[30001] E-Mailの仕組み
  • [30002] メールのヘッダについて
  • [30003] メールを書く時に注意すること－ネチケットについて
  • [30004] 使ってはいけない文字、使わない方がいい文字について
  • [30005] 添付ファイルについて
  • [30006] コンピュータウィルスについて
  • [30007] HTMLメールとは
  • 【作成中】[30008] ファイルの圧縮・展開について

付録：関連用語解説


Becky!Ver.1.xxからのバージョンアップ

Q. [01001] Becky!Ver.1.xxからのバージョンアップ

今までBecky!Ver.1を使ってきましたが、Ver.2にバージョンアップしようと思います。新規開発されたそうですが、今までのメールデータやアドレス帳のデータは使えますか？移行に関する注意点などがあれば教えてください。

A. Becky!Ver.2ではメールやアドレス帳のデータ保管形式が変更になりました。しかし、移行ソフトが付属していますので、今までのデータを使うことももちろん可能です。また、Ver.1とVer.2を一台のパソコンにインストールして併用することも可能です。

ただし、やはり新規開発ソフトであるために、使い勝手や設定方法などが変わっている部分もあります。バージョンアップのための作業や、Ver.1と2の違いをまとめたWEBページがありますので、そちらを参照するといいでしょう。「Becky!ユーザーの部屋」内の「ちょっといい話」-「Becky!Ver.1→2移行ガイド」です。

また、Ver.2から、フォルダの名前は先頭に" # ! . "などの文字を使えなくなっています。その他にもデータ保管形式の変更に伴って、ファイル名の制約が少々変わっています。移行する前に、Ver.1上でフォルダ名を変更してから移行ツールを使いましょう。

なお、Ver.1とそのデータですが、無事移行できた後はもちろん削除してもいいと思います。使い勝手になれるまでは併用しておいて、問題ないと判断できてから削除という手順でもいいでしょう。判断はあなた次第です。

コントロールパネルの「アプリケーションの追加と削除」から「Becky!インターネットメール」を削除、その上で標準では"C:\Program Files\Rimarts\Rebecca"以下をすべて削除すれば、アンインストール完了です。

→ 関連項目
  • [19001] Ver.2ではまた登録料を払わなくてはいけない？
  • [19002] Ver.1にあった機能が見当たらないのですが
Copyright 2000-2002 Becky! Ver.2 FAQ Working Group, All Rights Reserved.
利用規約・免責事項等については Becky! Ver.2 FAQ & Tips について をご覧ください。


他のメールソフトからの移行

Q. [01002] 他のメールソフトからの移行

今まで違うメールソフトを使ってきたのですが、Becky!に乗り換えようと思います。いままでのメールやアドレス帳の資産はどのように移せばいいでしょうか？

A. Becky!にはいくつかの代表的なメール保存形式のデータを取り込む（インポート）機能があります。つまり、今まで使ってきたメールソフト側でそれらの形式でメールデータを書き出して（エクスポート）、Becky!側でそのファイルをインポートすれば（「ファイル」-「インポート」）、メールデータの移行ができます。

Becky!が扱えるメールのデータ形式は下記の通りです。

  • UNIX mbox形式
  • eml形式
  • カスタム（メールの区切り文字列を指定可能）

いくつかのメールソフトに対してはデータ形式変換ツールが存在します。たとえば野元さんの「MailExp」では種々のメールソフトのデータを相互変換できます。ぜひ試してみてください。

また、ほんとさんの「よもやまメールデータ移行方法紹介のページ」が参考になります。

アドレス帳の移行は、Becky!側ではCSV形式（１レコード１行のテキスト形式で、１項目の区切りが半角カンマ）かタブ区切りテキスト（項目区切りがタブ文字）のファイルをインポートすることが可能です（アドレス帳のメニューから「ファイル」-「インポート」）。移行元のメールソフトのアドレス帳データをエクスポート、あるいは直接編集してそれらの形式にしてしまいましょう。

メールにせよアドレス帳データにせよ、上記の形式で書き出し可能かどうかはそのメールソフトごとに違います。それぞれのメールソフトのサポート先に問い合わせてください。代表的なメールソフトについては別項で解説します。

→ 関連項目
  • [01003] Outlook Express 4/5/6からの移行
  • [01004] Outlook 97/98/2000からの移行
  • [01005] Netscape Messengerからの移行
  • [01006] Eudoraからの移行
  • [01007] AL-Mailからの移行
  • [01011] Datulaからの移行
  • [01012] EdMaxからの移行
  • [01013] PostPetからの移行


Outlook Express 4/5/6からの移行

Q. [01003] Outlook Express 4/5/6からの移行

A. まず、お使いのOutlook Expressのバージョンを確認してください（「ヘルプ」-「バージョン情報」）。バージョン4と5(5.5を含む)/6ではデータ形式が異なるので、手順も違います。

Microsoft Officeなどに付属の個人情報ソフト「Outlook」は別ソフトですのでご注意ください。

まずメールの移行です。

メール数が少ない場合、あるいはツールの利用が不安な初心者の方は、ほんとさんの 「よもやまメールデータ移行方法紹介のページ」にて紹介されている方法をお薦めします。画像入りでわかりやすく解説されています。

メール数が多い場合や、フォルダをたくさん作って整理してしまっている場合は、便利な変換ソフトを使って、データをまとめてBecky!が取り込める形式に変換してしまいましょう。

バージョン4の場合

野元さん作の「MailExp」を使い、Becky!形式としてファイルに保存しましょう。ただしMailExpが書き出すBecky!形式は旧バージョン（Becky!Ver.1.xx）のものなので注意してください。直接データフォルダ内に納めてもBecky!Ver.2からは認識されませんので、Becky!Ver.2にて「ファイル」-「インポート」で取り込む必要があります。半角ピリオドを区切り文字に指定しましょう。

手順そのものは同様ですが、メール区切り方式が異なるUNIX mbox形式を経由するのもお薦めです。

バージョン5/6の場合

Tietewさん作の「OE5/6 Multi Converter」を使いましょう。このツールはBecky!のデータ形式に直接変換することができます。

アドレス帳の移行はバージョン4/5/6共通です。若干の表記の違いは有りますが、基本的な手順は変わりません。CSV（カンマ区切りテキスト）形式を経由しましょう。

  1. まずOutlook Expressのアドレス帳をテキストファイルに「エクスポート」します（「ファイル」-「エクスポート」-「ほかのアドレス帳」）。
  2. アドレス帳エクスポートツールが起動しますから、「テキストファイル（CSV）」を選びます。
  3. 書き出すファイル名を指定しましょう。どんな名前でもかまいませんが、拡張子を.csvとしておいた方がいいですね。
  4. エクスポートするフィールド（項目）を選択します。Becky!のアドレス帳にはない項目は除いておきましょう。それが終わるとエクスポート完了です。
  5. Becky!のアドレス帳側で先ほどのファイルをインポートします（「ファイル」-「インポート」-「テキスト形式」）。ここで取り込む項目と順番を指定し、区切り文字を「カンマ」にすれば取り込めます。

エクスポート／インポートする時の項目の選択が手間ですが、いく度か試してみてください。OEからエクスポートする時に、どの項目を書き出したかメモしておくといいでしょう。

またBecky!へのインポート時には、Y.Hadaさんの「Becky Address Book Manager For B2」を使うと便利です。CSVファイルの中身を見ながら対応項目を選択できますし、入力テンプレートも用意されています。

→ 関連項目
  • [01002] 他のメールソフトからの移行


Outlook 97/98/2000からの移行

Q. [01004] Outlook 97/98/2000からの移行

A. 残念ながら直接メールデータを変換する方法はないようです。いったんインターネットエクスプローラに付属のメールソフト「Outlook Express（以下、OEと略記）」を経由しましょう。

名前はややこしいですが、個人情報ソフト「Outlook」とメールソフト「Outlook Express」は別ソフトですのでご注意ください。

まずOEはお使いのパソコンに入っていますか？最近のパソコンなら最初から組み込まれているはずです。もし入っていない、あるいはバージョンが古い場合には、ここは思い切ってインターネットエクスプローラの最新版ごとセットアップしてしまいましょう。インターネットエクスプローラはパソコン雑誌の付録CD-ROMなどから入手できます。

OEを起動できたら、「ファイル」-「インポート」-「メッセージ」を実行してください。取り込めるメールソフト一覧が出てきますので、そこでお使いのOutlookを選び、データを変換してOEに取り込んでしまいましょう。

さて、この後はOEからBecky!への移行方法に従います。下記の関連項目を参照してください。

アドレス帳データのみ移行したい場合にはOEを経由しなくても移行する手段があります。CSV形式のテキストファイルを経由してBecky!に取り込みましょう。下記はOutlook2000の場合です。

  1. まずOutlookの「連絡先」をテキストファイルにエクスポートします（「ファイル」-「インポートとエクスポート」から「ファイルへエクスポート」）。
  2. そこで（例えば）テキストファイル（Windows、カンマ区切り）を選びます。
  3. 書き出すファイル名を指定しましょう。どんな名前でもかまいませんが、拡張子を.csvとしておいた方がいいでしょう。
  4. 「連絡先」フォルダを選択しましょう。
  5. 表計算ソフトなどでCSVファイルの内容を確認しましょう。多くの項目があるので、不要な列を適当に削除する必要があります。その際、Outlookでの「電子メール表示名」をBecky!の「宛先名」に対応させて残しておくといいでしょう。
  6. Becky!のアドレス帳側で先ほどのファイルをインポートします（「ファイル」-「インポート」-「テキスト形式」）。ここで取り込む項目と順番を指定し、区切り文字を「カンマ」にすれば取り込めます。
→ 関連項目
  • [01003] Outlook Express 4/5からの移行
  • [01002] 他のメールソフトからの移行


Netscape Messenger 4.xx からの移行

Q. [01005] Netscape Messenger 4.xx からの移行

A. まずメールの移行ですが、Netscape Messengerのメールデータは１メールフォルダ＝１ファイルで「UNIX mbox形式」で保管されていますので、Becky!の標準のインポート機能を用いて移行できます。

Netscape Messengerのメールデータの保管場所は標準で
"C:\Program Files\Netscape\Users\プロファイル名\Mail"
で、その中にあるメールフォルダと同名のファイルがデータとなっています。このファイルを、Becky!側の「ファイル」-「インポート」にて「UNIX mbox形式」を指定した上でインポートすればOKです。

ただし、あらかじめNetscape Messenger側で「ファイル」-「フォルダを圧縮」を実行しておきましょう。メールを重複して取り込んでしまうことがあります。

アドレス帳の移行はCSV（カンマ区切りテキスト）形式を経由しましょう。

  1. まずNetscape Messengerのアドレス帳をテキストファイルに「エクスポート」します（「ファイル」-「エクスポート」）。
  2. エクスポートダイアログが開きますから、「ファイルの種類」を「カンマ区切り（*.csv）」にし、書き出すファイル名を指定します。拡張子を付けなければ.csvが補われます。
  3. 「保存」を押せばエクスポート完了です。
  4. Becky!のアドレス帳側で先ほどのファイルをインポートします（「ファイル」-「インポート」-「テキスト形式」）。ここで取り込む項目と順番を指定し、区切り文字を「カンマ」にすれば取り込めます。

インポートする時の項目の選択が手間ですが、いく度か試してみてください。

またBecky!へのインポート時には、Y.Hadaさんの「Becky Address Book Manager For B2」を使うと便利です。CSVファイルの中身を見ながら対応項目を選択できますし、Netscape Messengerに関しては入力テンプレートも用意されています。

→ 関連項目
  • [01002] 他のメールソフトからの移行


Eudoraからの移行

Q. [01006] Eudoraからの移行

A. Eudoraのメール保管形式は、基本的にUNIX mbox形式で、Windows版の場合データフォルダの中に拡張子が.mbxのファイルとして保管されています。つまりBecky!のインポート機能で取り込みが可能ですが、いくつか注意点があります。

  • 添付ファイルが別に保存されており、Becky!のインポート機能では移すことができない。
  • 自分の送信済みメールにはDate:ヘッダが付加されていないので、送信日時が引き継がれない。

またアドレス帳はテキストファイルですが、書式が少々複雑なので、簡単には移行できません。

これらの問題を解決するには、他のソフトを経由して移行するという手段がありますが、現時点ではどれも完璧とはいかないようです。それぞれの利点と問題点を下記に列挙しました。

ここでの記述はEudora Pro Ver.4.3.2-Jのデータで確認しました。Eudoraはどのバージョンの保管形式も大きな変更はないようですが、細かな違いによりうまくいかない可能性があることに注意して下さい。
野元さん作のメールデータ変換ツール「MailExp」を使う
  • 送信済みメールの送信日付は、元情報を変換しうまく追加してくれる。
  • 添付ファイルは移行不可。
  • アドレス帳は当然対象外。
Outlook Expressを経由

Outlook Expressのインポート機能を利用。「ファイル」-「インポート」-「メッセージ」でメールを、同じく「ほかのアドレス帳」でアドレス帳を取り込み可能。

  • 対象とするEudoraのバージョンが3以前ということで、Ver.4のデータでは一部うまく移行できないメールがある。
  • 送信済みメールの送信日付は引き継がれない。
  • 添付ファイルは移行不可。
  • アドレス帳は移行可。
Netscape Messengerを経由

Netscape Messenger ver.4.7xのインポート機能を利用。「ファイル」-「インポート」でメール・アドレス帳を一括取り込み可能。

  • 送信済みメールの送信日付は引き継がれない。
  • 受信メールの添付ファイルは移行可。送信済みメールのものは不可。
  • アドレス帳は移行可。
→ 関連項目
  • [01002] 他のメールソフトからの移行
  • [01003] Outlook Express 4/5からの移行
  • [01005] Netscape Messengerからの移行


AL-Mailからの移行

Q. [01007] AL-Mailからの移行

A. まずメールデータですが、AL-Mail32bit版の場合、UNIX mbox形式を経由しましょう。AL-Mail側の各フォルダ内で「メール」-「全メールの選択」の後、「メール」-「名前をつけて保存」にて「ファイルの種類」を「mboxファイル(*.mbox)」で書き出し、各フォルダごとに一つのファイルに保存してやりましょう。あとはBecky!側で「インポート」を実行すれば取り込めます。

あるいは野元さんの「MailExp」でBecky!（ただしVer.1）形式を経由するのもお薦めです。UNIX mbox形式の場合、メール本文中の行頭にFromがある場合、そこでメールが分断されてしまうことがあるからです。また16bit版AL-Mailのメールデータも変換できます。Becky!側で取り込む時は「カスタム」で半角ピリオドを区切り文字で指定すればOKです。

アドレス帳のインポートは、Y.Hadaさんの「Becky Address Book Manager For B2」を使うと、テキストファイルの直接編集の必要がなく、簡単にインポート可能です。

→ 関連項目
  • [01002] 他のメールソフトからの移行


Datulaからの移行

Q. [01011] Datulaからの移行

A. まず、メールデータはUNIX mbox形式を経由しましょう。

Datula側の各フォルダ内で「編集」-「すべて選択」の後、「メール」-「エクスポート」にて「Unix Mailbox」で書き出し、各フォルダごとに一つのファイルに保存してやりましょう。あとはBecky!側で「インポート」を実行すれば取り込めます。

ただしUNIX mbox形式の場合、メール本文中の行頭にFromがあるとそこでメールが分断されてしまうことがありますのでご注意を。そのメールだけ別に移行するといった対応が必要です。
また古いバージョンのDatulaの場合、UNIX mbox形式で書き出せないそうです。その時はAL-Mail形式で書き出し、メール区切り行を74個の"*"とすればインポートできます。

アドレス帳のインポートは、Y.Hadaさんの「Becky Address Book Manager For B2」を使うと、テキストファイルの直接編集の必要がなく、簡単にインポート可能です。

→ 関連項目
  • [01002] 他のメールソフトからの移行


EdMaxからの移行

Q. [01012] EdMaxからの移行

A. まず、メールデータはUNIX mbox形式を経由しましょう。

EdMax側の各フォルダ内で「編集」-「すべて選択」の後、「ファイル」-「エクスポート」にて「形式」を「再構成して保存（添付ファイル付き）」に、「区切り」を「UNIX MBOX」にして書き出し、各フォルダごとに一つのファイルに保存してやりましょう。あとはBecky!側で「インポート」を実行すれば取り込めます。

ただしUNIX mbox形式の場合、メール本文中の行頭にFromがあると、そこでメールが分断されてしまうことがありますのでご注意を。そのメールだけ別に移行するといった対応が必要です。
EdMaxの場合、バージョンごとにメニューの構成や表記が変更されていることが多いため、上記と多少異なる場合があります。

アドレス帳のインポートは、Y.Hadaさんの「Becky Address Book Manager For B2」を使うと、テキストファイルの直接編集の必要がなく、簡単にインポート可能です。

→ 関連項目
  • [01002] 他のメールソフトからの移行


PostPetからの移行

Q. [01013] PostPetからの移行

A. s164さん作成の「PPExport」を使いましょう。メールとおともだち帳（アドレス帳）の両方をBecky!Ver.1形式に変換してくれます。旧バージョンのものですが、Ver.2で簡単に取り込むことが出来ます。利用方法や書き出し先ファイル名などについてはPPExportのドキュメントを参照してください。

書き出したメールデータは、Becky!Ver.2にて「ファイル」-「インポート」を実行し、取り込みましょう。「カスタム」を選択し、区切り文字に半角ピリオド"."を指定すればOKです。

Becky!Ver.1形式に書き出したおともだち帳は、Becky!Ver.2にてアドレス帳を起動し、インポートを実行しましょう（「ファイル」-「インポート」-「テキスト形式」）。取り込む順番は「メールアドレス」-「宛先名」です。区切り文字は「タブ(09h)」にしてください。

→ 関連項目
  • [01002] 他のメールソフトからの移行


１台のパソコンを複数のユーザーで共有したい

Q. [01008] １台のパソコンを複数のユーザーで共有したい

１台のPCを複数のユーザーで共有しているのですが、Becky!を使い分ける方法はあるでしょうか？

（注意）Becky!はシェアウェアであり、ライセンスと実際に使うユーザー数の関係に注意する必要があります。詳しくはLicense.txtを参照してください。
使用時に再ログオン（再起動）ができる場合：Windowsのユーザー管理を使用して切り替えましょう

Windowsでは、複数のユーザーがアプリケーションの設定やデスクトップなど、それぞれ独自の環境を保存することができます。Windows NT(2000)ではこれが標準になっていますので、何も考えずにそれぞれの人がBecky!を起動すれば問題ありません。

Windows98/95の場合は、「コントロールパネル」-「パスワード」-「ユーザー別の設定」タブで「各ユーザーは独自に基本設定とデスクトップ設定を変更できる。……」をチェックすると、Windows起動時やスタートボタン→「xxxのログオフ」後の再ログオンでユーザーを切り替えることができるようになります。後は普通にそれぞれのユーザーが普通にBecky!を使用できます

再ログオン（再起動）ができない場合：データフォルダを複数作ってショートカットで切り替えましょう

まず、「ファイル」-「システム」-「データフォルダの変更」を実行した後B2を再起動します。するとデータフォルダを新規に作ることができますので、この作業を人数分繰り返してデータフォルダを作成します。

次に、B2.exe へのショートカットを作成し、リンク先のBecky!Ver.2のパスの後に/F"先程作成したデータフォルダ"を追加します。

例) "C:\Program Files\Rimarts\B2\B2.exe" /F"C:\Becky!\abc"

これをデータフォルダの数だけつくってやれば、それぞれのユーザー専用のBecky!を起動することができます。

ただし、この方法では「全般的な設定」の内容は全員で共有することになります。

※秀まるお氏作の設定切り替えソフト「TwinSet」を利用すると、設定を変更してからBecky!の起動が可能になります。つまり、ログオンユーザーを変更しなくても複数ユーザーの使い分けができるようになります。


他のパソコンにBecky!を移すには

Q. [01009] 他のパソコンにBecky!を移すには

新しいパソコンを買ったので、今までのBecky!のメールデータをそちらに移したいのですが。

A. まずBecky!のデータフォルダを、MOやCD-R/RWなどの大容量メディアを使って新しいパソコンに移しましょう（CD-R/RWを使った場合には注意点があります。下記関連項目を参照して下さい）。Becky!のデータは通常は
C:\Becky!\"Windowsログオン名"
というフォルダに保管されています。"C:\Becky!\"ごと移動してしまいましょう。これでメール、アドレス帳、振り分け設定、アカウント情報など主要なデータがコピーできますした。

次に新しいパソコンにBecky!をインストールしましょう。

あとは初回起動時に「データフォルダの指定」ダイアログでどこをデータフォルダにするか問い合わせてきますので、「既存のフォルダを選択」をONにしてから「参照」ボタンを押し、コピーしてきたフォルダ（C:\Becky!\"Windowsログオン名"）を指定すればOKです。

ただし、「全般的な設定」の一部やBecky!の登録情報などは移行できません。古いパソコンのWindowsのレジストリに保管されているためです。レジストリについてご存じならコピーも可能ですが、再度設定し直してもそれほど手間はかかりません。

→ 関連項目
  • [11003] データのバックアップと復旧
  • [11004] CD-R/RWにバックアップしたときの注意


Becky!をバージョンアップするには

Q. [01010] Becky!をバージョンアップするには

Becky!の開発元RIMArts社からバージョンアップのお知らせが届きました。最新版の方が良さそうなのでバージョンアップしたいのですが、どのようにすればいいですか？

A. バージョンアップの方法は、基本的には新規インストールと同じです。

RIMArtsのWEBページからBecky!最新版の配布ファイルをダウンロードし、実行しましょう。インストール先を、すでにBecky!がインストールされているフォルダにすればOKです。今までのメールや各種設定も問題なく引き継がれます。

あ、バージョンアップ料などは必要ありませんので、ご心配なく。

ただし、「今まで使ってきたBecky!はVer.1.xxなんだけど、Ver.2.xxにしたいなあ」という場合には注意が必要です。Ver.2.00から2.02へという場合には上書きインストールでいいのですが、Ver.1とVer.2とはほぼ別ソフトなので移行作業が必要なのです。

→ 関連項目
  • [01001] Becky!Ver.1.xxからのバージョンアップ


Becky!の動作環境は？Windowsのバージョンに依存しますか？

Q. [01014] Becky!の動作環境は？Windowsのバージョンに依存しますか？

Windows 2000やWindows Me、あるいはWindows XPなど、Windowsの新バージョンが次々に出てきますが、Becky!はそれらのWindows上でちゃんと動作するのでしょうか？

A. Becky!Ver.2は基本的にWindows 95以降のWindowsであれば動きます。

ただし、Windows 95の初期の版をお使いの場合、システムファイルが古いと起動できないそうです。対処方法は下記関連項目（[02014]）を参照してください。また、Windowsとしての互換性が少々低いWindows NT 3.51以前は、残念ながらはっきりと対象外とされています。Becky!Ver.1.23まででしかサポートされていません。

上記の例外を除き、OSで互換性の問題が起こるのは主にドライバレベルの話で、Becky!のような普通のアプリケーションは OS やドライバにバグがなければ動くはずのものです。少なくとも Becky! はそのような作りになっているそうです。

ただし、まさにネットワークドライバの問題などによって動作しない例も報告されています。詳しくは下記の関連項目を参照してください。

→ 関連項目
  • [02014] 起動できません
  • [02038] 送受信時にBecky!がエラーを起こしてしまう


サーバーへの接続に失敗して送受信できません

Q. [02001] サーバーへの接続に失敗して送受信できません

「メールサーバーへの接続に失敗しました」というエラーメッセージが表示され、メールを送受信できません。

A. 主な原因は次のような事が考えられます。

  • メールボックスの設定で「POP3サーバー」「SMTPサーバー」の設定が間違っている
  • サーバーが何らかの原因で止まっている
  • サーバーが非常に混雑していて反応が遅い
  • サーバーへの途中経路に問題がある

初めてBecky!を利用する場合、１番目の原因であることが多いです。設定をよく確認してみてください。

  • 半角ピリオドをカンマと間違えていないですか？
  • アルファベットの"l(小文字のエル)"と"I（大文字のアイ）"、あるいは数字の"1"を間違えていないですか？
  • 同じく"O（オー）"と"0"を間違えていないですか？
  • 日本語入力をOFFにして入力していますか？

今まで使えていて特に設定を変えてもいないのにダメになった場合、サーバーや途中経路の問題かもしれません。

確認方法ですが、MS-DOSプロンプト(コマンドプロンプト）で、ping POP3サーバー名 というコマンドを実行してください。サーバーまでの経路と反応を確認できます。

Reply from xx.xx.xx.xx: byte=32 time=xxms TTL=xxx

のような表示が数行出た場合、サーバーからはちゃんと反応があるということです。つまりBecky!の設定が間違っていると考えられます。もう一度設定を確認してみてください。

Request timed out.

と出た場合はサーバーからの反応が無いということです。つまりメールサーバーか途中のネットワークに問題があります。

サーバーの一時的な停止や混雑の場合、しばらく経てば復旧することがほとんどだと思います。時間を改めて試してみてください。インターネットプロバイダのWEBページを確認したらサーバーメンテナンスの告知があるかもしれません。

時間をあけてもダメな場合は、ネットワーク管理者かインターネットプロバイダのサポート窓口に連絡してください。


IDまたはパスワードが違うといわれてしまいます

Q. [02002] IDまたはパスワードが違うといわれてしまいます

メールを受信しようとすると、「メールサーバーから接続を拒否されました/ユーザーIDまたはパスワードが間違っていないかご確認ください」と表示され受信できません。

A. そのメッセージダイアログの最後の行が重要です。

-ERR Password supplied for ユーザー名 is incorrect

と表示される場合は、ユーザーIDかパスワードが間違っています。「メールボックスの設定」で確認してみてください。CapsLockがかかっていて大文字と小文字の入力が間違っていませんか？カンマとピリオドを間違ってはいませんか？

-ERR Maildrop lock busy! Is another session active?

と表示される場合は、サーバー上のメールデータがすでに使用中と見なされ、重複使用を禁じられています。この前の受信時に、途中でパソコンがエラーを起こしたりして、不慮の中断を起こしていませんか？しばらくすると解除されるはずですから、10分ぐらい間をおいてもう一度試してみてください。

もしいつまで待っても同様のメッセージがでる場合、メールサーバーの管理者やインターネットプロバイダのサポート窓口に連絡してください。

メッセージはこれらの通り出るとは限りませんが、だいたいの場合似たようなニュアンスのメッセージが表示されると思います。


サーバーにメールが残ってしまっているようなのですが

Q. [02004] サーバーにメールが残ってしまっているようなのですが

メールを受信すると、ステータスバーの表示が「9/12」のように半端な数字から始まり、この場合、4通しか受信しません。「1/12」から始まるはずではないですか？「メールボックスの設定」ではサーバーから削除する設定にしてあるのですが。

残ってしまっているとしたら、どのようにすれば削除できるでしょうか。

A. お察しのとおり、サーバーにメールが残ってしまっていると思われます。

メールボックスの設定→基本設定→受信メールをサーバーに残す にチェックが入っていると、メールを受信した後もサーバーにメールが残ったままになります。また、この設定を解除しても、既に残っているメールは削除されないのです。

あるいは、受信中にBecky!がハングアップしたことがあるといった原因で、設定によらずサーバーに残されてしまうということもあるようです。

このメールを消す方法は下記の3種類になります。

いらないメールだと分かっている場合

「メール」-「受信済みのメールをサーバーから削除」

全部受信し直す場合

「メール」-「受信済みのメールも含めて全て受信」

内容を確認して消す場合

「メール」-「リモートメールボックス」でサーバーにあるメールを確認・操作できます。「リモートメールボックス」の使い方はヘルプを参照して下さい。


定期チェックの間隔を変更しても反映されない

Q. [02005] 定期チェックの間隔を変更しても反映されない

「メールボックスの設定」-「受信」で定期チェックの間隔を変更したのですが、なぜか反映されません。チェック間隔が設定したものとは違うようなのですが。

A. 「全般的な設定」-「受信」での「巡回メールチェック」のチェック間隔が設定されたままなのではないでしょうか。

Becky!のメールチェック間隔は

  • 各メールボックスごとの定期チェック間隔（「メールボックスの設定」-「受信」-「定期チェック」）
  • 「巡回メールチェック」の間隔（「全般的な設定」-「受信」-「定期チェック」）

の２種類があります。ユーザーがしっかり使い分けましょう。


送信できません

Q. [02007] 送信できません

新しくインターネットプロバイダと契約し設定も済ませたのですが、メールを送ろうとするとエラーがでて送信できません

A. まず、SMTPサーバーの指定が間違っていないでしょうか。ここに問題がある場合の対処は関連項目を参照して下さい。

問題ない場合は、「ツール」-「プロトコルログを取る」にチェックを入れて、プロトコルログを確認して下さい。メールサーバーとBecky!の通信内容が確認できます。

エラーがでた直後のログに、下記のどれか、あるいは類似のメッセージがあった場合、そのサーバーには不正使用を禁じるための送信制限がかかっていると思われます。インターネットプロバイダやネットワーク管理者に問い合わせて、どのような制限があるかを確認しましょう。

エラーメッセージの例：

  • Relay operation rejected.
  • Relaying Denied: Authenticate with POP first.
  • sorry, that domain isn't in my list of allowed rcpthosts
  • Unable to relay for mail@address
  • not local host host.name, not a gateway
  • Relaying denied to host.name

一番多いのは、いったん受信動作を行なってユーザー認証をしてからでないと送信を許可しない「POP before SMTP」という方法で認証を行っている場合です。「メールボックスの設定」-「詳細」の「送信前にPOP3認証を行う」にチェックを入れてください。

サーバーによっては、この認証が反映されるまでに時間がかかる場合があります。上記の設定を行ってもだめな場合は、「送信後[300]ミリ秒待つ」の時間の設定を長めにしてみてください。

あるいは、送信しようとしているプロバイダとは別の会社のアクセスポイントに接続してはいないですか？その場合はもっとも制限が強くかけられることが多いです。たとえば以下のような可能性があります。

他のプロバイダなどからの送信を認めていない

素直にあきらめ、その会社のアクセスポイントへ接続しなくてはいけません。

自社のドメイン以外のメールアドレスでの送信を制限している

Sender:ヘッダに正規のメールアドレスを書くことで回避できる場合がありますが、MLなどでこのヘッダを使用している場合がありますので使用には注意してください。また、From:ヘッダをチェックしている場合、素直に正規のメールアドレスで送信するしかありません。

存在しないドメインからの送信を制限している

自分のメールアドレスが間違っていませんか？ピリオドやカンマの間違いなどに気をつけて、設定を確認して下さい。

また、企業などではSMTP AUTHという方法で、メールの送信時に認証を必要とする場合があります。「メールボックスの設定」-「詳細」の「SMTP認証」の設定を行なって下さい（設定内容は ISP や会社のネットワーク管理者に確認してください）。

→ 関連項目
  • [02001] サーバーへの接続に失敗して送受信できません


開封確認メールを送信できない

Q. [02034] 開封確認メールを送信できない

開封確認が必要なメールが来るとBecky!が確認メールを生成してくれますが、送信時にエラーが起きて送れません。

A. SMTPサーバーによっては、不正利用防止などの理由で、差出人情報であるEnvelope-From（ヘッダのFromとは違うもの）が空であったり別のドメインのものであったりするメールは、送信を許可していない場合があります。

ところが、開封確認の送信の時、Envelope-From、つまりSMTPセッションの"MAIL FROM"コマンドで送信するアドレスは空（"<>"）でなければならないとRFC2298で定義されています。

つまり、残念ながらSMTPサーバーに上記のような制限がかかっている場合には、開封確認メール送信機能との両立が出来ません。

Becky!Ver.2では、ヘッダのSenderフィールドに記述したアドレスをEnvelope-Fromとして優先して使用する仕様ですので、送信前にSenderに適当なアドレスを記述してやれば送信できることはできます。が、これはRFCに反してしまうことにご注意。

なお、Outlook Expressは開封確認メールであってもEnvelope-Fromが空ではないために送れてしまいます。当然、これはRFC違反です。

結局のところ、一言「読んだよ」というメールを送り返してあげる方が確実です。


送受信時にBecky!がエラーを起こしてしまう

Q. [02038] 送受信時にBecky!がエラーを起こしてしまう

大きなファイルを送受信する途中でエラーを起こし、強制終了してしまうことがあるのですが。

Windows2000やXPでメールを送受信する時に、Windowsごとエラーを起こしブルースクリーンが表示されてしまうのですが。

相手に送った添付ファイルが壊れているといわれます。自分あてに送ってみると、送信済みのものと受信したものでファイルサイズが違っているのですが。

A. トラブルが起きる原因は様々なものがありますが、送受信の際のトラブルの要因として多いのが、ネットワークドライバの問題です。いくつかのネットワークカードでは、おそらくドライバの不具合から、Becky!での送受信の際にトラブルが生じることが報告されています。送受信の際のトラブルはネットワークカードを疑ってみてください。

下記にサポートメーリングリストやBBSで報告された例をまとめておきます。ただし、未報告の例もあると思われますし、また、同じカードを使っていてもトラブルが起きていない例もあります。あくまで参考ということでどうぞ。

メーカー | 型番or商品名 | 症状・備考
Windows XP/2000/NT4
Planex | FNW-9800-T | 送信時にWindowsがブルースクリーンを表示して落ちる。突如再起動される。Becky!のみが落ちることもある。 同メーカー（ADMtek社）製のチップを使っている。
 | FNW-9802-T
 | FNW-9700-T
Corega | FastEther CB-TXL
Laneed | CardBus 100BASE-TX | Becky!が落ちる
Windows 9x
Planex | FNW-9800-T | 送信時にWindowsがブルースクリーンを表示して落ちる。Becky!がエラーを起こして強制終了される。
 | FNW-9802-T
 | ENW-8300-T | ある程度以上のサイズのメールが送れない。送信したはずの添付ファイルが壊れていることがある。 Windows標準の汎用ドライバではなく、最新のドライバに変更したら直ったという報告もあり。
ライオス システム | ISA-TPII(LN0370H) | ある程度以上のサイズのメールが送れず、Becky!がエラーを起こす。 メーカーが解散したため最新ドライバの入手は困難。

また、報告数は少ないものの、ディスプレイドライバの不具合によるものらしきトラブルもあるようです。

ネットワークやディスプレイのドライバを最新版に変更したら直る場合もありますが、すべての環境で改善されるわけではないようです。その場合はLANカード自体を交換してみる以外にないでしょう。

→ 関連項目
  • [02006] Becky!が強制終了されてしまいます


本文が文字化けしている

Q. [02012] 本文が文字化けしている

送られてきたメールの本文が意味不明の文字列になってしまって読めません。

本文は読めるのですが、その後ろに意味不明の文字列が何行も表示されます。

A. いわゆる「文字化け」にはいくつかの原因が考えられます。中には「文字化け」という症状とは違う場合もあります。下記の事項を確認してみてください。

外国語で書かれたメールではないか

"Content-Type"ヘッダの"charset=xxxx"という部分で、そのメールの言語が指定されています。日本語メールはたいてい「ISO-2022-JP」となっているはずです。

もし外国語のメールである場合には、それを読むための設定が必要です。設定の方法はBecky!Ver.2のヘルプの「高度な使い方」-「多言語サポート」を参照して下さい。また、言語とフォントの対応は、下記関連項目を参考にしてください。

メールの言語情報と実際の本文が一致していないのではないか

たとえば、メールが日本語で書かれているにもかかわらず、"Content-Type"ヘッダの"charset=xxxx"という部分が日本語のものでない場合があります。

これは送信側に問題がありますので、送信者にその旨連絡しましょう。

また、すでに受信してしまったものを表示するには、ウィンドウ右下の地球アイコンをクリックして、正しい言語を選択しましょう。ただし一時的な改善でしかありませんので、「フォルダの修復」などを実行するとまた文字化け状態に戻ってしまいます。完全に修正するにはヘッダを編集する必要があります。

HTMLメールの場合も同様の問題が生じることがあります。たとえばJUSTSYSTEMのShurikenから送られてきたHTMLでは、HTML本文がJISコードであるにもかかわらず、HTMLの記述が
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=Shift_JIS">
となってしまっている（つまりShift-JISを指定している）場合、表示がおかしくなります。「表示」-「ソースの表示」してから「直接編集モード」に移行し、このタグを編集（あるいは削除）すれば問題は解消すると思われます。

添付ファイルがデコードされていないのではないか

まれにBecky!が添付ファイルを自動でデコードできないことがあります。本文の後ろに文字列が付加されているのはたいていこのケースです。「ツール」-「解読」にて「uudecode」か「BinHex」を実行してみてください。文字列の先頭行が「begin 644」で始まっているのは「uudecode」で解読できるものと思われます。

また添付ファイルがついたメールが分割して送られてきている場合（Subjectに[1/5]のように「順番/分割総数」が付加されています）にも、途中のメールは文字化けのように見えます。到着したメールのどれかをリストビューでダブルクリックすると結合でき、その際に添付ファイルを自動でデコードしてくれます。

上記の項目にあてはまらない場合、配送途中のサーバーやもちろんBecky!の問題ということも考えられます。詳しい状況（文字化けが生じる再現状況。特定の文字が化けるとか、特定の宛先で生じるとか）を調べて、サポートMLやBBSに報告して下さい。

→ 関連項目
  • [30005] 添付ファイルについて
  • [20005] 言語とフォントの対応
  • [13003] ヘッダを編集するには


メール文中にじゃまな文字列が表示される

Q. [02013] メール文中にじゃまな文字列が表示される

メール文中にタグのような意味不明の文字列が表示されて読みにくいのですが。

A. そのメールは携帯電話やPHSから送られてきたメールではありませんか？携帯電話等のメールは、ハートマークやTELマークなどのE-MAILでは扱えない文字を送ることができます。これらの文字が入ったメールが携帯電話から一般のE-Mailに送られた場合、それらの文字が携帯電話のシステムやインターネットをつないでいるサーバーにて変換されて届きます。

変換された後の文字の例としては、下記のようなものがあります。

  • "〓"：i-modeからのメール中の特殊文字
  • <#HEART><#CLOCK><#TELEPHONE><#CUP>：DDI Pocket (H")のPメールDX中の特殊文字

また、これ以外にも下記のような原因で文字列が混入することがあります。メールのヘッダを確認してください。

Content-Type: text/htmlの場合

俗に言うHTMLメールといわれるものです。「全般的な設定」-「メール表示」-「HTMLメールの表示」で「MSIEコンポーネントを使用」にチェックを入れればHTML表示になるはずです。

Content-Type: text/enrichedの場合

Eudora Pro Ver.3にて書式付きのメールを送るとこの形式になってしまいます。が、受信・表示対応のメールソフトは他にはほとんどありません。送信者に「書式なし」で再送してもらってください。


文字で書かれたイラストや地図がズレて表示される

Q. [02024] 文字で書かれたイラストや地図がズレて表示される

地図を罫線文字で書いて送ったのですが、相手方ではうまく表示できないようです。なぜでしょう。

署名に文字で書かれた絵を付けている人がたくさんいますが、私のところではゆがんで表示されます。きれいに表示するにはなにか方法があるのですか？

A. メール本文を作成・表示する時のフォント（文字書体）によります。

フォントには「固定ピッチフォント」と「プロポーショナルフォント」の２種類があります。

固定ピッチフォントとは、いわゆる全角文字の幅は全て等しく、かついわゆる半角文字の幅がちょうどその半分であるフォントのことです。

プロポーショナルフォントとは、文字ごとに幅が異なるフォントです。たとえば"M"と"I"がおなじ幅だと、印刷物などでは美しくありませんよね。本来、文字ごとにきれいにみえる幅はデザインに応じて異なりますので、それを反映したフォントです。また、同じ文字でもフォントごとに幅が異なります。

そして、メールはあくまで「文章」を送るだけであって、相手がどのフォントで読んでくれるかまでは指定できないのです。

つまり、文字を使った絵（テキストアート）をメールで送る際には、まず自分側で固定ピッチフォントを利用して作成し、かつ相手が固定ピッチフォントを用いてその絵を見てくれる必要があります。

したがって、普段は相手が固定ピッチフォントで見てくれることを前提とするべきではありません。地図を送りたいなど、どうしても固定ピッチで見てほしい時には、その旨メール中にお願いの文章を書いておきましょう。

署名にもテキストアートを用いた凝ったものを利用する人がいますが、相手にそのとおりに見えることは期待してはいけません。

参考までに、Windowsに標準でインストールされている日本語フォントの内、固定ピッチフォントの例は「ＭＳ ゴシック」「ＭＳ 明朝」、プロポーショナルフォントは「ＭＳ Ｐゴシック」「ＭＳ Ｐ明朝」です（Ｐは「プロポーショナル」を意味しています）。

→ 関連項目
  • [03004] 署名を固定ピッチフォントで作りたい


直接編集モードでヘッダが編集できない

Q. [02027] 直接編集モードでヘッダが編集できない

送られてきたメールのDate:ヘッダがおかしかったので修正しようと、ヘッダ表示中に直接編集モードに切り替えました。ところが、文字を消そうとDeleteキーを押したらメールがゴミ箱に行ってしまい、驚きました。ヘッダは編集できないのですか？

A. 残念ながら、ヘッダ表示中は直接編集モードは無効となる仕様のようです。しかし編集する方法はありますので、下記関連項目を参照してください。

→ 関連項目
  • [13003] ヘッダを編集するには


未開封ジャンプが効かなくなる時がある

Q. [02042] 未開封ジャンプが効かなくなる時がある

スペースキーや4Wayボタンによる未開封ジャンプが使えなくなることがあるのですが、どうしてでしょうか。

A. その時の表示メールは、HTMLメールではないでしょうか。その場合、HTMLメールの最後を検知する方法がないため、ジャンプできないのが仕様とされています。

この場合は [Ctrl]+[Space]で次の未読に飛びましょう。

→ 関連項目
  • [30007] HTMLメールとは


スレッドがつながらない

Q. [02020] スレッドがつながらない

A. スレッドがうまくつながらない理由は大きく分けて二つあります。

返信メールにスレッド表示に必要なヘッダが含まれていない

一部のメールソフトは「返信」でメールを作成しても、スレッド表示に必要な情報をヘッダに記述してくれないものがあります。"References:"や"In-Reply-To:"ヘッダの有無を確認してみてください。

やりとりしているメールの送信日付(Date:ヘッダ）が前後している

相手かこちらのメール端末（パソコン）の時計が狂っている場合に、実際のメールの順番と送信日付（Date:ヘッダ）の順番が違ってしまうことがあります。この場合、スレッド表示に必要なヘッダがあってもBecky!内ではスレッド表示ができません。

それぞれの修復の方法は下記関連項目を参照してください。

また、emacs上で動作するMUA "Mew"からBccで送信されたメールは、タブシートの"0:ヘッダ"を見ても"References"フィールドがあるにも関らず、スレッドがつながってくれません。

これは、MewのBcc送信形式があまり見られない形式であることによります。「表示」-「ソースの表示」でメールの構造を見ると分かるのですが、実は":Content-Type: Message/rfc822"でメッセージが添付されていて、添付されている側の本文・ヘッダのみがタブシートに現れているのです。

しかし、Becky!のスレッド表示は、添付されている側ではなくメールそのものの"References"フィールドを見るので、スレッドがつながらないという状態になります。

解決法としては、Bccされたメールを「メール」-「添付メールを展開」してやれば無事にスレッドがつながります。

→ 関連項目
  • [20002] スレッド表示と修復
  • [06002] 日付が前後したメール間でもスレッドをつなげたい


ツリービューの未開封メール数表示がおかしい

Q. [02029] ツリービューの未開封メール数表示がおかしい

ツリービューでフォルダの未読数表示がおかしいです。起動時には実際と異なる数字が表示され（あるいは全く表示されず）、フォルダを開くと正しい数字になるようですが、次回の起動時にはやはりおかしい表示になってしまいます。

A. データフォルダのFolder.iniやFolder.idxなどが「読み取り専用属性」になっていないですか？たとえば、CD-R/Wにバックアップしたことがあるとファイル属性が変更されてしまいます。その場合、Becky!が設定を保存できません。

一括で「読み取り専用」属性を解除する方法は、関連項目を参照してください。

→ 関連項目
  • [11004] CD-Rにバックアップしたときの注意
  • [20001] Becky!のデータ保管形式


開封済みメールが未開封に戻ってしまう

Q. [02041] 開封済みメールが未開封に戻ってしまう

「修復」などでインデックス作成後、あるいは「送信日付で整理」の後、いくつかのメールが開封済みから未開封に変わってしまうのですが。

A. そのメールは、大きな添付ファイルが付いているなど、サイズが大きいメールではありませんか？その場合、未開封に戻ってしまうのは仕様上の理由によるそうです。

Becky!は、インデックスの内容は一部本体の方にも書き込んでいます。しかし、巨大なメールの場合には極端にパフォーマンスが落ちてしまいますので、3MB程度を目安に、インデックスの更新の際、本体は更新しないようにしているそうです。

ただし、そのような状態で、そのメールを移動したり、違うフォルダやメールボックスに移るなどインデックスを元に本体を書き直すような処理をすると、その時点での既読情報が本体に書き込まれます。

→ 関連項目
  • [02029] ツリービューの未開封メール数表示がおかしい


フォルダを開く時に時間がかかる

Q. [02048] フォルダを開く時に時間がかかる

フォルダを開く時にずいぶんと時間がかかり、１分以上も待たなくてはいけないことがあります。

A. 特定のフォルダでのみの現象の場合、そのフォルダで「ファイル」-「フォルダ」-「修復」を実行してみてください。

それで直らない場合、あるいは複数のフォルダで現象が生じる場合、ウィルス対策ソフトを導入し、常に監視させてませんか？この場合、Becky!がデータファイルを開く時にもウィルスチェックが働くせいで、動作が遅くなってしまうことがあります。

この場合、常時監視の対象からBecky!のデータフォルダ（通常はC:\Becky!以下のフォルダ）を除外することで動作スピードが通常に戻ります。


日本語入力中にウィンドウ表示がおかしくなってしまう

Q. [02026] 日本語入力中にウィンドウ表示がおかしくなってしまう

メール作成中、日本語を入力する時にメール作成ウィンドウが消えてしまい、日本語だけが浮き上がった状態になってしまいます。どのタイミングで起こるのかも分からないのですが、対処方法はあるでしょうか。

A. これは、一部の古いWindows95に起因する既知の問題ですが、残念ながらBecky!Ver.2の方では対応はしない予定だそうです。

同じWindows95環境でも、発生しない環境もありますので、インターネットエクスプローラなどを最新版にする事によってシステムファイルが更新されて、問題が発生しなくなる可能性もあります。しかし、はっきりした対処方法は判っていません。

なお、文字入力の際、マウスカーソルをツールバーの上に置いた状態でなければ現象は発生しないはずです。日本語入力時にマウスの位置に気をつけることで対応しましょう。


ニックネームの展開がうまくいかない時がある

Q. [02028] ニックネームの展開がうまくいかない時がある

アドレス帳の登録アイテムにニックネームを設定して、いつも便利に使っているのですが、時々ニックネームがアドレスに展開されない時があります。どうしてでしょう？

A. 複数の「アドレス帳」を登録していないですか？

「ニックネームの検索対象はアクティブになっているアドレス帳のみである」のが仕様だそうです。検索の高速性を考えたものでしょうね。

アクティブなアドレス帳というのは、基本的に一番上のアドレス帳です。また、「メールボックスの設定」-「メール作成」や「フォルダのプロパティ」-「一般」にある「アドレス帳」で指定することも出来ます。

極力アドレス帳を分けずに、グループをたくさん作って分類するという使い方を推奨します。


署名の前の一行が削除できない

Q. [02030] 署名の前の一行が削除できない

署名の前の行でDeleteキーを押した時や署名の先頭でBackSpaceキーを押した時に、署名直前の空白行の削除ができません。

A. Becky!Ver.2では、編集後の署名の交換などができるように、本文と署名の区切りを内部的に記憶しています（このため別の色で表示されているのです）。したがって、署名と本文の区切りとなる「署名の直前の改行」が簡単には削除できないのは仕様です。

まったく削除できないわけではなく、その行を選択状態にしてから削除すれば可能です。しかし、その後の署名の変更に支障がでますので、ご注意を。


文章の一部の色が変わってしまう

Q. [02036] 文章の一部の色が変わってしまう

メールを書いていると、一部の文字が紫や黄緑に表示されることがあります。また、本文中のある部分から文字が緑色になってしまうことがあるのですが、これらはどうしてなのでしょうか。

A. 一部の文字だけが（標準状態で）紫や黄緑に表示される場合、それはメールには使ってはいけない、あるいは使わない方がいい文字です。Becky!はそのような文字を色を変えて警告してくれているのです。どんな文字が問題なのか、あるいはその理由や色分けの仕組みについては、下記関連項目を参照してください。

また、ある部分からメール中の文章が緑になってしまうのは、おそらく「署名」中に文章を書いてしまっているのだと思われます。Becky!は「ここからここまでが署名である」という情報を保持しており、署名を変更する場合などに備えていますが、その領域は（標準状態で）緑で表示されるようになっているのです。そこを避けて文章を書くようにしましょう。

→ 関連項目
  • [30004] 使ってはいけない文字、使わない方がいい文字について


HTMLメール作成時にMS Office 2000のCD-ROMを要求されてしまう

Q. [02037] HTMLメール作成時にMS Office 2000のCD-ROMを要求されてしまう

A. Office2000より、その時点で必要になったモジュールを随時インストールする機能が追加されたのですが、それが仇となっているようです。モジュールの設定を変更して対処しましょう。

「コントロールパネル」-「アプリケーションの追加と削除」でMicrosoft Office2000を選び、「変更」-「機能の追加/削除」を行います。

「Microsoft Office2000 の機能の追加/削除」で「Officeツール」-「HTMLソース編集」が「初めて実行するときにインストール」になっているとこの症状が出ますので「HTMLソース編集」を「マイコンピュータから実行」か「インストールしない」に変更すれば CD-ROM を要求されなくなります。

但し、「マイコンピュータから実行」に変更する場合はOffice2000のCD-ROMが必要なので、これが手元に無い場合は「インストールしない」にしてください。


外部編集ツールの起動を検知できない

Q. [02039] 外部編集ツールの起動を検知できない

慣れたエディタでメールを作成・編集したいのですが、「外部編集ツールの起動を検知できませんでした」というメッセージが出て、うまく使うことができません。

A. 外部エディタの起動の検出は、タイトルバーに編集中のファイル名が含まれているウィンドウがあるかどうかで判断されます。お使いのエディタのタイトルバーに編集中のファイル名が表示されているか、確認してみてください。もし表示されていなく、かつ設定変更で対応できるエディタならば、そのように設定を変更しましょう。

また、MDIのエディタをお使いの場合は、メール作成ウィンドウの「ツール」-「外部編集ツールの設定」にて「MDI」にチェックを入れましょう。MDI（Multi Document Interface）とは親ウィンドウの中に文書ごとの子ウィンドウが開くタイプのアプリケーションです。たとえばDana、ＭＭエディタ、ＱＸエディタ、ViViなどが、有名なMDIのエディタです。この場合、「MDI」にチェックを入れないと、子ウィンドウのタイトルバーに含まれるファイル名を検出できないことがあります。

なお、文書ごとにウィンドウが開くタイプのアプリケーションはSDI（Single Document Interface）と言います。秀丸やWZ Editorが相当します。

Mule/Meadowは、標準では編集中のファイル名がタイトルバーに表示されません。設定を変更して表示されるようにする必要があります。.emacsに下記の一行を追加すると表示できるようになるそうです。

(setq frame-title-format "%b")


返信メール作成時に引用部分が文字化けしてしまう

Q. [02043] 返信メール作成時に引用部分が文字化けしてしまう

返信メールを作成しようとメール作成ウィンドウを開くと、引用の日本語部分が化けてしまう時があるのですが、どうしてでしょう？

A. 相手から送られてきたメールの文字コードがUNICODE(UTF-8)になってはいないでしょうか。そのようなメールに対して、返信テンプレートがISO-2022-JPで作成されている場合、引用文(%Mの部分)が文字化けをおこします。

これは様々な文字コードを扱う上で出てくる難しい問題です。日本語のメールはISO-2022-JPが主流ですが、徐々にUNICODE(UTF-8)によるメールも増えてきているようです。少なくとも現状では返信時にユーザーが気をつけて、下記のような回避策を取る必要があります。

  • UTF-8、あるいは英数字のみのテンプレートを作成し、それを使用する。
  • テンプレートを使用しない。


送信時に添付したはずのないファイルが添付されてしまう

Q. [02023] 送信時に添付したはずのないファイルが添付されてしまう

送信相手からファイルも添付されていると連絡があったのですが、心当たりがありません。なぜ勝手に添付ファイルが送信されるのでしょう？

メールを送った相手に、もう一通不明なファイルが添付されたメールが届いてしまうそうです。なぜでしょうか？

A. あなたのパソコンにはコンピュータウイルスに感染されている可能性が高いです。すぐにそのパソコンでのメール送信を中止して、下記関連項目を参照し、ウイルスチェックを行なって下さい。

→ 関連項目
  • [30006] コンピュータウイルスについて


[02025] Macからの添付ファイルが開けない

Q. [02025] Macからの添付ファイルが開けない

Macを使っている人から添付ファイルのあるメールを受け取りました。B2でダブルクリックしてもファイルが開けません。添付ファイルをデスクトップに保存しなおしてもやはり開けません。なぜでしょうか？

A. Macユーザから送られてきたメールが開けない理由はいくつかあります。

添付ファイルに拡張子がない場合

Windowsではファイルをどのアプリケーションで扱うか（開くか）は拡張子によってOSが判断します（拡張子の関連付け）。

一方、Macは必ずしも拡張子を必要としないため、Macで作成されたファイルの多くは拡張子がついていません。したがってWindowsは添付ファイルをどのアプリケーションで開くか判断できません。その場合の対処方法は２通りあります。

拡張子を補って保存しなおす

添付ファイルを右クリックして表示されるメニューから、「名前を付けて保存」を選択し、ファイル名に正しい拡張子を補い適当な場所へ保存しましょう。その後ダブルクリックすれば、補った拡張子に関連付けされたアプリケーションが起動しファイルを開いてくれるはずです。作成したアプリケーション（PhotoShopやMS-Wordなど）や保存の形式(Jpegやtextなど）を送信者に確認して、それに対応した拡張子を補ってください。

アプリケーションから開く

添付ファイルがどのアプリケーションで開けるかが明らかな場合は、Becky!上やエクスプローラ上でダブルクリックするのではなく、そのアリケーションを起動してから開く方法もあります。

拡張子の関連付けがない／正しくない

拡張子があっても、その拡張子にどのアプリケーションも関連付けされていない場合、ファイルをダブルクリックすると「ファイルを開くアプリケーションの選択」というダイアログが表示されてしまいます。自分が持っているどのアプリケーションで送られてきたファイルを開けるか、まずは確認してみてください。無い場合にはアプリケーションを入手する必要があります。

これはWindowsユーザから送られてきたファイルでも当てはまります。また、こちらから添付ファイル付きのメールを送る時には、相手がそのファイルを開くことができるアプリーションを持っているか確認しましょう。

一例として、MacOSでよく使われる圧縮ファイルに拡張子.sitがあります。Windows上でこのファイルを展開するソフトを導入していない場合は、この添付ファイルは開くことができません。

.sit(StuffIt形式)を展開できるWindows上のソフトは「AladdinExpander for Windows 5.1J」などがあります(無料)。

または、まったく別の機能を持ったアプリケーションに拡張子が関連付けされている場合にもこの添付ファイルが開くことができません。恐らくエラーとなることでしょう。

Macの管理情報により開けない

添付ファイルに、MacOS独自の管理情報が付加されていることが考えられます。

添付フィルの拡張子がアプリケーションに関連付けされていても、ファイルが持つMacOSの管理情報を判断（無視）できないと、この添付ファイルは扱えない（壊れている、開けない）と判断して、処理を中断することがあります。

その場合、Windowsには不要なMacOS管理情報を削除しましょう。B2から適当な場所へ保存した後、MacOS管理情報を削除するツールを使用して、不要な情報を削除すればいいでしょう。

そのような機能（MacBinaryとリソースフォークの除去）を持つソフトとして「Macバイナリー削除ユーティリティ」があります。登録料500円のソフトですが、除去などの基本機能は登録料を払わなくても使えます。

その他、Windows-Mac間のデータのやりとりには様々なソフトが公開されています。 Vectorの「Windows95/98 > ユーティリティ > Macintosh関係」ページを参照してみるといいでしょう。


添付ファイルを読み取り専用で開いてしまう

Q. [02031] 添付ファイルを読み取り専用で開いてしまう

メールの添付ファイルを開くと、読み取り専用（参照用、上書き禁止）で開いてしまいます。もらったファイルを編集したいことがあるのですが。

A. Becky!Ver.2では添付ファイルのデータはメールと一緒に保存され、開く時にディスク上の一時フォルダに書き出されるようになりました。参照した後は削除されてしまうため、編集しても意味がありませんので、読み取り専用属性の付いたファイルとして書き出されます。

添付ファイルを編集したい場合は、いったん「名前をつけて保存」やドラッグアンドドロップでディスク上に保存してから編集してください。

添付元のメールに編集を反映することは、基本的にはできません。

→ 関連項目
  • [05002] 添付ファイルの保管場所はどこ？
  • [20001] Becky!のデータ保管形式


送信した添付ファイルが壊れてしまう

Q. [02045] 送信した添付ファイルが壊れてしまう

相手に送った添付ファイルが壊れているといわれます。自分あてに送ってみると、送信済みのものと受信したものでファイルサイズが違ってしまうのですが。

A. ネットワークカードによってそのような症状が報告されています。おそらくドライバの不具合だと思われます。

問題が起きやすいネットワークカードの例や対処方法は下記関連項目を参照してください。

→ 関連項目
  • [02038] 送受信時にBecky!がエラーを起こしてしまう


印刷時に文字化けしてしまう

Q. [02044] 印刷時に文字化けしてしまう

メッセージビューでは正常に表示されるのに、印刷プレビューや実際の印刷では文字化けしてしまうのですが、どうしたらいいのでしょうか。

A. そのメールはUNICODEを利用したUTF-8あるいはUTF-7という文字コードではないでしょうか。ウィンドウ下部の地球アイコンをクリックして確認してみてください。

それが理由の場合、Becky!ではVer.2.00.04以降でUTF-8の印刷に対応しました。お使いのBecky!のバージョンを確認して、古い場合には最新版に更新して下さい。


受信したメールを開かず捨てるには

Q. [02046] 受信したメールを開かず捨てるには

ウィルス付きのメールを受信してしまいました。表示すると感染してしまうそうですが、メールを表示せずに捨てる方法はないでしょうか。

A. まず、「表示しただけで感染するウィルスメール」とはたいていHTMLメールを利用しています。「全般的な設定」-「メール表示」の「MSIEコンポーネントを使う」とオフにしましょう。この場合、HTMLメールはソース表示されるので、ウィルスは実行されなくなりますので、そのメールを開いても大丈夫です。

その上でDeleteキーやツールバーのＸボタンを押して削除しましょう。Shiftキーを押しながら行なえば、ごみ箱にも送られず直接削除されます。

また、どうしても不安で開きたくない場合、そのメールを挟みこむように複数メールを選択すれば、開かずにゴミ箱送りにできます。

  1. 件のメールの上のメールをクリックして開く。
  2. 件のメールの下のメールを、Shiftキーを押しながらクリックして開く。
  3. すると件のメールを挟んで一連のメールが選択されますので、DeleteキーやツールバーのＸボタンを押してゴミ箱に送れます。

ただし、必要なメールをゴミ箱から戻す際に、件のメールが表示されてしまうことがありますから、注意が必要です。下記の手順で戻しましょう。

  1. 元のフォルダに戻したいメールを選択する。Ctrlキーを押しながらのクリックで必要なメールを飛び飛びに選択できます。
  2. 「編集」-「コピー」。
  3. 元のフォルダを開いてから「編集」-「貼り付け」。これで元のフォルダに必要なメールがコピーで書き戻されます。
  4. あとは「ファイル」-「ごみ箱を空にする」を実行すれば、ごみ箱からも完全に削除されます。

→ 関連項目
  • [30006] コンピュータウィルスについて
  • [30007] HTMLメールとは


アンチウィルスソフト利用時にメールが消失してしまう

Q. [02049] アンチウィルスソフト利用時にメールが消失してしまう

ウィルス対策ソフトのメール送受信時のウィルスチェック機能を利用しているのですが、実際にウィルス付きのメールが検出された時に、Becky!の受信箱のメールが一部消失してしまいました。どうしたらいいでしょう？

ウィルス付きメールを受信したので削除しようとしたところ、ウィルス対策ソフトのウィルス検出に引っかかった直後に、Becky!のメールデータが破損してしまいました。

A. ウィルス対策ソフトを導入しており、かつBecky!が2.00.08より古いバージョンであるか、最新版でも適切に設定されていない場合に起きる現象です。

ウィルス付きのメールを受信してしまった時、ウィルス対策ソフトによって、Becky!が使用中のデータファイルがロックされたり削除されてしまったりすることがあります。その結果Becky!のデータの整合性が崩れたり、同じファイルに保存されていた別のメールも一緒に無くなってしまうというトラブルが発生するのです。

残念ながら一度失ってしまったデータは復活が難しいです。バックアップログに残っている分を再度取り込むしかないでしょう。

複数のウィルス対策ソフトで同種の現象が起きているようですし、けっきょくアプリケーション（この場合はBecky!）の動作を横取りするという、現在のウィルス対策ソフトの制限とも言えましょう。この問題に対応するには下記の２つの方法があります。

まず、お使いのBecky!のバージョンが2.00.07以前のものである場合、最新版にバージョンアップしましょう。Ver.2.00.08以降では、ある程度以上のサイズのメールを単独のファイルとして保存することで、無関係なメールが巻き添えで消失しないように対策されています。今後のためにも最新版にしておきましょう。なお、単独で保存する目安は「ツール」-「全般的な設定」-「高度」の「？KB以上のメールは１ファイルで保存」オプションで設定できます。初期値は16KBですが、それより小さいウィルスもあるという報告もありますし、6KB程度に設定し直しておく方がいいかもしれません。

次にウィルス対策ソフトの設定を変更し、ウィルスチェックをする対象からBecky!が利用するいくつかのファイルやフォルダを除外しておく方法も有効です。

データフォルダ（初期状態ではC:\Becky!以下のフォルダ）を常時監視から除外

ウィルスチェックをデータフォルダに対しても常時行なっていると、メールフォルダを開く時に時間がかかるようになることがあります。

<テンポラリフォルダ>\B2Temp以下にある拡張子が「.tmp」のファイルも除外

Becky!内でメール操作をする時に書き出される一時作業用ファイルです。このファイルが常時監視の対象になっていると、たとえばウィルスが含まれているメールを移動しようとした時に、ウィルス対策ソフトが一時ファイル中のウィルスを検出してメール移動が正常に行われず、結果としてメールデータが壊れてしまうことがあります。

テンポラリフォルダとは環境変数tempに指定されたフォルダですが、もし場所がわからないければスタートメニューの「検索」-「ファイルやフォルダ」から「B2Temp」を検索してみましょう。

ただし、除外指定をするのはあくまで拡張子が「.tmp」というファイルだけです（ワイルドカードを使って"*.tmp"と指定しましょう）。誤ってB2Tempフォルダ全体などを指定してしまうと、今度は添付ファイル実行時にウィルスチェックが働かなくなってしまいますのでご注意を。

メール送受信時のウィルスチェックを無効にする

送受信に時間がかかるようになり、また実際にウィルスが送られてきた時に送受信が滞り、前述のように受信データが壊れてしまうことがあります。この機能の利用をあきらめるか、あるいは利用するならこれらのリスクを覚悟しておきましょう。

これらを除外・無効にしても、たとえばウィルス付きの添付ファイルを実行する際にはテンポラリフォルダにファイルが生成された時に常時監視に引っかかるので、ウィルスの感染を防ぐことは可能です。

ウィルスも実行せず単にファイルに保存しておく分には問題とはなりませんし、データが消失しては元も子もありません。ウィルス対策ソフトにも頼り過ぎずうまく扱う方がいいでしょう。

→ 関連項目
  • [30006] コンピュータウィルスについて
  • [30007] HTMLメールとは


起動できません

Q. [02014] 起動できません

A. Windows95をお使いではないですか？Becky!Ver.2はシステムファイル（Comctl32.dll）が古い（4.72以前）と起動できないそうです。

インターネットエクスプローラの最新版を入れるのが一番の解決策ですが、「それは好かない」というMS嫌いな方でも、せめてComctl32.dllは新しいものを入れておきましょう。左のリンクが古い場合でも、MicrosoftのTopページから「Comctl32.dll」を検索すれば、最新の配布版を探せると思います。

これ以外は特に決まった原因はないようです。なるべく具体的な現象（エラーメッセージなど）を明記の上、サポートメーリングリストやサポートBBSに報告しましょう。ヘルプの「サポートについて」の項を参照してください。


Becky!が強制終了されてしまいます

Q. [02006] Becky!が強制終了されてしまいます

A. Becky!は非常に安定したアプリケーションソフトですが、様々な状況で使われている以上、残念ながらエラーが起きて強制終了されてしまうことがあります。

原因は様々で一概には判断できないのですが、下記のような事項に注意してみてください。

特定のメールを表示する時やフォルダを開いている時に起きる場合

「ファイル」-「フォルダ」-「修復」を実行してみましょう。メールデータが壊れているのかもしれません。

プラグインを確認

便利なプラグインですが、そちらに不具合がある可能性もあります。エラーが起きた時のダイアログで「詳細」ボタンを押して、どのモジュールでエラーが発生しているかを確認してみてください。「?????.dll」というプラグイン本体のファイルでエラーが起きている場合、そのプラグインが原因である可能性が高いです。プラグインを読み込まないように、あるいはPluginsフォルダから削除してみてください。そのプラグインが最新版でない場合、最新版を入手してバージョンアップしてみましょう。

また、複数のプラグイン同士の相性で生じる場合もあります。すべてのプラグインをいったん外してみてから、一つずつ組み込んで確認してみましょう。

ドライブの残り容量を確認

データフォルダがあるドライブの残り容量を確認しましょう。残り容量がなくなってしまっている場合、Becky!はデータを書き込めずに強制終了されます。これが原因の場合、必要のないアプリケーションをアンインストールする、データフォルダを別ドライブに移すなどの対策で、書き込める容量を確保しましょう。

→ 関連項目
  • [11001] データフォルダの容量を節約したいのですが

ふるかわあきひとさんの「DiskSpaceプラグイン」を用いると、Becky!使用時にドライブの残り容量を確認し、設定した容量より少ない時には警告してくれます。

ドライブやWindowsのシステムが壊れていないか確認

ドライブのエラーチェックをしましょう。「マイコンピュータ」から各ドライブのプロパティを表示し「ツール」-「エラーチェック」を実行すると「スキャンディスク」が起動します。

あまりにエラーが多い場合には、ドライブの初期化をしてWindowsの再インストールを行った方がいいかもしれません。

Becky!を最新版に

Rim-Artsの公式ページにてBecky!の最新バージョンを確認し、お使いの版が古い場合にはぜひバージョンアップしましょう。不具合が修正されている可能性もあります。すでに最新版をお使いでも、上書きインストールをすることで状況が改善されるかもしれません。

各種ドライバを最新版に

ディスプレイドライバやLANカードのドライバの不具合で動作がおかしくなることもあります。各メーカーのWEBサイトから最新版のドライバを入手してみましょう。

→ 関連項目
  • [02038] 送受信時にBecky!がエラーを起こしてしまう
Windowsに不具合修正版を適用

Windowsにも不具合があります。Microsoftからサービスパックや各種不具合修正モジュールを入手し、適用しましょう。

上記の作業を行っても改善されない場合

もし同じ操作を何回行なってもエラーが生じるなら、Becky!の不具合かもしれません。同様の症例がないかサポートBBSで検索してみましょう。それでも見つからない場合は、再現手順の詳細とお使いの環境（WindowsやBecky!、プラグインのバージョン等）を明記の上、サポートMLやBBSに報告しましょう。


メールが消えてしまった

Q. [02015] メールが消えてしまった

あるフォルダに入っているはずのメールが見当たりません。どうしたらいいでしょうか？

A. まずはメールの消えたフォルダを開いて「ファイル」-「フォルダ」-「修復」を実行してみましょう。メールのデータが残っていれば、インデックスファイルを再度生成することで見えるようになります。

※この時、他のメニュー（「送信日付で整理」、「コンパクト」、「重複メールを削除」、「フォルダメンテナンスコンボ」）を間違えて実行しないように注意して下さい。残っているデータを消してしまう可能性があります。

「修復」を実行してもメールが復活しない場合は、残念ながら、完全にメールのデータが無くなってしまったということかもしれません。パソコン上でデータを扱っている限りデータが壊れるということは起こり得ますし、もちろんBecky!の不具合という可能性もあります。

その場合でも、送受信メールのバックアップログを取ってあれば「ファイル」-「バックアップログから取り込み」を実行することで、消えたメールを再度取り込むことも可能です。しかし、バックアップログが無い場合は・・・、残念ですがあきらめましょう。

無くなってしまってからでは遅いのですが、こういう事態に備えてデータのバックアップを普段から行っておきましょうね・・・。

→ 関連項目
  • [11002] データフォルダの中の日付が名前のファイルは何？
  • [11003] データのバックアップと復旧


データフォルダがどこかにいってしまった

Q. [02016] データフォルダがどこかにいってしまった

エクスプローラでファイルを直接編集しようとしているうちに、フォルダそのものをどこかに移動してしまったようです。メールデータがBecky!内から無くなってしまい、とても困っています。どのようにして以前のメールを復活させたらいいでしょうか。

A. まず、以前のメールデータがどこかにあるか探してみましょう。

標準ではデータフォルダは
"C:\Becky!\あなたのログオンユーザー名"
というフォルダにあるはずです。

どうしても見つけられない場合、データフォルダにかならず存在する"B2.ini"というファイルを検索しましょう。

  1. スタートボタンの「検索」-「ファイルやフォルダ」を選択。
  2. 「ファイルまたはフォルダの名前」に"B2.ini"と入力。
  3. 「探す場所」は「マイコンピュータ」もしくは「ローカルハードドライブ」を選択。
  4. 「検索開始」。

B2.iniが見つかったら、そこにお望みのデータがあるか確認しましょう。関連項目を参照して、フォルダ構成を確認してみてください。

それでもデータが見当たらない場合は、残念ながらメールデータを無くしてしまったということかもしれません。

運良くデータが見つかった場合、そのフォルダをあなたの使いたい場所に移動しましょう。その上でBecky!にて「ファイル」-「システム」-「データフォルダの変更」を実行して再起動、B2.iniがあるフォルダを指定すれば、以前のデータがBecky!内で読めるようになるはずです。

→ 関連項目
  • [20001] Becky!のデータ保管形式


ツールバーの表示がおかしい

Q. [02017] ツールバーの表示がおかしい

ツールバーの表示がおかしいです。グレーになっているアイコンの部分が窪んでいるようにみえたりします。

A. 一部のビデオチップやディスプレイドライバの不具合でこういった症状が起きるようです。下記の対策で改善されることもあります。

  • コントロールパネルから、「画面のプロパティ」→「設定」→「詳細」→「パフォーマンス」のハードウェアアクセラレータ（あるいは類似の設定項目）の設定値を下げる。
  • 同じく「画面のプロパティ」→「ディスプレイの設定」にて、画面の解像度や色数を変更する。
  • ディスプレイドライバを新しいものにする。メーカーのWEBページで探してみましょう。


起動パスワードを受け付けられず、Becky!を使えない

Q. [02018] 起動パスワードを受け付けられず、Becky!を使えない

起動パスワードを設定しているのですが、うっかり忘れてしまってBecky!を使うことができなくなってしまいました。助けてください。

設定したはずがないのに、起動パスワードの入力を求められて困っています。このままではBecky!を使うことができません。

A. まれに何らかの原因で設定がおかしくなり、設定していないはずの起動パスワードを求められてしまうこともあるようですね。

設定したはずのパスワードが受け付けられない場合、まず、キーボードのCapsLockがONになってしまっていないか、あるいは日本語入力IMEがONの状態でパスワードを入力してないか確認してみてください。

どうしても受け付けられない時は、Becky!をコントロールパネルの「アプリケーションの追加・削除」からアンインストールし、再度Becky!をインストールしましょう。設定がクリアされて、Becky!を起動できるようになるはずです。今まで使っていたデータフォルダを指定すれば、メールやアカウント情報、アドレス帳などの大部分のデータが問題なく復活します。「全般的な設定」の一部の情報だけ再度設定し直してやればOKです。

万が一その方法でも駄目な場合は、他のメールソフトを用意し、B2-FAQ-WG<b2-faq-wg@becky-users.net>宛にメールで問い合わせてください。対応策をお教えします。


メールサーバーのパスワードを忘れた

Q. [02019] メールサーバーのパスワードを忘れた

パソコンの入れ換えを機にBecky!の設定をやり直そうと思うのですが、うっかりメールサーバーのパスワードを忘れてしまいました。今まではBecky!が記憶してくれていたので問題なかったのですが。どうしたらいいでしょう。

A. そうならないように、アカウント情報などはしっかりメモを取っておきましょうね。

残念ながら、忘れてしまったものはどうしようもありませんので、ネットワーク管理者やインターネットプロバイダにお願いして、教えてもらうか初期化してもらいましょう。

ここだけの話、パスワード設定欄からパスワードを読み取ってくれるソフトもあります。たとえばTietewさんの「GetEdit」（Junk Software内）やikeさん作のシェアウェア「チューチューマウス」の「みえみえパスワード」機能、CHOMBOさん作の「AltIME」など。これらを使えばBecky!でも読み取りは可能だと思います。言うまでもありませんが、悪用は無しということで。


ウィンドウが最大と最小でしか表示できなくなった

Q. [02021] ウィンドウが最大と最小でしか表示できなくなった

Becky!のウィンドウ（あるいはメール作成ウィンドウ）の大きさが「最大化」と「最小化」のみになってしまいました。最大化状態で「元のサイズに戻す」を押すと最小化になってしまいます。タスクバーの上で右クリックすると「元のサイズに戻す」が選べない状態になっています。

A. 実は最小化ではなく元のサイズに戻っているのですが、なんらかの理由で、画面からはみ出たところにBecky!のウィンドウが表示されているのだと思われます。

まずは下記手順をおためしください。画面にウィンドウが戻ってくることがあります。

  1. Becky!を起動
  2. ウィンドウを「元のサイズに戻す」(と、表示されなくなる)
  3. タスクバーのBecky!の右クリックメニューから「移動」を選ぶ
  4. どれでもいいので矢印キーを押す
  5. マウスを動かす

これで修復できなかったら、Imabeppuさん作の「B2PosInit」というツールを使ってみましょう。ウィンドウサイズを初期化、修正してくれます。

ウィンドウサイズの修正はレジストリを操作することでも可能です（「B2PosInit」はこの操作を自動でやってくれているのです）。もし手作業で行ないたい場合、レジストリエディタでBecky!のウィンドウ位置設定を書き換えましょう。

左側のツリーでたどっていき、右側のペインに出てくる以下の項目を消してみてください。\マークは階層の区切りです。

画面に表示されないのがBecky!のメインウィンドウの場合
  • HKEY_CURRENT_USER\Software\RIMArts\B2\Window\MainTop
  • HKEY_CURRENT_USER\Software\RIMArts\B2\Window\MainLeft
画面に表示されないのがメール作成ウィンドウの場合
  • HKEY_CURRENT_USER\Software\RIMArts\B2\Window\CompX
  • HKEY_CURRENT_USER\Software\RIMArts\B2\Window\CompY
画面に表示されないのがアドレス帳の場合
  • HKEY_CURRENT_USER\Software\RIMArts\B2\Window\AddrX
  • HKEY_CURRENT_USER\Software\RIMArts\B2\Window\AddrY


クリッカブルURLを使うとBecky!がフリーズする

Q. [02022] クリッカブルURLを使うとBecky!がフリーズする

メール中に書いてあるURL（ホームページのアドレス）をクリック（あるいはダブルクリック）してブラウザで見たいと思ったのですが、Becky!が固まってしまいます。

A. Internet ExplorerやNetscape Navigatorといったブラウザの関連付けがおかしくなってしまい、外部（この場合はBecky!）からうまく起動できないことがあります。するとBecky!はブラウザが起動するのを待ちつづけ、動かなくなってしまうようです。

解決策としては、まず「全般的な設定」の「メール表示」「URL/E-Mailのアクション」で「DDEを使う」オプションのチェックを外してみてください。DDEというのはアプリケーション間の情報のやりとりの仕組みですが、これに絡んだOSの不具合が関係することもあるようです。

それでも駄目な場合は、ブラウザを再インストールしてみてください。再度Windows内でHTTPプロトコルなどとの関連付けが行われ、修正されることがあるようです。


勝手にダイヤルアップされてしまう

Q. [02010] 勝手にダイヤルアップされてしまう

ダイヤルアップ環境でBecky!を使っているのですが、使用中に時々Becky!が勝手にダイヤルアップ接続を行ってしまいます。自分が必要としている時意外は勝手に接続して欲しくないのですが。

A. Becky!が接続しようとするのは下記の２通りの場合があります。それぞれ、設定が適切に行われていれば、問題はなくなるはずです。

Becky!が定期チェックを実行しようとする時に接続
  • 「全般的な設定」-「受信」-「巡回メールチェック」の「ダイヤルアップ接続中のみチェック」がチェックされているか。
  • 「メールボックスの設定」-「受信」-「メールチェック」の「ダイヤルアップ接続中のみチェック」がチェックされているか。
  • 使用中の「メールボックスの設定」-「接続」が「LAN接続」になってしまっていないか。
HTMLメール表示の際に接続

HTMLメールを表示する時に、そのメール中に外部サイトにある画像が貼り込んであると、ダイヤルアップ接続を実行して取得しようとすることがあります。「全般的な設定」-「メール表示」-「HTMLメール表示」の「オフラインモード」にチェックを入れると回避できます。


クリッカブルURLでNetscape 6が２つ開いてしまう

Q. [02032] クリッカブルURLでNetscape 6が２つ開いてしまう

メール中のURLを開こうとすると、Netscape6のウィンドウが2つ開いたり、IEとNetscapeの両方が開いたりします。

A. Becky!以外のアプリケーションから開く時も同様の症状が起きることがあるそうで、どうもNetscape 6の不具合と思われます。Becky!側からの対応は難しいようです。

ただし、Tietewさんの「Powerful Customizer Plug-in」を利用して、ブラウザの関連付けによる起動ではなく明示的にNetscape 6を指定してやると、このトラブルを避けられるそうです。


設定を変更しても保存されない

Q. [02033] 設定を変更しても保存されない

「全般的な設定」や「メールボックスの設定」、フォルダの「プロパティ」などで各種設定を変更しても、次回のBecky!起動時には元に戻ってしまいます。

A. データフォルダのMailbox.iniやFolder.iniといった設定保存ファイルが「読み取り専用属性」になっていないですか？たとえば、CD-R/Wにバックアップしたことがあるとファイル属性が変更されてしまいます。その場合、Becky!が設定を保存できません。一括で「読み取り専用」属性を解除する方法は、関連項目を参照してください。

また、「メールボックスの設定」-「接続」の「ダイヤルアップ」関係の設定が保存されない場合、ダイヤルアップネットワークの接続名に不正な文字が含まれている場合があります。「マイコンピュータ」の「ダイヤルアップネットワーク」にて、お使いのダイヤルアップ設定の名前を変更（空白や記号を除くなど）して試してみてください。

→ 関連項目
  • [11004] CD-Rにバックアップしたときの注意
  • [20001] Becky!のデータ保管形式


エクスポートしたメールの日本語が化ける

Q. [02035] エクスポートしたメールの日本語が化ける

メールを「ファイル」-「エクスポート」でファイルに書き出したのですが、開いてみると日本語が化けてしまって読めません。

A. 現在、日本語のメールはISO-2022-JPという規格が主流ですが、これは文字コードとしてはJISコードを大部分採用しており、パソコン上で主流の文字コード（Shift-JIS）とは異なります。

Becky!Ver.2は受信したメールはそのまま保管するようになりました。Ver.1の頃は日本語はShift-JISに変換されていましたが、より多言語を扱いやすい仕様に変更されたのです。

そして、エクスポートとはメールをそのまま書き出す機能ですから、つまり書き出されたファイルの日本語はJISコードであるということになるのです。

これを解決するには二つの方法があります。

書き出したファイルを開くのにJISコード対応のアプリケーションを使いましょう。秀丸やDanaといった高機能エディタはたいていJISコードを扱えます。また、いちいち指定せずとも文字コードの自動判別を備えていることも多いです。

そもそもShift-JISで書き出したいという場合、上村さん作の「Shift-JIS Export PlugIn」を使いましょう。その名の通り、メール中の日本語部分をShift-JISに変換してから書き出してくれるプラグインです。


未送信メールがないのに終了時に警告が出てしまう

Q. [02040] 未送信メールがないのに終了時に警告が出てしまう

Becky!を終了させようとすると、送信箱にメールが入っていないのに「未送信のメールが送信箱に残っています。このまま終了してよろしいですか？」というメッセージが出てしまうのですが。

A. 実データとインデックスの不整合により、そのような症状が起きることがあるようです。送信箱を表示している時に「ファイル」-「フォルダ」-「修復」を実行してみてください。過去に送信に失敗したことがあるメールが現れることがあります。

うまくいかない場合には、下記関連項目を参照して、データフォルダの草稿箱の実体フォルダの中身をすべて削除してください。

→ 関連項目
  • [20001] Becky!のデータ保管形式


Becky!の起動に時間がかかる

Q. [02047] Becky!の起動に時間がかかる

最近、Becky! の起動が遅くなった気がするのですが何故でしょう？

A. Becky!は起動時にメールボックスやフォルダ、組み込んであるプラグインをチェックするため、これらの数が起動時間に影響します。まず不必要なメールボックスやフォルダを作らない方がいいでしょう。また、プラグインの影響は容易に体感されるほど大きいようです。

Becky! は「全般的な設定」-「高度」-「プラグイン」で選択されているプラグインを起動時に全て読み込みます。トラブル防止の意味からも不要なプラグインは選択解除しておく事をお勧めします。


宛先毎に署名や名乗り、Fromアドレスを変更したい

Q. [03001] 宛先毎に署名や名乗り、Fromアドレスを変更したい

宛先に応じて、署名や挨拶、名乗り、こちらの送信メールアドレスを変更したいのですが、可能ですか？

A. フォルダの「プロパティ」を利用することで可能です。

Becky!ではその時開いているフォルダによって、メールを書く時の宛先アドレスやFromアドレス、署名などを指定できます。テンプレートを指定すれば、挨拶や名乗りをあらかじめ決めておくことも可能です。

たとえばメーリングリスト用のフォルダをあらかじめ作っておき、Becky!の強力な振り分け機能を使って、投稿されたメールは常にそのフォルダに振り分けられるように設定しましょう。その上でフォルダの「プロパティ」にて、そこで書くメールの設定を行っておきましょう。以降は新規にメールを書くのも返信するのも、そのフォルダを開いている時に行えばお望みどおりです。

初心者にはとっつきにくいテンプレートですが、使ってみると意外に簡単に作れます。まずはヘルプの「高度な使い方」-「テンプレートを使う」を参照してみてください。

また、Ｔ∀Ｋさん作の高機能テンプレートプラグイン「Advanced Template plug-in」を利用すれば、フォルダごとではなく宛先アドレスに応じたテンプレートの変更も可能です。Pascalという言語を用いるので最初は難しいですが、使いこなせるようになると便利ですよ。

→ 関連項目
  • [10001] 「プラグイン」とは何ですか？


文字の大きさ・色の変更や画像貼り付けの方法は？

Q. [03002] 文字の大きさ・色の変更や画像貼り付けの方法は？

メールの中の重要な箇所を強調したいのですが、文字の色や大きさをそこだけ変更できますか？また、友達にきれいなメールを送りたいので、背景の色を変えたり画像を貼り付けたりしたいのですが。どうすればいいでしょうか。

A. Becky!で通常、作成・送信するメールは、文字装飾や色などの属性がまったくない「プレーンテキスト」のメールです。文字装飾や画像貼り付けを行うにはHTMLメールというものを作成する必要があります。Becky!はVer.2にてHTMLメールの作成・送信機能をサポートしました（受信・表示は以前より対応しています）。

詳しくは下記関連項目を参照してみてください。

→ 関連項目
  • [30007] HTMLメールとは


メールにBGMを添付したい

Q. [03003] メールにBGMを添付したい

相手がメールを開いた時に、BGMが自動で流れるようにしたいのですが。

A. HTMLメールなら好みのMIDI・WAVEファイルをBGMにすることができますね。HTMLの作成・送信をサポートしたBecky!Ver.2でも可能です。当然のことながら、相手がHTMLメールの表示ができるメールソフトを使っていないと意味がありませんのでご注意を。

ただし、わかりやすくBGMを挿入するコマンドはありませんので、HTMLメール作成モードでHTML用ツールバーの右端のボタンを押して、「ソースの編集」モードにし、自分でHTMLを編集する必要があります。

具体的には<BODY>タグの後ろに

<BGSOUND src="音楽ファイルのフルパス">

と書きこめばいいです。Becky!が音楽ファイルを自動で添付し一緒に送ってくれます。また、ファイルのフルパスと言われてもわからない場合、もしくは手入力では面倒という向きは、

<BGSOUND src="">

とだけ書き込むという手段もあります。すると、そのメールを送信箱や草稿フォルダに収める時にBecky!が

「イメージファイル""が見つかりません。（中略）ファイルを自分で選択しますか？」

と問い合わせてきます。そのダイアログで「はい」を押すと、ファイル選択ダイアログが開きます。ただし、画像選択用なので初期値ではJPEGあるいはGIF、PNGといったファイルしか表示できませんので、「ファイル名」欄に「*.mid」や「*.wav」を書き込んで「開く」を押しましょう。すると目的のファイルを表示・選択可能になります。

BGMを表示中繰り返し演奏させたい時は、

<BGSOUND src="音楽ファイルのフルパス" loop=infinite>

とすればいいです。"infinit"を数字に変更すれば、その数字の回数だけ繰り返し演奏になります。

また、安藤亮太さん作の「BkMIDIプラグイン」を組み込んであると、プレーンテキストのメールでも、添付されているファイルがMIDIファイルである場合には自動で演奏してくれます。当然、相手もBecky!Ver.2を使っていてBkMIDIプラグインを組み込んでいることが必要ですが、そのような相手とは簡単にBGM付きのメールのやりとりができて楽しいですね。

→ 関連項目
  • [30007] HTMLメールとは
  • [10001] 「プラグイン」とは何ですか？


署名を固定ピッチフォントで作りたい

Q. [03004] 署名を固定ピッチフォントで作りたい

署名のレイアウトを整えるために固定ピッチフォントで作成したいのですが、「メールボックスの設定」-「署名」の作成欄はプロポーショナルフォントのようですね。不便なのでここを固定ピッチフォントにしてもらえるといいのですが。

A. 「メールは固定ピッチフォントで読まれるとは限らない」ということに基づいた作者さんのポリシーもあって、プロポーショナルフォントでの作成欄になっているようです。

確かに送信先の相手に固定ピッチで読まれることを期待しない方がいいのですが、それでもという方は、メール作成ウィンドウでの「ファイル」-「選択範囲を署名として保存」機能を使いましょう。固定ピッチフォントでメール表示を行っていればこれで目的が達せられるでしょう。

また、Tietewさん作の「Becky! 2 Powerful Customizer」で「署名」欄のフォントを変更できます。このプラグインを導入して、「署名」欄のフォントを「MS ゴシック」などの固定ピッチフォントに変更しましょう。

→ 関連項目
  • [02024] 文字で書かれたイラストや地図がズレて表示される
  • [10001] 「プラグイン」とは何ですか？


「全員に返信」の時、元の差出人以外もTo:に入れたい

Q. [03005] 「全員に返信」の時、元の差出人以外もTo:に入れたい

「全員に返信」を実行すると、元メールの差出人のみ返信メールのTo:に入り、元メールの宛先アドレスはCc:に入ってしまいますが、返信メールではすべてTo:に引き継がれるようにしたいのですが。

A. MASAさん作の「れすお～る」プラグインを用いるとお望みのように動作を変更できます。


宛先に敬称を付けたい

Q. [03006] 宛先に敬称を付けたい

To:やCc:などの宛先に"別倉恋太郎様 <koitaro@tosan>"のように敬称や相手の役職を付けたいのですが。

A. まずこちらから新規で送るメールについては、アドレス帳の「宛先名」に敬称付きで登録しておきましょう。

あるいはアドレス帳にて「ツール」-「入力形式」-「mail@address」を選択することで、送信宛先をメールアドレスのみにしてしまい、そもそも敬称や役職を気にせずにすませるという手段もあります。

ただし返信時は返信元メールのFrom:などの記述が利用されてしまい、上記の設定が反映されませんが、下記のプラグインを使うことで宛先の記述を変更できるようになります。

返信宛先をアドレス帳に登録されている本名に置き換える

ゆーちさん作「BkReplyer」

返信宛先をメールアドレスのみにする

よしずみさん作「DelName」

Masaさん作総合返信用プラグイン「れすお～る」

→ 関連項目
  • [10001] 「プラグイン」とは何ですか？


Outlook Expressの「ひな形」を使う方法

Q. [03007] Outlook Expressの「ひな形」を使う方法

A. 下記の手順で可能です。

  • Becky!のメール作成ウィンドウでHTMLメール編集モードにしましょう。
  • ソース編集モードにします。下部ツールバーの右端のボタンを押しましょう。
  • すでに書いてある内容は、すべて削除。「編集」-「すべて選択」の後、「編集」-「カット」。あるいは、Ctrl+Aの後、Deleteというキー操作でも可能です。
  • 「編集」-「特殊なコピー／貼り付け」-「ファイルから貼り付け」を実行しましょう。
  • 出てきたファイル選択ダイアログから、ひな形のファイルを探しましょう。通常
    "C:\Program Files\Common Files\Microsoft Shared\Stationery\"
    に存在するようです。
  • その中の「ひな形名.HTM」というファイルを指定すればOKです。
  • 再度、下部ツールバーの右端のボタンを押し、ソース編集モードから戻りましょう。

ソース編集モードから戻った直後は画像が表示されていませんが、いったん草稿箱や送信フォルダに収めると画像もHTMLメールに付加されます。


複数のプロファイルで同時にメールチェックしたい

Q. [04001] 複数のプロファイルで同時にメールチェックしたい

メールボックスに複数のプロファイルを設定しているのですが、そのうちのいくつかのプロファイルは定期チェック時や手動受信の際に同時に受信したいのですが。

A. 「メールボックスの設定」にて、同時に受信したい全てのプロファイルで「受信」-「他のプロファイルのPOP3サーバーも含めて受信」にチェックを付けましょう。

ただし、あるプロファイルだけ受信間隔を変えるということはできません。今現在つかわれているプロファイルの時間間隔に従って定期チェックが行われるようです。


PostPetからのメールをサーバーに残したい

Q. [04002] PostPetからのメールをサーバーに残したい

PostPetも使っているのですが、ペットが運んできたメールはBecky!で受信したくないのですが。受信せずにサーバーに残す方法はあるでしょうか。

A. 「ツール」-「フィルタリングマネージャ」を使って、特定のメールをサーバーに残すことができます。フィルタリングマネージャの「アクション」にて左側の欄を「フィルタ」にし、その右側の欄で「サーバーに残す」を選択して、下記の条件を追加して下さい。

PostPetからのメールの判別は
「X-Mailerヘッダに"Postpet"という文字が含まれているメール」
という条件で可能です。しかしこれではポストマンが持ってきた普通のメールも該当してしまいますので、さらに
「Content-Typeヘッダに"***kiritorisen***"という文字列が含まれているメール」
という条件を「絞り込み」で追加することで、ペットが持ってきたメールのみをサーバーに残すことが可能です。ただし残念ながらこの設定でも、ポストマンが持ってきた添付ファイル付きのメールもサーバーに残ってしまいます。

「フィルタリングマネージャ」や「フォルダへの振り分けルール」のヘッダ欄の候補に「X-Mailer」や「Content-Type」が見当たらない場合は、ご自分で書き込んでやりましょう。また、目的のメールを表示している時であれば、ヘッダ欄と文字列欄にそのメールのヘッダから抽出された候補が表示されます。


Hotmail/MSN/AOLのメールアカウントで送受信できますか？

Q. [04003] Hotmail/MSN/AOLのメールアカウントで送受信できますか？

Hotmail/MSN/AOLのアカウントを取得してOutlook Expressや専用ソフトで送受信しています。できれば使いなれたBecky!で送受信したいのですが、可能ですか？

A. Becky!標準の機能では不可能です。Hotmail/MSN/AOLはPOP/SMTPを利用した仕組みではないので、通常のメールソフトでは利用できないのです。

しかし、Hotmailに関しては荻野哲男さん作の「BkHotmail」プラグインを導入することで送受信が可能になります。

MSN/AOLに関してはそういったプラグインも存在しません。ただし、外部ソフトを利用するという手があります。通常のメールソフトを様々なWebメールに対応させるWeb2Popという仲介ソフトを用いると受信は可能になるようです。送信は未対応のようですので、他のプロバイダのSMTPサーバーを使いましょう。フランス製のシェアウェアです（英語ページもあります）。


広告メールなどを読まずに自動削除したい

Q. [04004] 広告メールなどを読まずに自動削除したい

いたずらメールや広告メールがたくさん来て困ります。読まずに削除するにはどうしたらいいでしょうか。

A. 受信時の自動振り分けを利用して、特定の差出人などからのメールを受信したらゴミ箱に直行で振り分けられるように設定しましょう。

振り分けの設定方法についてはBecky!のヘルプの「Becky!入門」-「メールを整理する」、および「メニュー構成」-「メイン画面」-「ツール(T)メニュー」内の「フィルタリングマネージャ」を参照してください。

自動振り分けを使っても「受信せずにサーバーから削除する」という設定はできません。ただし、自動ではありませんが、「リモートメールボックス」機能を使って、受信したくないメールを手動でサーバーから削除することは可能です。

プロバイダが受信拒否サービスを提供していることもありますので、ご利用のプロバイダに確認してみてください。

→ 関連項目
  • [04006] メールを受信せずに削除するには？


受信の後に送信したい

Q. [04005] 受信の後に送信したい

プロバイダのメール送信の制限として、いったん受信しないと送信させてくれないそうです（いわゆる「POP Before SMTP」）。Becky!は送信-受信という順番のようですが、逆にすることはできませんか？

フィルタリングマネージャで自動返信を設定したのですが、送信-受信という順番だと、自動返信メールの送信は次回の送受信時まで待たなくてはなりません。できればすぐに返信メールを送りたいのですが。

A. プロバイダの制限への対策は「ツール」-「メールボックスの設定」-「詳細」の「送信の前にPOP3認証を行う」をチェックしましょう。ユーザー認証を行うだけですぐには受信はしませんが、「POP Before SMTP」への対策としてはそれで十分なのです。実際の受信は送信の後に行われます。

自動返信メールをすぐに送信したい場合は、「全般的な設定」-「送信」の「送受信の際、受信の後にも送信を行う」にチェックを入れましょう。


メールを受信せずに削除するには？

Q. [04006] メールを受信せずに削除するには？

ウイルスと思われる添付ファイル付きのメールが来ました。幸い受信サイズ制限に引っかかり、まだ受信していません。受信せずに削除するにはどうしたらいいでしょうか。

A. 受信せずにサーバーから削除するにはリモートメールボックス機能を使います。サーバー内のメールを一覧して操作できる機能です。

リモートメールボックス機能の具体的な使い方については、Becky!のヘルプの「メニュー構成」-「メイン画面」-「メール(M)メニュー」を参照してください。

→ 関連項目
  • [04004] 広告メールなどを読まずに自動削除したい


HTMLメールのHTMLパートを削除するには

Q. [13001] HTMLメールのHTMLパートを削除するには

初心者がOutlook ExpressからHTMLメールを送ってきた場合など、メールから必要のないHTML部を削除したいのですが、「この添付ファイルはmultipart/mixedの形式で無いため、削除できません」というメッセージがでてしまいます。なんとか削除する方法はないでしょうか。

A. 「表示」-「ソースの表示」の後で「直接編集モード」に移行して、メール全体を編集し、不要なパートを削除してしまうという手段があります。ただし、当然ながらメールの構造に関して知識が必要です。

この手順を簡単にしてくれるプラグインを利用すると便利です。前田裕也さんの「HTML Killer」はまさにこのための機能を追加してくれます。またKAZさんの「添付ファイル一括削除プラグイン」は、本来は添付ファイルをフォルダ中から一括で削除するためのプラグインですが、HTMLメールのHTML部も削除してくれます。一括とは言いながら、添付ファイルがあるメールを一覧後、選択的に削除もできます。

→ 関連項目
  • [10001] 「プラグイン」とは何ですか？


メールをキー操作で他のフォルダに移動/コピーするには

Q. [13002] メールをキー操作で他のフォルダに移動/コピーするには

A. Becky!Ver.2ではメールのカットアンドペーストがサポートされました。

つまり、標準のキー割り当ての場合、移動したいメールを表示している時にリストビューにフォーカスを移してからCtrl+X（カット）、その後目的のフォルダを開いてからCtrl+V（貼り付け）でメールが移動できます。Ctrl+Xの代わりにCtrl+C（コピー）を使えば、メールのフォルダ間コピーになります。

これはエクスプローラでのファイル移動/コピーと互換の操作です。
→ 関連項目
  • [20004] キー操作でBecky!を使う


ヘッダを編集するには

Q. [13003] ヘッダを編集するには

ヘッダ表示中に直接編集モードに切り替えてみたのですが、どうもヘッダは編集できない仕様のようですね。他に編集する方法はありませんか？

A. ヘッダを編集したい場合には、「表示」-「ソースの表示」でメール全体を表示してから直接編集モードに移行すると、本文とヘッダを含めて一体的に編集できます。

ただしSubjectおよびDateに関しては、本文表示中の直接編集モードへの移行で、ミドルバーからも編集できます。


メールを別ウィンドウで表示したい

Q. [13004] メールを別ウィンドウで表示したい

メールを複数同時に参照したい時があるので、Outlook Expressのように別ウィンドウで表示したいのですが。

A. Becky!には標準では別ウィンドウでメールを開く機能はありません。メインウィンドウ右下のメッセージビューで表示するのみです。目的を達するためには下記のような手段を使いましょう。

返信／転送ウィンドウを使う

「返信」や「転送」機能を使ってメール作成ウィンドウを開きましょう。自動引用する設定にしておけば、引用文を参照することができます。

「MailOpenプラグイン」を使う

ふるかわあきひとさん作の「MailOpenプラグイン」を使いましょう。リストビューでのダブルクリックや、メールの右クリックから「お気に入りのツールへ送る」ことで、別アプリケーションにメールを受け渡すことができます。送り先のアプリケーションとしてテキストエディタやＴ∀Ｋさん作の「B2 Mail Viewer」、Koji27さん作「Mesview for Becky! ver.2」を指定すると、別ウィンドウでメールを参照することができるようになります。

→ 関連項目
  • [10001] 「プラグイン」とは何ですか？


HTMLメールを表示したくない

Q. [13005] HTMLメールを表示したくない

表示に時間がかかるのでHTML表示はオフにし、ソース表示されるようにしておきたいのですが。

ウィルス付きのメールを受信し、HTML表示をすると感染してしまいそうです。HTMLメールを表示しない方法はあるでしょうか。

A. 「全般的な設定」-「メール表示」の「MSIEコンポーネントを使う」とオフにしましょう。HTMLパートはタグなどが見えるソース表示になります。この状態であれば不正なスクリプトやウィルスは実行されません。

そのHTMLメールが安全であると判断できた場合などHTML表示で見たい場合は、メール下にあるHTMLアイコン（ファイル）をダブルクリックしましょう。ブラウザが起動して表示されます。

→ 関連項目
  • [30006] コンピュータウィルスについて
  • [30007] HTMLメールとは


BASE64以外のエンコード方法で送信したい

Q. [05001] BASE64以外のエンコード方法で送信したい

Becky!Ver.2で添付ファイルを送信しようとしても、必ずBase64エンコードになってしまいます。その他の形式で送信するにはどのような操作をすればいいのでしょうか？

A. Becky!Ver.2でも今までと同様にドラッグアンドドロップによるファイルの添付が行えますが、この方式で添付されたファイルのエンコード形式は初期状態ではBase64とされてしまいます。

一時的にその他のエンコード形式を使用するには、Shiftキーを押しながらドラッグアンドドロップするか、メール作成画面で「ファイル」-「ファイルを添付」から添付するファイルを選択してください。エンコード形式を選択するダイアログが開きます。

また、このエンコード形式を選択するダイアログで、通常使用するエンコード方式 （ドラッグアンドドロップによる添付時に選択される方式）を変更する事ができます。

いったん添付してしまったファイルのエンコード形式をあとから変更することはできません（添付した瞬間にエンコードされているため）。添付を解除してから、再度添付し直してください。


添付ファイルの保管場所はどこ？

Q. [05002] 添付ファイルの保管場所はどこ？

データフォルダの中に添付ファイルが保管されている場所が見当たらないのですが、どこに保管されているのでしょうか？Ver.1の頃はすぐに見つかったのですが。

A. Becky!Ver.2では添付ファイルの保管形式が変更になり、送受信メールともエンコードされたまま各メールに付加されています。「表示」-「ソースの表示」でファイルが添付されている様子を見ることができます。

開く時やドラッグアンドドロップ・「名前をつけて保存」など、必要時に自動でデコードされますので、ユーザーが操作時に意識する必要はありません。

→ 関連項目
  • [20001] Becky!のデータ保管形式


添付ファイルを探すには

Q. [05003] 添付ファイルを探すには

添付で送ってもらったファイルを探すにはどうしたらいいでしょうか。Becky!Ver.1の時はデータフォルダの中を探せばよかったのですが、Ver.2では見当たりません。

A. Becky!Ver.2ではデータ保管形式が変更され、添付ファイルはメールに添付されたまま保管されるようになりました。したがって添付ファイルを探す場合には、まず添付されているメールを探す必要があります。下記の二つの方法で探せます。

「編集」-「クエリー検索」にて
  • 検索文字列に「multipart/mixed」
  • 検索対象を「ヘッダのみ」

という条件でメールをクエリー検索すると添付ファイルを持つメールが一覧されますので、その中から目的のメールを探しましょう。

ただし、本文がなく、添付ファイルのみというメールの場合には、この条件ではヒットしません。その場合には

  • 検索文字列に添付ファイル名
  • 検索対象を「ヘッダのみ」

で検索してみましょう（残念ながら、本文がある添付付きメールの場合にはファイル名の検索ではヒットしません）。

hamfaceさんの「添付ファイル便利ツールプラグイン」やKAZさんの「添付ファイル一括削除」プラグインを使う。

フォルダ中の添付ファイルを持つメールを一覧できます。

→ 関連項目
  • [10001] 「プラグイン」とは何ですか？


メール一覧（リストビュー）の日付・時刻表記を変更したい

Q. [06001] メール一覧（リストビュー）の日付・時刻表記を変更したい

A. メール一覧（リストビュー）での送信日付・時刻表記は、Windowsの設定に従っています。「マイコンピュータ」-「コントロールパネル」-「地域」の「時刻」や「日付」にて変更できます。和暦を使ったり、24/12時間制を切り替えることももちろん可能です。


日付が前後したメール間でもスレッドをつなげたい

Q. [06002] 日付が前後したメール間でもスレッドをつなげたい

スレッドがつながらないので原因を探してみたところ、相手のパソコンの時計が間違っていて、やりとりしているメールの送信日付（Date:）の順番が実際と違っていました。

しかし、スレッドツールでスレッドをつなげようとしたのですが、「対象メールより新しいメールは親にできません。」というメッセージが出て修復できません。どうしたらいいでしょうか。

A. 間違った送信日付のメールを修正してしまいましょう。「メール」-「直接編集モード」にすると、ミドルバーにて送信日付を修正できます。

その際、そのメールの"Received:"ヘッダに含まれる日付が参考になります。"Received:"は複数ありますが、通常は一番下のものが「メール端末（パソコン）からサーバーにメールが受け渡された日付・時刻」です。サーバー側で書き込んだ時刻ですので、一般には正確度が高いはずです。これを用いればいいでしょう。

時刻修正直後はまだつながってくれないように見えますが、いったん他のフォルダを開く、あるいはスレッド表示のON/OFFを切り替えるといった動作で、正常な表示になります。

また、しののんさんの「スレッド修復プラグイン」を用いると、直そうとしたメール間で日付・時刻が前後している時に、ダイアログを表示して修正を助けてくれます。

「いちいち"Date:"ヘッダを直さなくてもスレッドがつながるようにして欲しい」という要望もあります。もちろんその方が便利なのですが、これはBecky!の仕様上、難しいと思われます。Becky!の内部ではメールを送信日付順に管理しているようだからです。おそらく動作の高速化のためでしょうね。

→ 関連項目
  • [20002] スレッド表示と修復


リストビューの表示項目を変更したい

Q. [06003] リストビューの表示項目を変更したい

リストビューには「件名」「差出人」「送信日時」「サイズ」各欄がありますが、これを変更できますか？具体的には

  1. 表示の順番を変えられるでしょうか。
  2. 項目を変更したい。「送信日時」の代わりに「受信日時」を、「サイズ」の代わりにVer.1のように「行数」を表示したいのですが。

A. リストビューの表示項目のカスタマイズは、順番の入れ換え・項目変更とも、残念ながらできません。

なお、受信日時に関しては、ミドルバーの「日時」という文字をクリックすると、その時表示しているメールのもののみ参照することができます。


フォルダの並び順を変えたい

Q. [07001] フォルダの並び順を変えたい

A. ツリービューでの並び順はフォルダ名の文字コード順になっており、任意の順番にすることはできません。

ただし、"00 "や"A."などフォルダ名の先頭に数字やアルファベットを付けて並び順をコントロールするという手段はあります。


メールボックスの並び順を変えたい

Q. [07002] メールボックスの並び順を変えたい

Becky! Ver.2を起動したときに作成順に並んでいるメールボックスを好きな順番に並べ替えたいのですが、どうしたらよいのでしょうか？

A. メールボックスの非表示・再表示機能を使って並べ替えることができます（「ファイル」-「メールボックス」-「非表示にする」または「再表示する」）。

例えば、上からＡ，Ｂ，Ｃとメールフォルダが並んでいるものをＣ，Ｂ，Ａの順に並べ替えたい場合は、メールボックスＡ，Ｂを非表示にしてから、Ｂ，Ａの順に再表示させると希望の順番に並べ替えることができます。

原理

Becky!のメールボックスは、実際のデータとしては「作成日付をもとにした数値.mb」という名前のフォルダとして保管されています。メールボックスはこの作成日付数値の順番に並んでいるのです。

「メールボックスの表示・非表示」機能は、メールボックスデータフォルダの名前を変更することで実現されています。つまり非表示にすると「作成日付をもとにした数値.mb.bak」という名前に変更されてBecky!上からは見えなくなり、再表示を実行すると、「その時点をもとにした数値.mb」という名前に変更されて、再びBecky!から見えるようになります。この時に名前が変更されることで並び順もその通りに反映されることになるのです。

振り分け条件設定ファイル（IFilter.def、OFilter.def）の中にもメールボックスのデータフォルダ名が記述されていますが、これも同時に書き換えられます。

つまりユーザーが自分でこのデータフォルダの名前を変更し、振り分け条件設定ファイルを書き換えることでも、Becky!上での順番を変更することができるということになります（ただし自己責任であることをお忘れなく）。

弊害として、ユーティリティを用いて他のドライブとメールボックスの同期を行なっている場合、フォルダ名が変更されることで大量のファイルの再同期が必要になるということが挙げられます。

→ 関連項目
  • [20001] Becky!のデータ保管形式


メールボックスを削除するには？

Q. [07003] メールボックスを削除するには？

A. Becky!のメインウィンドウの「ファイル」メニューから「メールボックス」-「削除」です。


アドレス帳のグループの並び順を変えたい

Q. [08001] アドレス帳のグループの並び順を変えたい

A. アドレス帳のグループの並び順はグループ名の文字コード順になっており、任意の順番にすることはできません。

ただし、"00 "や"A."などグループ名の先頭に数字やアルファベットを付けて並び順をコントロールするという手段はあります。


アドレス帳のグループを移動したい

Q. [08003] アドレス帳のグループを移動したい

アドレス帳のグループの階層を変更したいのですが。ドラッグアンドドロップでは移動してくれないのですか？

A. 残念ながらBecky!のアドレス帳ではグループの移動はサポートされていないようです。

まっとうな方法としては、移動したい場所に新規でグループを作成して、そこにアドレスを移動する、となるでしょう。

ですが、エクスプローラなどから、データフォルダを直接移動するという手もあります。下記の関連項目の「アドレス帳データフォルダ」の項を参考にチャレンジしてみてください。

→ 関連項目
  • [20001] Becky!のデータ保管形式


アドレス帳を印刷したい

Q. [08004] アドレス帳を印刷したい

A. Becky!自身にはアドレス帳を印刷する機能はありません。但し、アドレス帳のインデックスファイルは、タブ区切りのテキストファイルですので、Excelなどのアプリケーションから直接読み込むことができます。あとは、アプリケーションの印刷機能を使えば自由に加工、印刷できます。（加工した後、保存しないように注意してください）

インデックスファイルのありかは、Becky!のデータフォルダの下のAddrBookというサブフォルダの中で、@で始まる名前のフォルダを開くと、その下にアドレスグループ名のフォルダがあります。その中にあるGroup.idxというファイルです。

例：￥Becky!￥MyName￥AddrBook￥@MyBook￥MyGroup￥Group.idx

また、Y.Hadaさん作のアドレス帳用外部ツール「Becky Address Book Manager For B2」の印刷機能を使うという手もあります。


アドレス帳をコピーしたい

Q. [08005] アドレス帳をコピーしたい

会社の部署内で共通のアドレス帳データを皆に配りたいのですが、どのようにすればいいでしょうか。

A. Becky!のアドレス帳は１グループ＝１フォルダのデータとなっています。つまり必要なフォルダを別のBecky!のアドレス帳データフォルダにコピーしてやればいいでしょう。

アドレス帳データの在りかは通常
"C:\Becky!\Windowsログオン名\AddrBook"
というフォルダです。下記関連項目を参照して、まずはデータの所在を確認してみてください。

→ 関連項目
  • [20001] Becky!のデータ保管形式


起動時の絵（スプラッシュ）を変更or非表示にしたい

Q. [09001] 起動時の絵（スプラッシュ）を変更or非表示にしたい

A. Becky!がインストールされているフォルダ（通常は"C:\Program Files\RIMArts\B2"）の中に"B2.BMP"というビットマップファイルがありますが、これを好みのものに取り替えればOKです。このファイルを削除（あるいは名前変更）してしまえばスプラッシュも表示されなくなります。

コマンドラインオプションで"/A"を指定しても、スプラッシュが非表示になります。

ユーザーが作成したスプラッシュ用画像一覧ページもあります。「B2ANIM.bmp」や「B2.bmp」を参照してください。


右上の封筒アニメーションアイコンを変更したい

Q. [09002] 右上の封筒アニメーションアイコンを変更したい

A. Becky!がインストールされているフォルダ（通常は"C:\Program Files\RIMArts\B2"）の中に"b2anim.bmp"というビットマップファイルを入れれば、次回の起動時からそれがアニメーションアイコンとして利用されます。さらに、b2animで始まるbmpファイル(たとえば"b2anim1.bmp"など)を複数作っておいて、b2anim.bmp自身は作らないでおくと、起動時にランダムで選択・利用されます。

画像形式は縦横30ビクセルを１コマとして、横にコマをつなげたものであればOKです。通常は一番左のコマが表示され、通信時には順に切り替えて表示されます。

ユーザーが作成したアニメーションアイコンを一覧したページもあります。「B2ANIM.bmp」や「Becky!ユーザーの部屋」内の「ちょっといい話」-「Becky!Ver.2用アニメーションアイコン」を参照してください。


英語メニューで使いたい

Q. [09003] 英語メニューで使いたい

A. Becky!には英語版も存在します。英語版ならば海外版Windows上でも使えますし、日本語Windows上で英語メニューで利用することも可能です。Rim-Artsホームページの英語版Becky!のページから入手してください。

※：プログラムが日本語版/英語版に分かれたのはVer.2からで、Ver.1ではWindowsの言語設定を判別して表記が切り替わります。つまり日本語版Windowsに英語版をインストールしても日本語メニューでしか使えません。

ただし英語版Becky!で日本語のメールを書くには、下記のような制約がありますのでご注意を。

そのままでは禁則処理が使えない。

ただし、レジストリに禁則処理の設定を保管すると使えるようになります。具体的には
HKEY_CURRENT_USER\Software\RIMArts\B2\Settings
という項目に"Oidashi"と"Burasage"という名前で禁則文字列を追加するのです。

ちなみに日本語版の初期値は

  • Burasage = 、。，．？！゛゜～…‥’”）〕］｝〉》」』】≫ーぁぃぅぇぉっゃゅょァィゥェォッャュョ
  • Oidashi = （［｛「〔《『【〈≪‘“

となっています。

自分でレジストリを書き換えることに慣れていないならば、日本語版Becky!で「全般的な設定」「エディタ」にて「行末禁則文字」「行頭禁則文字」の設定を初期値からいったん変更、保存してやるとレジストリに書き込まれます。その後は英語版Becky!にても禁則処理が使えるようになります。

「オートインデント」がONでも、箇条書きの際、行頭の整形をしてくれない。

これは回避策がないようです。


起動時にメールボックスを指定したい

Q. [09004] 起動時にメールボックスを指定したい

Becky!を起動した時に最初に開くメールボックスを時によって変えたいのですが、起動時に指定する方法はありますか？

A. 残念ながら現状ではできません。常に「ファイル」-「通常使うメールボックスに設定」されたメールボックスにて起動します。

Ver.1の頃に存在した「Blaunch」に相当する外部ユーティリティも、Ver.2用のものはまだ存在しません。


画面の配色を変更したい

Q. [09005] 画面の配色を変更したい

A. メッセージビューおよびメール作成ウィンドウの本文部は、「全般的な設定」の「メール表示」-「色指定」で配色を設定することができます。

ツリービューやリストビューはBecky!独自の配色はできません。Windowsの配色に従います。「画面のプロパティ」-「デザイン」で設定できる「ウィンドウ」の色がBecky!上でも反映されます。


URLクリック時にブラウザを新しいウィンドウで開きたい

Q. [09006] URLクリック時にブラウザを新しいウィンドウで開きたい

Webページをすでに開いているときに、B2のURLをクリックすると、今見ていた ブラウザにURLが渡ってしまいます。そのページを参照したまま、メールで送られてきたページを見たい時もあるのですが、新規でブラウザのウィンドウを開く方法はありますか？

A. 基本的に、ブラウザがどのウィンドウでWEBページを開くかは、外部アプリケーション（この場合はBecky!）から指定することはできないそうです。つまりブラウザの機能を利用しなくてはなりません。

Internet Explorerの場合
常に新しいウィンドウで開くようにする
インターネットオプション→詳細設定の「ショートカットを起動するためにウィンドウを再使用する」のチェックを外してください。
都度選択する
Shiftキーを押したまま右クリックし、「このURLを開く」を実行してみましょう。

Netscape Navigator 4.xまたはNetscape6の場合

Netscapeの場合には「全般的な設定」の「メール表示」にて「DDEを使う」のチェックを外すと新しいウィンドウで開けることもあるそうです。ただし、うまくいかない環境もあるようです。

うまくいかないばあい、Tietewさんのプラグイン「Powerful Customizer」を利用して、ブラウザの関連付けによる起動ではなく明示的にNetscape NavigatorまたはNetscape 6を指定してやると、うまく新しいウィンドウで開けたという報告があります。

それ以外のブラウザ

残念ながら、判りません。もしあなたがその方法を見つけたならば、是非、教えてください。


各部のフォントを変更したい

Q. [09007] 各部のフォントを変更したい

Becky!のツリービューやリストビューなど、各部の表示フォントの種類や大きさを変更したいのですが。

A. 各部のフォントはBecky!独自の設定が可能な場所と、Windowsの設定に従う場所があります。

メッセージビュー

「表示」-「フォントの変更」で変更できます。違う言語のメール用のフォントを変更する時は、そのメールを表示している時にこのメニュー項目を実行すればOKです。また、「全般的な設定」-「言語/フォント」でも言語ごとのフォントが設定できます。

ツリービュー

Windowsの画面の設定に従います。「画面のプロパティ」の「デザイン」にて「指定する部分」が「アイコン」の時の設定が用いられます。ただし、Becky!が起動中に変更しても反映されません。次回のBecky!起動後に反映されます。

ただし、Tietewさんのプラグイン「Powerful Customizer」を導入すると、Windowsの設定から独立して、独自のフォント・サイズを指定できます。

リストビュー

Windowsの画面の設定に従います。「画面のプロパティ」の「デザイン」にて「指定する部分」が「アイコン」の時の設定が用いられます。ただし、他言語のメールのSubjectの場合は、その言語の本文表示用のフォントが使われます。

ただし、Tietewさんのプラグイン「Powerful Customizer」を導入すると、Windowsの設定から独立して、独自のフォント・サイズを指定できます。

ステータスバー

Windowsの画面の設定に従います。「画面のプロパティ」の「デザイン」にて「指定する部分」が「ヒント」の時の設定が用いられます。


「プラグイン」とは何ですか？

Q. [10001] 「プラグイン」とは何ですか？

Becky!Ver.2はプラグインという仕組みで機能を拡張できると聞きました。プラグインとは何でしょうか？Ver.1の時の便利なユーティリティとは違うものですか？

A. Becky!Ver.2より「プラグイン(Plug-in)」という仕組みによって、Becky!に機能を追加したり、動作を変更したりすることができるようになりました。

Ver.1でもBecky!をコントロールするような外部支援ソフトは存在しましたが、あくまでBecky!を独自に解析しコントロールしていたのです。Ver.2に装備された「プラグイン・インターフェース」とは、Becky!から情報を得たりコントロールしたりするためのプログラム内部のルールを作者さんが設定し、それを公開したものです。これを利用することで、よりBecky!に密着したソフトウェアを作りやすくなっているのです。

Ver.2のβ版で仕様が公開されてから、さっそくパワーユーザー諸氏がプラグイン・インターフェースを利用した機能追加ソフト（この文書内では単に「プラグイン」と呼びます）をたくさん発表されています。

→ 関連項目
  • [10002] どんなプラグインを、どこで入手できますか？
  • [10003] プラグインの組み込み方
  • [10004] プラグインを作成するには


どんなプラグインを、どこで入手できますか？

Q. [10002] どんなプラグインを、どこで入手できますか？

A. Ver.2β版公開以来、多くのプラグインがパワーユーザー諸氏により作成されています。その種類も機能付加や改善、Ver.1に使い勝手を合わせるものなど様々です。

作者諸氏の努力により日々増え、あるいは更新されてますので、ここでまとめることはしません。プラグインや外部ツールの紹介と入手方法を紹介した下記のサイトを参照してみてください。

  • 「Becky!ユーザーの部屋」内「周辺ソフトウェア」
  • 「Becky!非公式BBS（お気楽版）」内「B2スペシャルルーム」
  • 「B2 Plug-in Forum」
→ 関連項目
  • [10003] プラグインの組み込み方
  • [10004] プラグインを作成するには


プラグインの組み込み方

Q. [10003] プラグインの組み込み方

プラグインを組み込むにはどのようにすればいいのでしょうか？プラグインを入手したのに、圧縮ファイルを展開しても中身が見当たらないようですが。

A. プラグインの本体はDLL（ダイナミック・リンク・ライブラリ）と呼ばれるファイルです（拡張子は.dll）。また、プラグインによっては複数のファイルが必要なこともあります。

Becky!への組み込み方法は、基本的にはプラグイン作者が配布しているファイルを、すべて

  • Becky!がインストールされているフォルダ内の「Plugins」フォルダ
  • データフォルダ内の「Plugins」フォルダ

のどちらかにエクスプローラなどでコピーするだけです（一部のプラグインにはインストーラが付属しています）。

ただし、Windowsは初期設定では肝心のDLLファイルを「システムファイルである」という理由で表示しない設定になっているため、肝心のプラグインファイルが見えず、コピーできない場合があります。その場合は、「マイコンピュータ」から「表示」-「フォルダオプション」-「表示」タブ内で「表示されないファイル」オプションを「すべてのファイルを表示する」か「隠しファイルを表示しない」のどちらかにして、システムファイルも表示されるようにしましょう。「登録されているファイルの拡張子は表示しない」オプションをOFFにすることも推奨します。

次にBecky!を起動した時に、そのプラグインが初めてコピーされたものの場合、組み込んでもいいかをBecky!が問い合わせてきます。自分がコピーしたものである場合には「はい」を押して機能組み込みを続行しましょう。問い合わせは初回のみです。それ以降はBecky!からプラグインの機能を利用することができるようになります。

インストールしたはずなのに機能しない場合、「ツール」-「全般的な設定」-「高度」の「プラグイン」ボタンを押して、使おうと思っているプラグインの名前にチェックが入っているかどうかを確認してみてください。以前、無効にしたことがある場合など、なんらかの理由でOFFになっていることがあります。

そもそも一覧に出て来ない時は、インストールがうまくいっていません。プラグインの説明文書をよく参照して、再度インストール作業を行ってみてください。

→ 関連項目
  • [10004] プラグインを作成するには


プラグインを作成するには

Q. [10004] プラグインを作成するには

A. プラグインとは結局はWindows上のプログラムファイルのことです。つまり作成するには、Windows上でのプログラムが可能な開発環境および作成者の技術が必要です。

その上で、作者さんが公開されているBecky!APIなどの仕様を知る必要があります。そのためのSDK(Software Developement Kit)はRimArts公式ページより入手してください。

また、プラグイン作者のための情報交換メーリングリストも開設されています。

→ 関連項目
  • [10001] プラグインとは何ですか？


データフォルダの容量を節約したい

Q. [11001] データフォルダの容量を節約したい

HDDの残り容量が少なくなってきたので、Becky!のデータフォルダのサイズをなんとか小さくしたいのですが。

A. HDDを増設しましょう・・・というのもノートパソコンなどでは難しいですね。当面はデータの整理などで節約するしかない場合もあるでしょう。Becky!のデータに関しては下記のような手段があります。

不要なメールを整理する

当たり前ですが、メールはしっかり整理して、不要なものやすぐには必要ないものををBecky!内から整理しましょう。メールマガジンやMLなど、古くなったメールを中身を確認せずに削除していい場合には、Tietewさんの「過去メール整理プラグイン」が便利です。フォルダごとに自動で古いメールを削除する機能もあります。

Becky!上で削除する前にそれらのメールを外部メディアにバックアップしておきたい場合は、複数のメールを選択後、「ファイル」-「エクスポート」でファイルに保存しておけばいいでしょう。前述の「過去メール整理プラグイン」は削除ばかりでなく他のメールフォルダへの移動もできますので、そのフォルダの実体ごとバックアップしておくというのも有効です。

フォルダのコンパクト化

「ファイル」-「フォルダ」-「コンパクト化」を実行すると、そのフォルダのメールから不要なヘッダを削除してくれます。フォルダの右クリックメニューからも実行可能です。ただし、最後の問い合わせでバックアップを残してしまうと、却ってその分容量が多く必要になります。

データフォルダから拡張子が.bakのファイルを削除

過去に上記の「コンパクト化」を実行した時のバックアップファイルが残っているかもしれません。エクスプローラで.bakファイルを検索して削除してしまいましょう。

バックアップログを削除

データフォルダの中に拡張子が.bklおよび.bksのファイルがありますが、これは送受信したメールのバックアップログです。念の為にそなえてあるファイルですが、必要ないと判断したら、削除しても問題はありません。また、このファイルは「全般的な設定」-「受信」にて保存期間を設定できます。

容量は節約したいがバックアップはできるだけ残しておきたいという方は、安藤亮太さんの「バックアップログ圧縮保存プラグイン」を使いましょう。Becky!起動時に１ヶ月以上前のバックアップログを自動で圧縮してくれます。

→ 関連項目
  • [20001] Becky!のデータ保管形式


メールボックスフォルダの中の日付が名前のファイルは何？

Q. [11002] メールボックスフォルダの中の日付が名前のファイルは何？

メールボックスフォルダの中に、ファイル名が数字のファイルが一杯あるけど、これって何ですか？数字はどうも日付のようなのですが・・。ずいぶんと容量を取っているのですが、消しても大丈夫なのでしょうか？

A. これらは不慮の事故等でメールが消えてしまった時の為のバックアップファイルです。今まで送受信したメールが日ごとに保存されているのです。

  • 拡張子がbklのファイルは受信メールのバックアップログ
  • 拡張子がbksのファイルは送信メールのバックアップログ

それぞれ、「全般的な設定」-「受信」タブの「受信メールをバックアップ」「送信メールをバックアップ」にチェックを入れると保存されます。また、ここで何日間保存しておくかも指定できます。

容量を大きく取ってしまうことが気になる場合は、削除してもBecky!の動作には影響有りません。

万一の時のために古いバックアップログを保存しておきたい人もいるでしょう。そんな時には安藤亮太さん作の「バックアップログ圧縮保存Plug-in」が便利です。前月のバックアップログを自動で圧縮して保存してくれます。

→ 関連項目
  • [10001] 「プラグイン」とは何ですか？


データおよび設定のバックアップと復旧

Q. [11003] データおよび設定のバックアップと復旧

Windowsを再インストールする前にBecky!のメールデータや設定をバックアップしておきたいのですが。またその後の復旧方法も教えてください。

A. まず、データフォルダを別のメディアにコピーしておきましょう。通常は
C:\Becky!\あなたのログオン名
というフォルダに保管されています。"Becky!"フォルダごと、外部メディア（CD-RやMOなど）に移しておけばいいでしょう（ただしCD-Rへのバックアップは注意が必要です。関連項目を参照してください）。これによって、メール（フォルダ構成含む）、アドレス帳、振り分け設定、メールボックスとプロファイルなど、大部分の情報がバックアップされます。

これらを復旧するには、"Becky!"フォルダを丸ごと新しい環境に移してやればいいです。そこでBecky!を初めて起動する時にデータフォルダの位置を聞いてきますので、書き戻したフォルダを指定してやりましょう。

全般的な設定やBecky!の登録情報などはレジストリに保存されていますので、別途バックアップが必要です。レジストリエディタを使ってファイルに書き出しましょう。

ただし、必要な設定はそれほど多くありませんので、レジストリのバックアップを取らず新たに設定し直してもそれほど大変なことではありません。レジストリを操作するのは危険が伴いますので、自信のない方にはお薦めしません。

  1. レジストリエディタを起動します。スタートメニューの「ファイル名を指定して実行」にて「regedit」と入力後、「OK」を押しましょう。
  2. レジストリエディタが起動したら、Becky!Ver.2の設定が保管されている箇所を開きます。左側のツリーの
    HKEY_CURRENT_USER\Software\RIMArts\B2
    を開いてください（"\"はツリーの分岐を意味します）。
  3. そこを選択した状態で「レジストリ」メニューの「レジストリファイルの書き出し」を実行しましょう。「書き出し範囲」は「選択された部分」で。ファイル名はお好きな名前で。書き出し先を選んで「OK」を押せば書き出せます。
  4. このように書き出されたファイルは、拡張子が.regになっています。

    このファイルを新しい環境でダブルクリックすると、レジストリに設定が書き込まれて、以前と同じ設定で使うことができます。ただし、データフォルダの場所などが以前と違っている場合には、最初の起動後に「ツール」-「システム」-「データフォルダの変更」を実行してBecky!を再起動、改めてバックアップからの復旧後のデータフォルダを指定しましょう。

    レジストリファイルを他の環境へ持っていく場合、Windowsのバージョンにも注意が必要です。Win95/98で書き出したレジストリファイルは互換性がありますが、Windows2000で書き出したファイルは形式が変更されているためWin95/98で読み込むことができません（逆は可）。保存時にファイルの種類を「Win9x/NT4レジストリファイル」にする必要があります。
→ 関連項目
  • [11004] CD-Rにバックアップしたときの注意
  • [20001] Becky!のデータ保管形式


CD-R/RWにバックアップしたときの注意

Q. [11004] CD-R/RWにバックアップしたときの注意

A. CD-RまたはCD-RWにバックアップしたファイルは、全て読み取り専用属性のファイルになってしまいます。HDDへ書き戻した後に読み取り専用属性を解除しないと、データが書き込めない、設定変更が保存されないといったトラブルが起きます。

その場合、下記の手順で一括で読み取り専用属性を解除することができます。

  1. マイコンピュータを使用して、Becky! Ver2のデータディレクトリを開きます（標準では、"C:\Becky!\(あなたのログオン名)"になっています）。
  2. F3キーを押します。するとファイル検索ダイアログが出ます。
  3. そのまま、「検索開始」ボタンを押します。
  4. 検索終了したら、「編集」-「全てを選択」し、
  5. 「ファイル」-「プロパティ」でダイアログを開いて、「読み取り専用(R)」 のチェックを外します。
  6. [OK]を押せば終わりです。後は、検索ウインドウを閉じてください。
→ 関連項目
  • [11003] データのバックアップと復旧


複数のデータフォルダをひとつにまとめたい

Q. [11005] 複数のデータフォルダをひとつにまとめたい

パソコンを修理に出している間、別のパソコンのBecky!Ver.2でメールの送受信をしてきました。修理から返ってきたパソコンにその間に送受信したメールを移して、また元のデータフォルダで使用したいのですが。

A. まず、その間に送受信したメールがバックアップログに残っているのなら、そのファイルを戻ってきたパソコンにコピーして、「ファイル」-「バックアップログからの取り込み」で取り込んでしまうのがいいでしょう

「バックアップログを残してなかったし、アドレス帳データも戻したい」という場合には、下記のような手順が考えられます。

メールデータ

データフォルダの中の《アルファベットと数字8文字》.mbというフォルダが各メールボックスの実体データです。これを元のデータフォルダにコピーしてやりましょう。万が一名前が重複している場合には、重ならないようにコピー元のフォルダ名を変更してください。一文字変更するだけで十分です。

元のBecky!を起動すると新しいメールボックスとして認識されますので、あとはBecky!上で必要なフォルダやメールを元のメールボックスに移してください。ドラッグアンドドロップで可能です。整理が終わって移してきたメールボックスが不要になったら、「ファイル」-「メールボックス」-「削除」で削除できます。

アドレス帳

データフォルダの直下にあるAddrbookフォルダがアドレス帳のデータです。その直下にある@"アドレス帳名"というフォルダがそれぞれのアドレス帳の実体になります。

結合する方法としては次の通りです。

  • アドレス帳単位で書き戻したい場合、@"アドレス帳名"フォルダの名前が元と競合しないように変更し、Addrbookフォルダにコピーしましょう。Becky!からは新しいアドレス帳として認識されます。
  • アドレスグループごとに書き戻したい場合、@"アドレス帳名"フォルダの中のフォルダの名前が競合しないように変更し、書き戻し先の@"アドレス帳名"フォルダの中にコピーしましょう。Becky!からは新しいグループとして認識されます。

アドレス帳はグループのドラッグアンドドロップはサポートされていませんので、整理したい場合は関連項目を参照してください。

データフォルダのその他のファイル

MLフォルダは、メーリングリストマネージャが使うファイルです。必要なものをコピーしてください。

また、B2.kwd（キーワード設定）、*.key（ショートカットキーの設定）、*.tml（全般的な設定→引用 で使われているテンプレート）も必要な方を残しましょう。

→ 関連項目
  • [20001] Becky!のデータ保管形式
  • [08003] アドレス帳のグループを移動したい


添付ファイル名も印刷したい

Q. [12002] 添付ファイル名も印刷したい

添付ファイルがあるメールを印刷する時には、その添付ファイル名も同時に印刷したいのですが、設定する項目が見当たらないようですが。印刷できないのでしょうか。

A. 2.00.04で機能が追加されました。「ファイル」-「印刷設定」の「添付ファイル名を印刷」で設定可能です（初期値はON）。お使いのBecky!のバージョンを確認して、古い場合には新しいバージョンにしてください。


HTMLメールを印刷したい

Q. [12003] HTMLメールを印刷したい

HTMLメールを印刷すると、ソースが印刷されてしまうようです。HTMLの見た目通りに印刷する方法はないでしょうか。

A. Becky!はInternet Explorerの機能を利用してHTMLメールを表示しているため、「ファイル」-「印刷」からではHTMLメールの印刷ができません。ですが、本文部（HTMLビュー）を右クリックして出てくるメニューの「印刷」を利用すると、Internet Explorerの機能を利用して印刷できます。

→ 関連項目
  • [30007] HTMLメールとは


Ver.2ではまた登録料を払わなくてはいけない？

Q. [19001] Ver.2ではまた登録料を払わなくてはいけない？

Becky!Ver.1に登録料を払って使ってきましたが、Ver.2にバージョンアップする時には再度登録料やバージョンアップ料金を支払わなくてはならないですか？

A. 払う必要はありません。作者さんによれば、Becky!のライセンスは「Ver.1、Ver.2というバージョンの区別なしに同一ライセンス」と考えていいそうです。

→ 関連項目
  • [01001] Becky!Ver.1.xxからのバージョンアップ


Ver.1にあった機能が見当たらないのですが

Q. [19002] Ver.1にあった機能が見当たらないのですが

A. Ver.2ではメニュー構成が大きく変更されているため、Ver.1で存在した機能を探すとすぐに見つからないことがあるかもしれません。ですが、基本的にはVer.1の機能を引き継いでいますので、まずはメニューや設定ダイアログを一通り眺めてみることをお勧めします。今までとは違う場所にその機能を発見できると思います。

ただし、中には見直しにより廃止された機能もあります。主なものをまとめましたので、以降の項目も参照してください。

また、極力Ver.1を引き継ぐように作られたとは言っても、新規作り直しによって誕生したVer.2はやはりVer.1とは別ソフトです。したがってVer.1の頃と機能や使い勝手が違うところがあっても、それが重大なものでない限りは、「仕様変更された」と考えた方がいいでしょう。

アカウントを削除したいのですが、Becky!Ver.1でのようにPOPサーバーを空欄にしても消えません。

アカウント（メールボックス）の削除は「ファイル」-「メールボックス」-「削除」から行えます。

ミドルバーをダブルクリックしてもビュー画面が最大化されないのですが。

Becky!Ver.2ではミドルバーのダブルクリックによるビュー画面の最大化はなくなりました。ツールバーの「メッセージビュー最大化」ボタンを利用して下さい。

あるいはしののんさん作の「Double Click Maximize」プラグインを使うとその機能を組み込めます。

巡回モニタはどうやって出せばいいのですか？

巡回モニタそのものはなくなりました。しかし新機能の「新着リスト」によって受信したメールを一覧することができます。「表示」メニューの「新着リスト」を実行してみてください。また、Tietewさんの「Powerful Customizer」プラグインを導入すると、新着メールがある時に自動で新着リストをポップアップすることができるようになります。

「最初に受け取ったメールを表示」オプションが見当たりません。

このオプションはなくなりました。前の問いと同じく「新着リスト」で新しく到着したメールを一覧して下さい。

キー割り当てが少し変わっていて気になります。ESCキーでフォーカス移動をしたいのですが。

フォーカス移動もVer.1から作法が変わったところです。また残念ながら「全般的な設定」の「ショートカットキー」でもフォーカス移動のキー割り当て変更はできません。しかし、どうしても気になる方は、上村さん作の「[ESC]Key Focus move」プラグインを入れることでVer.1の頃の割り当てを再現することも可能です。

ミドルバーの「アドレス確認」ボタンは無くなってしまったのですか？

ミドルバーからは見られなくなりました。が、メール一覧を右クリックして「メールのプロパティ」で同様の画面を見ることはできます。

「現在の状態を保存」機能は無くなったのですか？データを書き込んでおかないと不安なのですが。

ユーザーが明示的に行うためのメニューコマンドは無くなりました。ですがVer.2では、たとえば別のフォルダを開いた時など、動作の節目節目でデータを書き込むようになったようです。したがってあまり意識する必要はないでしょう。

あるメールボックスを巡回対象から外すにはどうしたらいいですか？「メールボックスの設定」に見当たらないのですが。

「メール」-「巡回設定」にて巡回対象を設定可能です。「メールボックスの設定」のダイアログから無くなったのは、プロファイル機能などとの絡みだと思われます。Ver.1でも「メール」-「巡回設定」は存在しましたので、そちらは引き継いでいるということでしょう。

メール作成画面で Cc:やBcc:を直接入力するには？

宛先や件名の部分にフォーカスがある状態でCtrl+↓を押すか、重要度を設定する切手アイコンの右隣の上下矢印で下矢印を押すと、Cc:やBcc:の入力フィールドが出てきます。

ツリービューの高さを変更（ロングツリービューをOFFに）するには？

「表示」-「レイアウトの変更」を実行するごとに、各ビューのレイアウトが変わります（ただし、Becky!Ver.2.00.03以降）。また、メッセージビューの幅が足りないためメールが読みにくい、といった場合にはCtrl+Alt+←、→でツリービューの幅を切り替えることができます。

→ 関連項目
  • [01001] Becky!Ver.1.xxからのバージョンアップ


複数のパソコンのメールデータを同期させて使いたい

Q. [19003] 複数のパソコンのメールデータを同期させて使いたい

自宅と仕事先のパソコンでメールの送受信をしているのですが、両方での送受信結果を同期させて使いたいです。

A. いろいろな方法が考えられます。下記に主なものを列挙しますが、それぞれ長所短所がありますので、各自の運用にあわせて工夫してください。

受信したメールをサーバーに残す

「メールボックスの設定」-「基本設定」で「受信メールをサーバーに残す」をONにしましょう。数日後に削除されるように設定しておけば便利です。自分が送るメールは、Bcc:を付けて自分宛にも送られるようにしておけばOK。

ただし、メールサーバーが自宅・会社両方からアクセスできる必要がありますし、開封済み/未開封の同期はできません。たくさんメールを受信している人には手間がかかりますね。

「バックアップログを残す」設定にしておいて、フロッピー等で運ぶ

「全般的な設定」-「受信」にてバックアップログを残す設定にし、受信メールのバックアップログ（.bkl）、送信メールのバックアップログ(.bks）を相互に運び、それぞれ「ファイル」-「バックアップログから取り込み」するという方法です。

これも開封済み/未開封の同期はできません。

外部メディアを使って運ぶ

自宅・会社それぞれのデータフォルダをMOなどの大容量リムーバブルディスクに同期コピーし、それを持ち歩く方法です。ファイル・フォルダ同期ソフトを利用すると便利でしょう。あるいは外部メディアをまるごとメールボックスにしているというケースもあるようです。

ただし、両方の場所に同じメディア用のドライブが必要ですし、メディアの破損や紛失に注意が必要です。

自宅用と会社用のアドレスを用意する

会社のアドレスがメインの場合、自宅での受信用に新たにプロバイダに入り、会社に来たメールをそちらにも転送するという方法です。方法がわからない場合にはネットワーク管理者に依頼しましょう。

同様の手段に、E-Mailの転送サービスを利用するものがあります。本来、所属などが変わっても人に教えるアドレスを訂正しなくてもいいようにするためのサービスですが、対外的には転送サービスのアドレスを使っておき、このアドレス宛のメールの転送先を会社と自宅両方にすればいいでしょう。

ただし、すでに長く使ってきたメールアドレスの場合は変更の周知が大変ですね。


Becky!でNetNewsを読みたい

Q. [19004] Becky!でNetNewsを読みたい

使い慣れたBecky!でNetNewsも講読したいのですが。Becky!にニュースリーダー機能が付く予定か、同じインターフェースのニュースリーダーが登場する予定はないですか？

A. 作者さんのポリシーとして、Becky!はあくまでメールソフトであって、Becky!自体にニュースリーダー機能が搭載されることは無いだろう、ということでした。この作者さんの発言を聞いてがっかりしたユーザーも多かったでしょうね。

ですが、すばらしいことに、Becky!Ver.2でサポートされた「プラグイン・インターフェース」により外部からの機能拡張が可能になり、ニュースリーダー機能をBecky!に付加するプラグインソフトが開発されました。

しののんさんの「BkNewsプラグイン」をBecky!に組み込んで使ってみてください。

→ 関連項目
  • [10001] 「プラグイン」とは何ですか？


Windows CEでBecky!を使いたい

Q. [19005] Windows CEでBecky!を使いたい

携帯用にWindows CEマシンを買おうと思っています。ぜひBecky!を使いたいのですが可能でしょうか？もし使えないとしたら、CE版のBecky!が登場する予定はありますか？

A. 残念ながら使えません。Windows CEはWindows2000/NT/98/95と名前や操作方法は似ていても、中身は違うOSです。アプリケーションにも互換性は無いのです。

もちろんCE上で動くBecky!が開発されればいいのですが、残念ながら作者さんもお忙しく、少なくとも現在は対応予定はないようです。

→ 関連項目
  • [19006] 他のOSで動くBecky!の登場予定は？


他のOSで動くBecky!が登場する予定は？

Q. [19006] 他のOSで動くBecky!が登場する予定は？

他のOS（MacOS/Linux/FreeBSDなど）で動くBecky!が登場する予定はありますか？

A. これらのOSは、Windows9x/NTと根本的に設計が異なっているため、Windows用のソフトは動きません。また今のところ対応される予定も無い様です。

どうしてもBecky!を使いたい場合は、LinuxではVMWare、MacOSではSoftWindowsやVirtualPCと言ったエミュレータを使えば動く可能性があります。


他のメールソフトへの移行

Q. [19007] 他のメールソフトへの移行

今までBecky!を使ってきたのですが、諸事情により別のメールソフトに乗り換えようと思います。いままでのメールやアドレス帳の資産はどのように移せばいいでしょうか？

A. Becky!にはいくつかの代表的なメール保存形式のデータへ書き出す（エクスポート）機能があります。つまり、今後使うメールソフト側がそれらの形式のメールデータ取り込み（インポート）に対応していればいいのです。

Becky!が書き出せるメールデータ形式は下記の通りです。

  • UNIX mbox形式
  • eml形式
  • カスタム（メールの区切り文字列を指定可能）

移行先のメールソフトがどの形式のデータをインポートできるかは、それぞれのソフトのヘルプやサポート先で調べてください。

よくある質問として移行先がOutlook Expressの場合、eml形式で書き出した後、OEのメール一覧部にそれらのファイルをドラッグアンドドロップすればインポートできます。

メールデータの相互変換に関しては、ほんとさんの「よもやまメールデータ移行方法紹介のページ」が参考になります。

アドレス帳の移行は、Becky!側ではCSV形式（１レコード１行のテキスト形式で、１項目の区切りが半角カンマ）かタブ区切りテキスト（項目区切りがタブ文字）のファイルへエクスポートすることが可能です（アドレス帳のメニューから「ファイル」-「エクスポート」）。移行先のメールソフトのアドレス帳にてインポート、あるいは直接編集してアドレス帳データの形式にしてしまいましょう。詳細はそれぞれのソフトのヘルプやサポート先で調べてください。


PalmOS搭載機と連携させるには

Q. [19008] PalmOS搭載機と連携させるには

Becky!Ver.2で受信したメールをPalm/Workpad/Visor/CLIE/TRGpro（以下、PalmOS搭載機）で読んだり、PalmOS搭載機で受信したメールをBecky!Ver.2に取り込みたいのですが、どうしたらよいでしょうか？

A. お使いのBecky!がVer.2.00.05以降であれば対応しています。Palm側で同期する時に、HotSyncの対象として「Outlook Express」を指定して下さい。また、Becky!をお使いのパソコンでの「標準のメーラー」にしておく必要があるはずです。

ただし、同期できるのは「通常使うメールボックス」の受信箱および送信箱（下位のフォルダは含みません）のみと、フォルダ構成なども含めた完全な同期（や細かい設定）ができるわけではありません。あくまでMAPIで対応できる範囲でのものだそうです。

PalmOS搭載機と完全に連携させるためには、メールソフトとPalmOS搭載機との同期を行うソフト（コンジット）が必要となります。残念ながら、コンジットは今のところ（2001/04現在）開発されていないようです。

他に、メールをPalmで読める形式に変換するという方法もあります。

野間さん作のDoc形式変換プラグイン「Nicky」やTEMPESTさん作の「Becky!toDOC」を使うと、Becky!Ver.2で受信したメールを、PalmOS搭載機の標準文書形式であるDoc/MeDoc形式に変換して、Palm上で閲覧することができます。

PalmOS搭載機から送信したメールはBcc:に自分のアドレスを入れて、Becky!Ver.2で受信するようにすればいいでしょう。

アドレス帳については、Becky!Ver.2のアドレス帳のエクスポート機能で、カンマ区切りテキスト（CSV）またはタブ区切りテキストに変換しましょう。それらのファイルはPalm Desktopのインポート機能で読み込むことが出来ます。

→ 関連項目
  • [10001] プラグインとは何ですか？


相手がメールを読んだか確認したい

Q. [19009] 相手がメールを読んだか確認したい

A. メール作成ウィンドウで「ツール」-「開封確認をリクエスト」をONにすると、相手がメールを読んだときに「開封された」という情報を送り返してくれる機能があります。

これは、メールのヘッダに"Disposition-Notification-To""X-Confirm-Reading-To"というヘッダフィールドを付けることで実現されています。相手のメールソフトがメールを受信して表示する時に、これらのヘッダフィールドがあったら開封確認のメールを作成してくれるのです。もちろんBecky!も送り返しに対応しています。

しかし、当然の事ながら受信側のメールソフトがこれらのヘッダに対応していないと何も起こりませし、対応していた場合でもメールソフトでは通常これに対して応答するかどうかをユーザーに問い合わせますので、ユーザーに確認送信を拒否された場合も応答は返ってきません。

また、この機能をあまり好ましく思わない人もいますし、メーリングリスト等に送った場合はとんでもない事になりかねませんので、使用する場合は注意が必要です。

開封確認と違って相手のサーバーまで届いたことを確認できればいい場合は、メール作成ウィンドウの「ヘッダ」ボタンを押して出てくるダイアログの中の「Delivery Status Notificationを受け取る」にチェックを入れると、最終到達先のサーバーから到達確認の応答が送り返されてきます。ただし、これは比較的新しい機能のため、サーバーによっては対応していない場合がありますので、確認メールが返って来なくても「届いていない」ことを示しているわけではありません。

以前は"Return-Receipt-To"というヘッダを用いて同じ事をやっていましたが、メーリングリスト等にこのヘッダが付いたメールが流れた場合に、メンバーごとのそれぞれのサーバーから山のような応答が返ってくる等の問題があり、最近はこれ応答しないようなサーバーが増えているようです。

つまり、各種の方法がありますが、どれも完全ではありません。あくまでも補助手段と考えて使い、どうしても確実に確認したい用件の場合には「読んだら返信してくれ」と依頼するなど、相手との意思の疎通を図る必要があります。

→ 関連項目
  • [02034] 開封確認メールを送信できない


Internet ExplorerからBecky!を起動したい

Q. [19010] Internet ExplorerからBecky!を起動したい

ホームページのmailtoをクリックするとOutlook Expressが起動してしまうのですが、これをBecky!に変更する方法はありますか？

Becky! Ver.1では外部ツールを使ってInternet ExplorerからBecky!を起動していたのですが、Ver.2では設定できません。新しいツールはどれを使えばいいでしょうか？

A. Becky! Ver.2では外部ツールを使わなくても設定できるようになりました。Internet Explorerの「ツール」メニューから「インターネットオプション」-「プログラム」タブ-「電子メール」で「Becky! Ver.2」を選びましょう。

ただしWindows2000やXPをお使いの場合、管理者権限のあるユーザーでBecky!をインストールしないと、この欄に「Becky!Ver.2」を追加することができないようです。もし欄にBecky!が見つからない場合、一度管理者権限のあるユーザーにて上書きインストールをして下さい。


NetscapeからBecky!を起動したい

Q. [19011] NetscapeからBecky!を起動したい

Netscape NavigatorでWEBページを閲覧している時に、mailtoをクリックしてBecky!を起動したいのですが、どうすればいいでしょうか？

A. Netscapeのバージョンが4.xxまでの場合、Netscape Mail Dispatcherというツールを使って関連づけることができます。

  • プログラム(P)欄に C:\Program Files\RIMArts\B2\B2.exe
  • コマンドライン欄に mailto:$a

と記入しましょう。B2.exeの場所はお使いの環境に合わせて下さい。またこのツールを使う場合には、使用条件をよくご確認下さい。作者さんに問い合わせをしてはいけません。

mozilaやNetscape 6ではメールソフトの呼び出し方法が変更になったようで、上記のツールは使えません。しかしこれらのブラウザの場合は、付属のメールソフトがインストールされていない時にはInternet Explorer同様「インターネットのプロパティ」に従うようです。Netscape 6/mozilaのインストール時に「カスタム」でインストールし、途中でメールコンポーネントをインストール対象から外しましょう。すでにメールソフトをインストールしてしまっている場合、ブラウザを一度アンインストールしてからメールソフト抜きで再度インストールし直す必要があるようです。

→ 関連項目
  • [19010] Internet ExplorerからBecky!を起動したい


Becky!のデータ保管形式

この項はあくまでB2-FAQ-WGの推測に基づくもので、間違いや今後の変更があるかもしれません。記述に基づいてデータを直接編集されて万一トラブルがあったとしても、B2-FAQ-WGは責任を取れません。自己責任においてお願いします。

以下、Becky!上のフォルダは「メールフォルダ」、OS上の（エクスプローラなどから見える）フォルダは単に「フォルダ」と表記します。

Ver.1からの変更点

Becky!はVer.1→2の際にデータ保管形式が大きく変更されました。この項はBecky!Ver.2について記述したものであり、Ver.1にはあてはまりません。Ver.1のデータ保管形式は「Becky!ユーザーの部屋」の「ちょっといい話」-「Becky!のファイル・ディレクトリ構成」を参照してください。

主要な変更点は下記の表のようになります。

変更点 | Ver.1 | Ver.2
メールフォルダ の実体 | データ（.mbx） インデックス（.idx） フォルダ設定（.dat） の３ファイル | データファイルを納めた 同名のフォルダ
保存文字コード （日本語の場合） | Shift-JISに変換して 保存 | 受信したコードのまま （多くはJISコード）
添付ファイル | デコードして別フォルダ に保管 | メール内にエンコード されたまま

データフォルダ

データフォルダは、通常は"C:\Becky!\ログオン名"になります。「ファイル」-「システム」-「データフォルダの変更」で別のフォルダに変更することも可能です。

メールボックス

メールボックスの実体はデータフォルダに指定されたフォルダ以下の「《英数８文字》.mb」という名前のフォルダです。この英数８文字は作成日時に基づいて決定される文字列で、これがメールボックスの表示上の順番も決定します。

メールフォルダとフォルダの関係

ユーザーが作成したメールフォルダは実体も同名のフォルダです。受信箱や送信フォルダなど、Becky!上の特殊メールフォルダは下記のような名前のフォルダが実体です。

  • 受信箱→!!!!Inbox
  • 送信箱→!!!!Outbox
  • 草稿→!!!Draft
  • 送信済み→!!!Sent
  • リマインダ→!!!XReminder
  • ゴミ箱→!Trash
フォルダ構成

メールフォルダ内のファイル

各フォルダ内のデータファイルは下記のようになっています。

拡張子が.bmfのファイル

メールデータ本体です。複数のメールがまとめて保管されており、データがある程度以上に増えると自動的に分割されます。この分割サイズの目安は「全般的な設定」の「高度」にて設定できますが、特に理由がない限り変更しないほうがいいでしょう。ファイル名はメールボックスと同様に日時を元に決定されます。

メールは基本的に受信した状態のまま保存されています（つまり日本語メールの場合、文字コードはJISコードであることが多い）。添付されてきたファイルもエンコードされてそのまま付加されており、必要時に随時デコードされます。Subjectなどのヘッダの日本語もMIMEエンコードされたままです。

これによって今までデータを直接操作してきた人は注意が必要です。テキストエディタで開いても、通常のShift-JISとして表示すると文字化けしているように見えます。もちろん複数文字コードを扱えるテキストエディタなら編集は可能です。

しかし、Becky!内からもヘッダを含めたメール全体を編集できますので、あえてエディタを使ってデータを直接編集する必要は少ないでしょう。Becky!内からヘッダを含めたメール全体を編集する時は、まず「表示」-「ソースの表示」のあとに「メール」-「直接編集モード」に移ってください。

Folder.idx

メール一覧を保持したインデックスファイルです。

Folder.ini

フォルダの状態やプロパティでの設定内容を保持したファイルです。

アドレス帳データフォルダ

アドレス帳データはデータフォルダ配下の[AddrBook」フォルダに保管されています。Becky!内での「アドレス帳」は名前の先頭に"@"が付いたフォルダ、その配下のアドレスグループは同名のフォルダです。

アドレス帳のフォルダ構成

アドレスグループフォルダ内のファイル

拡張子が.babのファイル

アドレスデータ本体です。記述形式はvCard形式です。ファイル名はメールボックスやメールフォルダデータと同様に日時を元に決定されます。

Group.idx

アドレス一覧を保持したインデックスファイルです。中身はタブ区切りテキストですので、表計算ソフトなどで開くことができます。印刷する時などに利用可能です。

Group.ini

グループの開閉状態やニックネームなどを保持したファイルです。

その他のファイル

主なファイルについて説明します。

データフォルダ直下

Becky.key, DanaKey

キー定義ファイル

B2.kwd

キーワード定義ファイル

拡張子が.tmlのファイル

テンプレートです。テキストファイルなのでエディタで編集可能です。メールボックスフォルダ直下の#tmlフォルダにも各メールボックス用のテンプレートが収められています。

メールボックスフォルダ直下

ユーザー名@サーバー名.dat

POPサーバーに残されているメールの情報が記録されています。

IFilter.def

受信メール用振り分け定義ファイル

OFilter.def

送信メール用振り分け定義ファイル

Mailbox.ini, PRFxxxxx.ini

メールボックスの設定および各プロファイル設定ファイル

$$$xxxxx署名名.txt

署名ファイル。xxxxの部分は16進数で署名の順番を表しています。テキストファイルなのでエディタで編集可能です。

memo.txt

QuickMemo保存ファイル

????????.bkl

受信メールのバックアップログ。数字は日付を表しています。必要が無ければ削除しても動作に影響はありません。

????????.bks

送信メールのバックアップログ。数字は日付を表しています。必要が無ければ削除しても動作に影響はありません。


スレッド表示と修復

スレッド表示とは

「スレッド表示」とはメールのやりとりを、順を追って階層的に表示する機能です。スレッド（Thread）とは「(話・議論の)筋道、脈絡」という意味で、メールの並び順を話の筋道に従わせると考えればいいでしょう。仕事でのやりとりやメーリングリストでの話題ごとにメールをまとめることができて、非常に便利な機能です。

Becky!では「表示」-「スレッド表示」を実行するか、あるいはツールバーのボタンから切り替えることができます。

スレッド表示

まれに、メーリングリストへ新規投稿する際に他の投稿者のメールへの返信を利用してメールを投稿する人がいますが、これは好ましくありません。もうおわかりでしょうが、スレッド表示する際に違う話題がつながってしまいます。

スレッド表示モードならではの便利な機能もあります。Becky!Ver.2ではスレッド全体を先頭のメールにたたみ込むことができるようになりました。

スレッドを閉じた時

そして、折り畳まれている時に先頭のメールに行われた操作は、スレッド全体に適用されるのです。つまりスレッド全体を他のフォルダに移動したり、一括で「開封済み」の状態にしたりすることが簡単にできます。

スレッド表示の原理

Becky!や他のスレッド表示をサポートしているメールソフトは、メールのヘッダを利用して前後関係を判断しています。

どのメールにも"Message-Id"というヘッダにそのメール固有の文字列が書かれています。そして「返信」メールには通常、"In-Reply-To"や"References"というヘッダに返信元メールのMessage-Id文字列を記述してありますので、どのメールに対する返信かということがわかるのです。

スレッドの親と子のメールのヘッダを参照して、確認してみてください。

スレッド修復方法

しかし返信メールにも関らず、"In-Reply-To"や"References"を付加してくれないメールソフトも存在します。有名なところではOutlook Express Ver.4、MacintoshのEudora-Jなどです。つまり相手がこれらのメールソフトで返信してきた場合、こちらではスレッド表示ができず、途切れてしまうことになります。せっかくのスレッド表示なのに、これでは便利さが半減ですね。

そういう時は「表示」-「スレッドツール」を使ってスレッドを修復してしまいましょう。元メールを指定すれば、返信メールのヘッダに"In-Reply-To"や"References"を追加して、スレッドがつながるようにしてくれます。

ただしこのスレッドツール、マウスでメールを選択できないという点で少々使い勝手が良くありません。それを解決してくれるのが、しののんさんの「スレッド修復プラグイン」です。マウスでのメール選択や元メール検索機能、日付が前後している時の修正支援機能など、使いやすいインターフェースを提供してくれるプラグインです。

ただしスレッドツールを用いてもスレッドがつなげられないこともあります。下記関連項目も参照してください。

→ 関連項目
  • [06002] 日付が前後したメール間でもスレッドをつなげたい


未作成項目です。

現在、作成中です。


キー操作でBecky!を使う

この項ではBecky!のキー割り当てをまとめました。マウスを使わなくても、Becky!の機能はほぼ全て利用できます。

Windowsアプリケーション標準

Windowsアプリケーションの標準的なキー操作です。

F1 | ヘルプを開く。
Alt + F4 | ウィンドウを閉じる。
Alt または F10 | メニューバーをアクティブに。
Alt + 英数字 | メニューを開きます。メニュー名に付加されている(F)といった文字に対応し、Becky!内では、たとえばAlt + Fで「ファイル」メニューが開きます。メニューを開いた後は、Altキーを併用しなくとも英数字キーで各項目にアクセスできます。
Alt + Space | システムメニューを開きます。マウスを使わずともウィンドウの最小化やサイズ変更が行えます。
Tab | フォーカス移動。選択中の項目が変更されます。
Shift + F10 | フォーカスがある場所のコンテキストメニュー（マウスの右クリック時に出るメニュー）を開く。

Becky!のキー割り当て（変更可能なもの）

「ツール」-「全般的な設定」-「ショートカットキー」で割り当て変更可能な機能の、初期設定一覧です。

  • 標準のショートカットキー割り当て（機能順）
  • 標準のショートカットキー割り当て（キー順）

Becky!のキー割り当て（変更できないもの）

メインウィンドウ

全般
Space | 未開封メールジャンプ（メールの最後までスクロール後、次の未開封メールへ）。
Ctrl + Space | 未開封メールジャンプ（メールを最後まで表示せず、次の未開封メールへ）。
Shift + Space | 表示中のメールを逆スクロール。
Tab | フォーカス循環。メールボックス選択リスト→ツリービュー→リストビュー→メッセージビュー→添付ファイル（ある場合）→タブシート→タブ切り替わり
Shift + Tab | フォーカス循環。「Tab」の逆順。
Ctrl + Tab | フォーカス循環。ツリービュー→リストビュー→メッセージビュー
ツリービュー
↑ | 一つ上のフォルダへ。
↓ | 一つ下のフォルダへ。
← | ツリーを閉じる。すでに閉じられている時は、親フォルダに移る。
→ | ツリーを開く。すでに開かれている時やサブフォルダがない時は、ひとつ下のフォルダに移る。
英数字 | 名前がその文字で始まるフォルダもしくはメールボックスにジャンプ。連続文字入力でフォルダを絞りこめます（「B2」と素早く打ち込めば、フォルダ名の先頭がB2であるものに移ります）。
リストビュー
Home | リストビュー最上段のメールへ。
End | リストビュー最下段のメールへ。
Shift + ↑または↓ | 複数メールを選択
← | （スレッド表示モード時）一つ上の親へ。スレッド先頭の時はそのスレッドを閉じる。
→ | （スレッド表示モード時）スレッドを開く。
Ctrl + ← | （スレッド表示モード時）スレッド先頭へ。
→ | （スレッド表示モード時）一つ下の子メールへ。スレッドが閉じている時は開く。
Ctrl + → | （スレッド表示モード時）次の兄弟へ

メール作成ウィンドウ

全般
Tab | フォーカス移動。宛先→（Cc:）→（Bcc:）→件名→本文部
Shift + Tab | フォーカス移動。本文部（非本文選択時）→署名→（Sender:）→（Reply-To:）→件名→（Bcc:）→（Cc:）→宛先（この後は署名に戻り循環）
宛先等入力欄
Ctrl + ↓または↑ | Cc:、Bcc:、Reply-To:、Sender:入力項目の表示・非表示

キー操作のTips

添付ファイルを開く／保存

  • Tabキーで添付ファイル表示部にフォーカスを合わせる。リストビューの次。
  • →キーを押すと添付ファイルが選択される。Shiftキー併用で複数選択可能。
  • Enterで「開く」。
  • 保存するには、Shift + F10でコンテキストメニュー表示後、「名前を付けて保存」。

複数のメールの選択

リストビューにて

  • Shift + ↑↓で連続範囲のメールを選択可能。
  • Ctrlを押しながら目的のメールに移動し（↑あるいは↓）、→で選択。非連続の複数メールを選択可。ただしスレッド表示モードの時は機能しない。


ドラッグアンドドロップでできること

Becky!の機能

ドラッグ元 | オブジェクト | ドロップ先 | 動作・機能
メインウィンドウ
リストビュー | メール | ツリービューの他のフォルダ | メールの移動（CTRL + の場合はコピー） ※ALT + の場合は振り分けルールダイアログオープン
 |  | ツリービューのメールボックスアイコン | そのメールボックスに移動し、振り分け
 |  | メール作成ウィンドウ | 作成途中のメールに添付メールとしてセット
外部（デスクトップやエクスプローラなど） | ファイル | メインウィンドウの任意の場所 | 新規メール作成ウィンドウを開き、添付ファイルとしてセット（SHIFT + でエンコード方式を選択可能）
メッセージビュー（添付ファイル部） | 添付ファイル | 外部（デスクトップやエクスプローラなど） | デコード&ファイル保存
 |  | メール作成ウィンドウ | 作成中のメールに添付ファイルとしてセット（SHIFT + でエンコード方式を選択可能）
 |  | メインウィンドウ | 新規メール作成ウィンドウを開き、添付ファイルとしてセット（SHIFT + でエンコード方式を選択可能）
メール作成ウィンドウ
外部（デスクトップやエクスプローラなど） | ファイル | メール作成ウィンドウの任意の場所 | 作成途中のメールに添付ファイルとしてセット（SHIFT + でエンコード方式を選択可能）
メール作成ウィンドウ | 文章 | メール作成ウィンドウ | 選択範囲の文章を移動（CTRL + の場合はコピー）
アドレス帳
アドレス帳のリストビュー | アドレスアイテム | 宛先リスト、または"To:""Cc:""Bcc:"タブ | アドレスをそれぞれの欄にセット
宛先リスト |  |  | アドレスをドロップ先の欄に移動
クエリー検索結果ウィンドウ
検索結果リスト | メール | ツリービュー | メールの移動（CTRL + の場合はコピー） ※ただし、ツリービュー上で現在開いているフォルダにはD&D不可
ツールバー（メイン・メール作成ウィンドウ）
ツールバー（Altを押しながら） | ボタンまたはセパレータ | ツールバー内のボタンを移動したい場所 | ボタンの並び順の変更
ツールバー（Altを押しながら） | ボタンまたはセパレータ | ツールバー外 | ボタンまたはセパレータの削除
ツールバーの変更ダイアログ
"利用できるツールバーボタン" | ボタン | "現在のツールバーボタン" | ツールバーボタンの追加
"現在のツールバーボタン" |  | "利用できるツールバーボタン" | ツールバーボタンの削除
 |  | "現在のツールバーボタン" | ツールバーボタンの表示位置変更

ドラッグアンドドロップのTips

ドロップしたいウィンドウが隠れている！そんな時は、

  1. ドラッグしたままタスクバーにカーソルを持ってゆき、目的のウィンドウのボタンの上で（マウスのボタンを押したまま）待つとそのウィンドウがアクティブになります。あとはウィンドウまで持っていってドロップ。
  2. ドラッグしたまま [Alt]+[Tab] を押せばウィンドウが切り替わります。あとはやはりそのままドロップ。

また他のドラッグアンドドロップに対応したアプリケーションと、オブジェクトのやりとりができます。下記はインターネットエクスプローラ（Ver.4以降）からの場合です。

  • リンク→メール作成ウィンドウ(本文領域)：リンク(URL)の挿入
  • ウィンドウ左上のアイコンまたはアドレスバーのアイコン→メール作成ウィンドウ(本文)：ページのURLを挿入
  • 表示されている文章またはテキストボックス内の文章（選択領域）→メール作成ウィンドウ(本文)：その文章の挿入
  • 画像→メインウィンドウ：その画像を添付した新規メール
  • 画像→メール作成ウィンドウ：その画像を添付

その他，テキスト形式のDrag&Dropに対応したツール類（Visual Studioのエディタなど）とメッセージビュー（本文）・メール作成ウィンドウ（本文）との間で、選択したテキストのやりとりができます。


メールのヘッダについて

ヘッダって何？

ヘッダとはメールの各種属性情報を記録する部分のことです。一般には、宛先、差出人、メッセージの用件、返信先などの情報が記録されています。

Becky!内でメールのヘッダ部を見るには、３種類の方法があります。

  • 「表示」メニューの「ヘッダの表示」。
  • マウスカーソルをメッセージビュー下部に移動し、表示されるタブシートのうち「0:ヘッダ」というタブを選択する。
  • Tabキーを押下。何回目かでフォーカスがヘッダ表示部に移ります。

他にもミドルバーの「差出人」「宛先」といったラベル部分をクリックすると、関連ヘッダフィールドを一覧できます。その一覧中のアドレス情報をクリックすると、そのアドレス宛にメールを書いたり、アドレス帳に登録できたりと、有効に利用できます。

主なヘッダフィールド

From:

差出人情報です。Becky!内では、リストビューやミドルバーの「差出人」に、この情報が表示されます。

またBecky!から送るメールでは、基本的に「メールボックスの設定」-「基本設定」の「名前」と「メールアドレス」が用いられれます。

ただし、ここに書かれたアドレスが確実に差出人本人のものとは限りません。存在していないアドレスや他人のアドレスであってもメールを送ることはできます。つまり差出人を詐称される可能性もあるということです。実際の手紙や葉書と同じようなものだと考えておきましょう。もちろん、故意に他人のメールアドレスを偽るのは重大なマナー違反です。またReceived:フィールド（下記）から配送経路をたどることも可能ですから、完全な詐称はできません。
To:

宛先です。複数の宛先に送る場合には、","（いわゆる半角カンマ）で区切って記述します。

Subject:

メールの表題や内容の要約です。

Becky!内では、リストビューやミドルバーの「件名」に、この情報が表示されます。

Cc:

カーボンコピー、つまり「メールの写しを別の宛先にも同時に送っておく」という意味合いです。たとえば、仕事の取引先へ（To:への指定で）送るメールを、報告として「Cc: 上司のアドレス」で上司にも届くように指定する、といった使い方が考えられます。

Becky!内では、ミドルバーにこの情報が表示されます。

Bcc:

ブラインドカーボンコピーの略と言われ、機能はCc:とほぼ同じです。ただし、違うのは「Bcc:フィールドはメールには書き込まれない」という点です。「写しを送ったことは、To:の相手先には知らせたくない」という場合に使います。たとえば、アドレスを複数持っている人が、別のアドレスでも送ったメールの控えを取っておきたい時に、「Bcc: 別のアドレス」と指定するという使用例が挙げられます。

Date:

メールの送信日付・時刻です。

Reply-To:

From:アドレスとは別のアドレスに返信してほしい場合に付加するフィールドです。通常、このフィールドがあるメールに「返信」すると、メールソフトはFrom:アドレスではなく、このフィールドに記述されているアドレス宛に返信メールを作成してくれるはずです。

たとえばメーリングリストでは、発言者へ直接返信するのではなく、メーリングリストへ返信したい場合が多いですよね。そのためメーリングリストサーバーが、自動で「Reply-To: MLのアドレス」を付加してから配信してくれることが多いのです。

もちろん送信者が自分で付加することもできます。

Sender:

From:とは違う人（アドレス）から配信されたということを示すフィールドです。

たとえばメーリングリストへの発言はFrom:アドレスからされたけど、全員に配信するのはメーリングリストのオーナーから、という意味合いで、MLサーバーが自動で「Sender: MLオーナーのアドレス」を付加してから配信してくれることが多いです。

Message-ID:

メールを特定するための固有の番号・文字列です。他のメールと重ならないように、メールソフトやサーバーが付加してくれます。

Becky!は自動的にMessage-IDを付加してくれますが、「全般的な設定」-「送信」にて「Message-IDを送信しない」動作にも変更できます。特に理由がなければこの設定を変更する必要はありません。

In-Reply-To:

このメールが「どのメールに対する返信か」を示すヘッダフィールドです。通常は返信元のメールのMessage-IDが記述されています。

Becky!はこのフィールドとReferences:を用いてスレッド表示を実現しています。

References:

このメールが「どのメールを参照して書かれているか」を示すヘッダフィールドです。通常は返信元のメールのMessage-IDが記述されています。

Becky!はこのフィールドとIn-Reply-To:を用いてスレッド表示を実現しています。

In-Reply-To:との違いは、返信先のスレッドをさかのぼって、複数の参照先を記述することがある点です。Becky!の場合、標準では２つ前のMessage-IDまで参照するようです。しかし明確な規格があるわけではなく、メールソフトごとに記述が異なります。

Received:

メールは通常、複数のサーバーを経由して運ばれますが、その中継したサーバーが付加するフィールドです。つまり、受信者がどのような経路で運ばれたメールかを確認することができます。当然複数のReceived:フィールドが付加されており、最新は上、つまり下から上へという順番で経路をたどれます。

Content-Type:

メールの中身がどのような形式かを示しています。

たとえば、本文のみの日本語メールの場合、通常は
"Content-Type: text/plain; charset="ISO-2022-JP""
といった記述がされているはずです。ここに日本語(ISO-2022-JP)であるという情報も同時に書かれているということです。

ファイルが添付されたメールなど、いくつかのPartに分けられているメールもあります。そのような場合は
"Content-Type: multipart/mixed; boundary="《区切り文字列》""
のように記述されています。なお、メールの構造については、メールの「プロパティ」で見ることができます。また、「表示」-「ソースの表示」にて生のメールデータを参照すると、添付やMultiPartがどのような仕組みか参考になるでしょう。

X-??????:

先頭に"X-"が付くヘッダフィールドは、特に決まった規格がなく、メールソフトや送信者が任意に付けたものであることが多いです。しかし、中には慣習化したものもあります。また、その性質上、遊び心で付加されることも多いようです。

X-Mailer:

そのメールが、どのメールソフトから送信されたかを示すヘッダです。Becky!の場合、"Becky! ver. 2.00"といった文字列が記述されます。

X-ML-Name:

fmlというメーリングリストサーバーが付加する、そのメーリングリストの名前です。振り分け条件に指定すると便利ですね。

X-Face:

48×48ピクセルの画像を文字列に変換して付加したものです。自分の似顔絵などを送ったりします。[参考ページ]

当然、メールソフトが送信・受信と表示をサポートしてなくては意味がないですが、Becky!ではふるかわあきひとさんの「X-Faceプラグイン」で実現できます。

X-Moe:

・・・・・。実際に使われている例を見て確認してください(^^;。

送信メールのヘッダを変更するには

送信時には、Becky!が適切なヘッダフィールドを付加してくれます。しかし、複数のメールアドレスを持っていて、相手によってFrom:のアドレスを使い分けたい場合など、ヘッダを変更したいこともあるでしょう。

一時的にそのメールだけ書き換えたいという場合には、メール作成ウィンドウの「ヘッダ(M)」ボタンを押すと編集ダイアログを出すことが出来ます。また、Cc:、Bcc:、Reply-To、Sender:といった基本的なヘッダは、ヘッダ欄にフォーカスがある時にCtrl+↓または↑キーを押すことで入力欄を表示・非表示にできます。

状況に応じてヘッダを使い分けたい場合は、フォルダと関連づけましょう。「フォルダのプロパティ」にて、そのフォルダを開いている時に作成するメールヘッダの初期値を指定できます。また、テンプレートを用いると、ヘッダをより思い通りに指定することができます。これらの使い方に関してはBecky!のヘルプを参照して下さい。

アドレスの記述形式

アドレスを含むヘッダフィールドには、下記のような３つの形式でアドレスが記述されます。

  • Name <address>
  • address (Name)
  • address

Becky!ではFrom:アドレスは１番目の形式が使われます。また、アドレス帳から入力する形式については、アドレス帳のメニューから「ツール」-「入力形式」で選択できます。

ここで注意すべきは、"Name"で使える文字です。上の形式を見て分かるように、"Name"の部分に"<>()"といった文字を使うと、メールソフトやサーバーがアドレスと名前の区切りを判断できなくなってしまいます。たとえば
"(株)床園商事営業部 <eigyo@dokosono.com>"
といった場合、送信時にエラーが起きたり、宛先不明で戻って来たりしてしまいます。","も複数アドレスの区切り文字ですので、同様に問題が生じやすいです。

Nameを""で囲むといった対応策もありますが、ソフト側の実装もまちまちで、完全に対応できるわけではありません。基本的には、上記の問題の起きやすい文字は使わない方がいいでしょう。

ヘッダ内の日本語の扱い

ヘッダ中に日本語などの2byte文字があると、配送途中で必要な情報が落とされてしまったり、場合によってはメールが分断されてしまったりすることがあります。基本的にヘッダ中にはASCII文字（いわゆる半角英数文字）以外の文字は使えないと考えた方がいいでしょう。

ですが、たとえばFrom:フィールドに日本語で自分の名前を記述したい場合もありますよね。それに日本語でSubject:を書けなかったら、日本人同士でメールのやりとりをする場合には不便極まりないです。

それを解決するために、MIMEという変換規格が用いられています。つまりメールヘッダ中の日本語（や、他の非ASCII文字を使う言語）は、配送途中ではエンコードされたASCII文字列となっているのです（まれにJISコードの場合もあります）。

例：
「先日の会合の件について」という文字は
「=?ISO-2022-JP?B?GyRCQGhGfCROMnE5ZyRON28kSyREJCQkRhsoQg==?=」
と変換されています。

Becky!は、受信したまま、あるいは送信する形式のままメールを保管しており、データ中では日本語はMIMEエンコードされたままです。「表示」メニューの「ソースの表示」にてメールデータを生で見ることで、エンコードされている様子がうかがえます。ただし、通常利用している時にはデコードされて表示されているので、ユーザーが特に意識する必要はありません。


メールを書く時に注意すること－ネチケットについて

インターネットでのコミュニケーション、特に電子メールのやりとりは、依然として文字が中心です。

文字だけのコミュニケーションは対面や電話でのそれと違い、相手の表情や声色でニュアンスを感じ取ることができません。声に出して伝えれば他愛のない言葉も、文字にするととてもきつい印象を与えることがあります。

また、特に電子メールの場合、相手がどのような環境で読み書きしているかわかりません。ダイヤルアップの低速な通信環境であったり、携帯端末の必要最小限なメール機能だけであったり。当たり前のことですが、皆がWindowsを使っているわけではないのです。

そのような表現や技術上の制約は、１対１でメールをやりとりしている時にはあまり問題にならないかもしれません。しかし、メーリングリストなどに参加すると、多数の人々と意見を交換する機会が格段に増えます。しかも、立場や考え方がまったく違うことも珍しくありません。そういった人たちと出会えるのがインターネットの魅力でもありますが、一方で、残念ながら無用の揉め事のもととなることもあります。

そのため、インターネットのコミュニケーションには「～～に気をつけましょう」という慣習的ルールが次第にできあがってきました。それらを「ネチケット」と呼びます。

ネチケットとは、「ネットワーク」と「エチケット」を組み合わせた言葉です。これは和製英語ではなく、英語圏でもちゃんと通用する言葉です。ちなみに英語ではNetiquetteと書きます。

エチケットというくらいですから、これは礼儀です。食事のテーブルマナーと同じようにちょっとしたルールはありますが、「～しなければならない」とか「～してはならない」と強制されるものではなく、お互いが気持ちよく過ごすための気配りだと思ってください。

一般に、メールにおけるネチケットには次のようなものがあります。

  • 素っ気なさすぎない程度に簡潔な表現を心がけましょう
  • 送信する内容には慎重さを、受信する内容には寛大さを心がけましょう
  • 引用は必要最低限に留め、無用の部分は省略しましょう
  • 一行は長くても80桁未満で折り返しましょう
  • 署名は大きく（長く）なりすぎないようにしましょう

また、インターネット全般に関するネチケットガイドラインもRFCなどで公開されています。参考になる事柄も多いですから、一度目を通してみることをお薦めします。

  • ネチケットガイドライン（RFC1855）の邦訳
  • ネチケットホームページ

もちろん、これらに書かれていることも強制ではなく、「こうしたほうがこちらの意図が正確に伝わりますよ」という助言に過ぎません。読んでみると「当たり前」と感じることも多いです。つまり、インターネットだ、ネチケットだ、と難しく考えることはありません。

「文字だけのコミュニケーション」特有の注意点さえわかってしまえば、あとは日常生活で心がけている気配りの、ほんの少し延長上にあるだけです。


使ってはいけない文字、使わない方がいい文字について

なぜそんな文字があるの？

インターネットでの文字表現、特に電子メールでは「使ってはいけない文字」や「使わない方がいい文字」があります。

コンピュータで文字を扱う時、内部では一文字一文字に数値（コード）を割り当てて処理しています。ところが日本語には、発生の歴史的経緯などからJISコード、Shift JIS、EUCなど何種類もの文字コードがあり、機種やOSによって採用しているコードが異なるのです。

たとえば、UNIXではEUC、WindowsとMacintoshではShift-JIS（ただし改行の扱いが異なる）が主流ですが、設定変更やアプリケーションごとの対応によって、採用されている以外の文字コードも扱うことはできないわけではありません。また近年、多くの言語に対応するUNICODEという文字コードも推進されており、Windows 2000などでは内部処理はUNICODE化が進められています。

異なる文字コード間であっても同じ文字だけしかないのであれば、単純に変換すればいいだけなのですが、ある文字コードに存在する文字が、他の文字コードには存在しない場合もあるのが厄介です。つまり様々な文字コードが氾濫している状況が問題の一つなのです。

では、同じ文字コードを採用していればお互いに問題なく文章のやりとりができるかというと、残念ながらそうとも言い切れません。文字にも様々な種類があり、規格に納め切れないものがあります。また、規格が決めていない一部のコードを勝手に利用して文字を割り振っていることがあったりするために、Windowsで意図した文字が、Macintoshでは違う文字として表示されたりしてしまうことが起きてしまいます。

このようにいくつかの理由によって、「使ってはいけない文字」や「使わない方がいい文字」が存在してしまうのです。これら、異なる機種や環境の間でメールのやりとりをするために、メールを送る時の言語情報の規格が存在します。その内の一つ、日本語のメールを送るための規格の主流がISO-2022-JPです。しかし、それで環境の違いが吸収し切れているわけでもありません。

それらの文字を総称して「機種依存文字」と呼んだりします。もっとも「機種」だけに依存しているわけではないので、正確な呼称とは言えません。

具体的にはどんな文字？

では、具体的にどのような文字に気をつければいいのでしょうか。

使ってはいけない文字

代表的なものが、いわゆる「半角カナ」です。これはISO-2022-JPに定義されていないため、送ることができません。半角カナまじりの文章をどうしても送りたい場合は、後述の項を参照してください。

いわゆる「半角」「全角」という区別は正確な呼び方ではありませんが、ここでは広く使われている呼び方にしたがって表記しておきます。
使わない方がいい文字

いわゆる全角記号のいくつかが相当します。たとえば丸囲み数字やローマ数字などは、フォントにもよりますが、Windowsマシン以外ではまったく違う文字として表示されてしまうと思っておきましょう。下記はその一例です。

Widows上の文字列
Windows上でこれらの文字が入ったメールを書くと
Macintosh上の文字列
Macintosh上ではこのように表示されます。

その他にも下図の文字は注意が必要です（これら以外にも存在します）。

使わない方がいい文字列（例）

より詳しい情報や技術的な解説については、下記のサイトが参考になるでしょう。

  • しまやさんの「Becky!非公式ホームページ」-「電子メールについて」-「機種依存文字」
  • 滝沢さんの「Taki Internet Mail Private Lab.」-「インターネットメイルに関すること」-「使ってはいけない文字」

Becky!でメールを書く時は

ところが、Becky!でメールを書いている時には、「使ってはいけない文字」「使わない方がいい文字」を色ちがいで表示してくれます。

使ってはいけない文字のカラー表示

これらは「ツール」-「全般的な設定」の「キーワード」で分類と色設定が行われています。「半角カナ」「新JIS追加文字」「機種依存文字」というグループが、最初から「気をつけるべき文字群」として登録されているのです。

逆に言えば、文章を書いていてある文字だけ色が変わってしまう場合（自分でキーワード登録したものを除く）、それは相手にちゃんと表示されない可能性がある文字だということです。なるべくその文字を使うことを回避しましょう。

ただし、「送ってはいけない文字」として、半角カナは草稿フォルダに納める時や送信する時に、自動で全角カナに変換されます。

半角カナをどうしても送りたい時は

「使ってはいけない」とは言っても、相手のマシン環境がわかっている上で「レイアウト上、あまり文字幅を取りたくない」といった理由で、半角カナまじりの文書を送りたいこともあるでしょう。その場合には、下記のような方法があります。

添付ファイルとして送る

メール本文に書かずに、テキストファイルやワープロのデータファイルにし、それをメールに添付して送れば問題はありません。

ISO-2022-JPではなくShift_JISとして送る

半角カナが定義されている言語コードでメールを送ってしまうという手段もあります。Becky!内でShift_JISで送るには、まずその言語コードを追加してやる必要があります。

  1. 「ツール」-「全般的な設定」-「言語／フォント」にて、下記の条件を追加。

    キャラクタセット名 | shift_jis
    エンコーディング | 8bitまたはBase64
    コードページ | 932
    説明 | 任意。たとえば「JIS X 0201-kana」

  2. メールの作成時、言語を shift_jis に変更。

    • メール作成時、右下の地球マークをクリックします。
    • 先程追加した「JIS X 0201-kana (shift_jis)」を選択します。
    • 通常通りメールを記入して、送信します。

この方法であれば、半角カナを使っても色ちがいにはならず、通常通り記述して送信できます。

ただし、相手のメールソフトによっては、Shift_JISに対応しておらず、正常に表示できないことがあります。また、エンコーディングが「8bit」だと、途中のサーバーで情報の欠落が起きる可能性もあります。かといって「Base64」では、メールソフトが対応していない可能性がより大きくなります。

結局相手のメール環境を調べてからでなくては使えませんので、ご注意を。


添付ファイルについて

手軽に送れる「添付ファイル」ですが、注意が必要なこともあります。仕組みを理解して有効に利用しましょう。

添付ファイルの仕組み

E-Mailは基本的に文字情報を送るためのシステムです。では、どうやって文字情報ではないファイルを送るのか。それは、ある変換ルールにしたがってファイルを文字情報に変換（エンコード）してメールに付加し、相手方が受信した後にその変換ルールにしたがって文字情報から元のファイルに変換（デコード）するという手順を踏んでいるのです。

最近のたいていのメールソフトはエンコード/デコードを自動で行ってくれますので、ユーザーが意識してエンコード/デコードする必要はあまりありません。

Becky!Ver.2では、添付ファイルはエンコードされたままの状態でメールに保管されており、開く時など必要がある時ごとにデコードされる仕様になっています。添付ファイルがあるメールを表示して「表示」-「ソースの表示」によってメールを生で表示させると、ファイルが何行もの文字列として付加されている様子を見ることができます。

変換のルールは何種類もありますが、代表的なものは以下の３種類です。

  • Base64（もっとも標準的な規格）
  • uuencode / uudecode（UNIXで伝統的に使われてきた規格）
  • BinHex（Macintoshで使われてきた規格）

もちろんBecky!は送受信ともこの３種類に対応しています。通常はインターネット標準とも言うべき「Base64」が主流です。最近はOSやメールソフトによらずBase64の対応度が高いですから、通常こちらから送る時は、まずBase64で送りましょう。

文字化けのように見えますが

まれに、Becky!が送られてきた添付ファイルを認識できず、エンコードされた文字列が表示されてしまうことがあります。初心者は「文字化けか？」と驚くようですが、文字列自体には問題はありません。その場合は「ツール」-「解読」-「uudecode」か「BinHexデコード」を試してみましょう。

また、大きなファイルが添付されたメールが分割されて送られてきた場合（Subjectに[1/5]のように「順番/分割総数」が付加されています）もエンコードされた文字列が生で見えてしまいます。これはリストビューにてそのうちの一通をダブルクリックすると結合することができ、その後は通常の添付ファイルとして扱われます。

添付ファイル送信時の注意

どんなファイルでも気軽にメールに添付してしまいがちですが、ちょっと待ってください。気をつけなくてはならない重要な事項があります。

ファイルのサイズに注意！

E-Mailはいわばバケツリレーでメールを受け渡していくシステムです。世の中には非常にたくさんのメールが流通しています。そこに大きなファイルが添付されたメールが流れてしまっては、途中経路に負荷をかけて流れが滞ってしまうこともあるのです。

また相手がインターネットプロバイダにダイヤルアップで接続している場合、受信に時間がかかるばかりでなく、相手が利用しているプロバイダのメールボックス制限を大幅に越えて溢れさせてしまうということにもなりかねません。受信にも時間がかかりますし、その間にエラーが起きてしまったら、何回でも受信し直さなくてはならない羽目に陥ることもあります。

したがって、添付する前にサイズを確認して、あまり大きなファイルはメールで送ることはやめましょう。

メールサイズの上限に統一されたルールはありませんが、数十キロバイト程度に抑えるべきだと主張する古くからのE-Mailユーザーもいます。現在ではインターネット基盤も整備されつつあるとはいえ、メガバイト単位のファイルを送るのはやめた方がいいでしょう。そのようなファイルを渡したい時は、フロッピーディスクやMO、CD-Rなど外部メディアを利用して受け渡すべきです。あるいはhttpプロトコルを利用（いわゆるWEBサイトにアップロード）して相手にダウンロードしてもらうのも有効です。

社内イントラネットの場合はこの限りではありませんが、それでもファイルサイズには注意しましょう。

たとえば、最近のデジタルカメラは精細度の向上が進んでいますが、その結果、一枚の写真データですら数百キロバイト以上になることが当たり前です。メールに添付する時はくれぐれもご注意を。

またメーリングリストなど不特定多数の利用者がいる場所での添付ファイルも、そこで許可が明言されていない限りは流してはいけません。

どうしてもある程度の大きさのファイルを添付したい時は、下記を考慮して添付しましょう。それほど大きくないファイルであっても同様に心がけておくことが好ましいです。

ファイルの圧縮

LZHやZIPという形式でファイルを圧縮してから添付すれば、データの送信量を減らすことができます。テキストファイルやMicrosoft WORDのデータなどは、圧縮することで半分以下にまでサイズを減らせます。ただし、すでに圧縮されているJPEG画像などは圧縮効果があまりありません。

サイズが小さくなるというほかに、複数のファイルやフォルダ構成を一つのファイルにまとめられる、長いファイル名を持ったファイルを圧縮して別名にすることで問題（後述）の回避ができる、というメリットもあります。

ただし、相手が圧縮ファイルを展開するソフトを持っている必要があります。

一般に圧縮にも専用のソフトが必要ですが（Windows MEは標準でZIPに対応してます）、安藤亮太さん作の「圧縮添付プラグイン」を組み込むと、Becky!でファイルを圧縮してから添付することが非常に簡単な手順で可能になります。

分割

大きいメールを分割して送信することで、転送時のリトライなど途中経路のサーバーの負荷を少々減らすことができます。Becky!では「全般的な設定」の「送信」にて分割メールのサイズを設定できます。ただし、データ総量自体は分割後もそれほど変わらず（むしろヘッダ分、若干増えてしまう）、根本的解決にはなりません。また相手のメールソフトが分割メールを統合することができる必要もあります。

ファイル名に注意！

相手がどのコンピュータ・OSやメールソフトを使っているかによって、日本語などの非ASCII文字を含んだファイル名や長いファイル名がうまく伝わらないことがあります。まだファイル名送信のための統一規格が浸透していないのが原因です。

インターネットに関するルールを文書化したRFCの2231では、添付ファイル名の多言語での扱いを規定しており、Becky!も対応しています。ところが、残念なことに現時点（2000年11月）では、このRFC2231の規格に対応したメールソフトはまだ多くありません。したがって、相手のメールソフトによっては、古くからある（しかし問題がある）形式でファイル名を送らなくてはいけません。Becky!では、「全般的な設定」-「送信」にて、どの形式でファイル名を送るか設定出来ます。今後は、周辺のメールソフトの対応度を見ながら、徐々にRFC2231形式に移行していく方がいいでしょう。

そのような規格に気を使わずに確実にファイル名を受け渡すには、日本語を使わずにいわゆる半角英数で８文字以内のファイル名にしましょう。あるいは、送りたいファイルを圧縮し、書庫ファイルを問題のないファイル名にして添付するのもいいでしょう。

ファイル名がうまく伝えられない時のために、本文中にファイルの名前や形式を明記しておくのも有効です。

添付ファイルを受け取ったら

手軽な添付ファイルですが、そのためにコンピュータウイルスの感染ルートとなることも多いです。知らない人から送られてきたファイルを開くことは絶対しないでください。知り合いからの添付ファイルであっても、いったんウイルスチェックをする方がいいでしょう。

コンピュータウイルスについては、関連項目を参照してください。

→ 関連項目
  • [30006] コンピュータウイルスについて


コンピュータウイルスについて

コンピュータウィルスとは

コンピュータウイルス（以下ウイルス）とは、他人のプログラムやデータに対して意図的に何らかの被害を及ぼすように作られたプログラムの一種です。このようなプログラムはコンピュータ上での存在方法や侵入方法によって、ウイルス・ワーム・トロイの木馬などに分類されます。しかし、最近ではこのようなプログラム全般を指して「ウイルス」と呼んでいることが多いようです。本項でも総称して「ウイルス」と表記することにします。

一般に、ウイルスによって下記のような被害を受けることがあります（もちろん症状はこれらに限りません）。

  • 自分のコンピュータ内のファイルを削除されたり、書き換えられたりしてしまう。
  • コンピュータが正常に動作しなくなる。
  • アドレス帳に載っているメールアドレス宛に勝手にメールを送ってしまう（特定のメールソフトを対象にしたウイルス）。
  • メールを送る時にウイルスが自分自身を勝手に添付して、他のコンピュータにも被害を拡大する。

ウイルスに感染し、それを他人に移してしまうことは信用問題になり得ます。以下に述べることやリンク先のWebサイトで情報を知ることによって、自分の身を守るようにしてください。

最大のポイントは「ウイルスは必ず特定の種類のファイルのやりとりを行うことによって感染する」ということです。最近はメールにファイルを添付してやりとりすることが多くなったため、ウイルスの広がる速度も速くなっています。

ただし、単にメール（HTMLメールは除きます。別項を参照して下さい）を読んだだけで感染するウイルスは存在しません。ときどき、"Good Times"、"PENPAL GREETING" や "JOIN THE CREW" などという「メールを読むだけで感染するウイルス」についての情報が流れてくることがありますが、無視してください。もし、真偽が確認できない場合は下記のリンク先にデマウイルス情報コーナーがありますので、調べてみてください。

気を付けるべきファイルの種類

  • 実行可能なファイル
    *.exe、*.dll、*.com、*.bat、*.pif、*.cmd、*.vbs、*.shs、*.js、*.scr、*.chm、*.vbe、*.jse など
  • Windows の設定に関係するファイル
    *.reg、*.inf、*.lnk、*.url など
  • Microsoft Office のデータファイル
    *.doc、*.xls、*.ppt、*.mdb、*.rtf など

そのほかにも、Lotus 1-2-3 や一太郎などのマクロ機能があるアプリケーションのデータファイルを開く場合は十分に気を付けましょう。

Becky!Ver.2では、特定の種類の添付ファイルを開くときに警告メッセージが出るようになっています。警告を出すファイルの追加も可能です。必要に応じて、「全般的な設定」-「全般」-「このファイルタイプの添付ファイルを開く時警告」で追加してください。

また、これらに限らず添付されてきたファイルはむやみに開かないという慎重さも必要です。

普段から注意するべきこと

感染しないためには

  • アンチウイルスソフトをインストールし、常にウイルス定義ファイルを更新する。アンチウイルスソフトをインストールしただけでは意味がありません。
  • 見知らぬ人から受け取った添付ファイルは絶対に開かず、直ちにメールごと削除する。
  • 知人から送られてきた添付ファイルであっても、予告なしに送られてきたものは開かない。相手に添付ファイルの名前を伝え、そのファイルを送ったかどうかの問い合わせを行う。
  • 受け取ったり、ダウンロードしたファイルは必ずウイルスチェックを行う。

こんな症状があったら注意

  • 勝手に添付ファイル付きのメールが送られる。
  • 特定の宛先にメールを送ることができない。
  • 見知らぬファイルがある。
  • 突然、Windows の起動やプログラムの実行が遅くなった。
  • 特定（特にアンチウイルスソフトメーカー）のWebサイトを見ることができない。

感染してしまったら

  • アンチウイルスソフトを使ってウイルスチェックをする。また、情報を集め感染したウイルスを特定する。
  • 今まで、ファイルやメールを送ったことのある人全員にウイルスに感染したことを伝える。メールを使って連絡するときは、必ずウイルスに感染していないコンピュータを使ってください。
  • アンチウイルスソフトを使うか自分の手でウイルスを除去する。
  • IPA（情報処理振興事業協会）にウイルスに感染したことを報告する。報告の義務はありませんが、感染被害の拡大と再発防止のためにできる限り報告するようにしましょう。

ウィルスに関する情報源へのリンク

  • IPA（情報処理振興事業協会）セキュリティセンター ウイルス対策室
  • JCSA（日本コンピュータセキュリティ協会）
  • シマンテック アンチウィルスリサーチセンター
  • トレンドマイクロ ワクチンバンク
  • ネットワークアソシエイツ AVERTウイルス情報
  • トレンドマイクロ ウイルスバスターオンラインスキャン（要Internet Explorer4.01以上）


HTMLメールとは

メール本文中の一部の文字の色を変えたりサイズを変更したり、写真などの画像を貼り付ける。Outlook ExpressなどからE-Mailをはじめた人には当たり前のことに思えるかもしれませんが、決してそうではありません。

もともとE-Mailは基本的に「文字だけ」を送る仕組みになっています。装飾情報もなにもない文字情報のことを「プレーンテキスト」といいます。初期のE-Mailはプレーンテキストであることが前提でした。添付ファイルもけっきょくは文字情報に変換してメールに付加されているのです。

しかしWWW、いわゆるホームページをインターネット上に公開する仕組みができた時、その記述のためのルールであるHTMLを利用すれば、メールでも文字だけでなくいろいろな書式を送れることとなったのです。HTMLも結局は文字情報に過ぎませんからね。

つまり、いろいろな文字装飾を施したり、画像を貼り付けたりしたメールを送るのは、HTMLメールを作成して送信している、ということなのです。強調したい部分を色ちがいにしたり、きれいな写真入りメールを記念日のカードとして送るといった用途にピッタリですね。

Becky!はVer.1の頃からHTMLメールの受信・表示はサポートされていました。そしてVer.2からはHTMLの作成・送信もサポートされました。ただし、これらはInternet Explorer（以下、IE）の機能を利用して実現されています。したがって表示にはIE3以降、作成にはIE5以降がそのパソコンにインストールされていることが必要です。

HTMLメールを送る時の注意点

しかしこのHTMLメール、現状では注意が必要です。というのは下記のような理由があるからです。

  • HTMLメールを表示できるメールソフトばかりではありません。むしろ種類としては表示できるもののほうが少ないです。HTMLメールを表示できるようにするというのは、つまりIEやNetscape Navigatorのようなブラウザを作ることに等しいですから、とても大変なことなのです。
  • 書式情報は当然その分メールのサイズを大きくします。文字だけで要件がすむメールにまで無用の書式情報が含まれてしまうのは無駄ですよね。

つまり、メーリングリストや相手がどのメールソフトを使っているかわからないような場合には、HTMLメールを送るべきではないのです。

Microsoft社のメールソフト（Outlook Expressなど）が古くからのE-Mailユーザーなどに嫌われているのは、HTMLメールが初期設定となっている、つまり不特定の相手にHTMLメールを送りつけてしまうことが多い仕様となっているのが原因の一つです。Outlook Expressなどを使う場合には、HTMLメール作成の初期設定を解除してから利用しましょう。

Becky!でのHTMLメールの表示

HTMLメールが送られてくると、リストビューのそのメールの封筒アイコンの左にクリップマークが表示されます。これは添付ファイルがあるメールと同様です。

HTMLを表示するのは簡単です。HTMLメールを表示するとメッセージビュー下部に「t/html」というタブが現れますから、それをクリックすれば表示されます。これは前述のとおりIE3以降がインストールされていることと、「ツール」-「全般的な設定」の「メール表示」-「HTMLメールの表示」にて「MSIEコンポーネントを利用」がONになっている必要があります（OFFの場合はHTMLパートが添付ファイルと同じ扱いになります）。

同じく「HTMLを優先的に表示」がONになっていると、メッセージ表示と同時にHTML表示になります。一部のメールソフト（Netscape Messengerなど）はHTMLパートのみのメールを送ってきますから、その場合にはこのオプションのON/OFFに関係なく、メールを表示した瞬間からHTML表示に移行します。

HTMLメール表示の注意点

HTMLメールを表示する時にも注意点があります。HTMLメールは様々なコマンドを実行することができるので、コンピュータウイルスとも言うべきメールをHTMLで送られてくる可能性もあるからです。

もちろんHTML表示部、つまりIEはそのような問題に対して防衛策を取ってはいます。Becky!がHTMLメールを表示する時も、セキュリティに気を使って表示させているようです。しかしプログラムは完全ではなく、時折IEに「セキュリティ・ホール」が発見されることもあります。したがって下記のような事項に気をつけてください。

  • 「全般的な設定」の「メール表示」-「HTMLメールの表示」にて「HTMLを優先的に表示」はOFFにしておき、必要時のみメッセージビュー下部のタブからHTML部を選択するようにしましょう。
  • IEは最新版を入れておくようにしましょう。セキュリティ対策がよりしっかりしています。
  • 未知の障害についてどうしても心配な人、HTMLパートのみのメールはすぐにHTML表示となってしまうことが嫌な人は、「全般的な設定」の「メール表示」-「HTMLメールの表示」にて「MSIEコンポーネントを使用」をOFFにしてしまいましょう。HTMLパートは添付ファイルとして扱われます。閲覧したければそのファイルを開けばOKです。

Becky!でのHTMLメール作成

HTMLメール作成は、メール作成ウィンドウにて「ツール」-「HTMLメールの作成」を実行してください。HTML編集モードに移行して、下部にHTML編集用のツールバーが現れます。そのツールバーの機能を利用してHTMLメールを書くことができます。前述のとおり、これにはIE5以降がインストールされていることと、「ツール」-「全般的な設定」の「エディタ」にて「インラインHTMLエディタを使う」がONになっていることが必要があります。

好みのHTMLエディタを使いたいという人は、メール作成ウィンドウにて「ツール」-「外部編集ツールの設定」でそのソフトを指定しましょう。


関連用語解説

本文中に出てきた関連用語の簡易解説です。より詳細に知りたい場合や、ここに掲載されているBecky!関係以外の用語を調べたい場合は、下記のサイトなどを参照してください。

  • アスキー デジタル用語辞典
  • 通信用語の基礎知識
APOP

メール受信時にパスワードを暗号化してサーバーに送信する規格。他サイト(他プロバイダのアクセスポイントに接続した時など)からメールを受信する場合に、通常のPOPではパスワードがそのまま流れるため、途中経路で傍受される危険がある。そのような場合にAPOPが有効だが、POPサーバー、メールクライアントの両方がAPOPを使える必要がある。

Becky!では「メールボックスの設定」-「基本設定」にてAPOPを使った認証設定ができる。

ASCII

「アスキー」。1byteの英数字およびいくつかの記号を定めた文字コードのこと。情報交換用米国標準コード。

Dana

Becky!と同じRimArts製の高機能テキストエディタ。Becky!にはDanaのサブセットが組み込まれているため、他のメールソフトに比してテキスト編集機能が充実している。なお、作者の乗松氏によれば読み方は「デイナ」であるとのこと。

eml形式

メール保存形式の１種。１メール１ファイルの形式。

Outlook Expressなどで書き出したメールはこの形式で、拡張子が.emlとなっている。メール内での本文とヘッダの区切りは空白行。

Becky!はこの形式のメールファイルをインポート/エクスポート可能である。

EUC

拡張UNIXコード。ASCII以外の文字（日本語など）を表すための文字コード規格の一種。その成り立ちからUNIXを搭載したマシンで用いられることが多い。

Windows上で表示するには、アプリケーションソフトが対応している必要がある。

IMAP

「Internet Message Access Protocol」の略。「アイマップ」と読む。メールシステムにおいて、メールを読み出すためのプロトコル。

一般によく使われているPOPと違って、メールをサーバー上に置いたまま管理する機能を持つ。つまり、複数のクライアント環境（たとえば会社と自宅の両方から）からアクセスしても、メールを同じように読み、管理することができる。モバイルでのメール利用にも有効。

保存領域を多く取る必要があるなどサーバー側の負担が大きいため、一般のインターネットプロバイダではあまり採用されていないが、企業などメールの一元管理が有効なネットワークでは、普及が進んでいる。

Becky!はVer.2よりIMAPに対応した。「メールボックスの設定」-「基本設定」にて「POP/IMAP」を選択可能。

ISO-2022-JP

日本語文字コードの符号化の規格。日本語メールを送信する場合の主流の形式。

具体的な文字情報としてはJISコードの大部分が採用されている。しかし、いわゆる半角カナの部分は採用されていないため、ISO-2022-JPのメールで半角カナを使うことはできない。

JISコード

日本語を表すための文字コード規格の一種。

Windows上で表示するには、アプリケーションソフトが対応している必要がある。

MIME

「Multipurpose Internet Mail Extensions」の略。「マイム」と読む。日本語など非ASCIIで表現される言語、音声、画像、動画等のファイルをメールで扱うための、ASCII文字列へのエンコード方式の規格。

ヘッダ、ヘッダのパラメータ、本文、添付ファイルごとに、MIMEとしての扱いがRFCで規定されている。

POP

「Post Office Protocol」の略。「ポップ」と読む。メールを保管しているサーバーから、その内容を読み出すためのプロトコル。

通常、パソコン上のメールソフト（Becky!も含む）は、メールの受信をPOP、メールの送信をSMTPで、サーバーとやりとりする。企業などではIMAPが用いられることもある。これらのプロトコルを利用できないネットワークではBecky!は利用不可能。

RFC

「Request For Comments」の略。IETF（Internet Engineering Task Force：Internet上の新しい技術の標準化を促進するために設立されたコンソーシアム）が公式に発行するドキュメントで、事実上、インターネット技術の仕様書。電子メールに関する仕様もRFC中にある。

これらのRFCは、Internet上にあるftpサイト（ftp.nic.ad.jp）などから無料で入手することができる。基本的には英語文書であるが、主要なものについては有志により日本語へ訳されているものもある。

Shift-JISコード

日本語を表すための文字コード規格の一種。WindowsやMacintoshで広く用いられている。

SMTP

「Simple Mail Transfer Protocol」の略。メールを送信するためのプロトコル。

SMTPは、もともとはサーバー間でメールをやり取りするためのプロトコルだったが、現在ではPOPを用いたメールクライアントが、サーバーに対してメールを送信する際にも利用されている。

UNICODE

「ユニコード」。文字コード規格の一種。多くの言語の文字を包括し、統一して扱えるのが特徴。

UNIX mbox形式

メール保存形式の１種。

基本的にはテキストファイルで、複数のメールが一つのファイルにまとめられた形式。前のメールとの区切りは"From"が行頭にある行で、一般に、
From 送信者のアドレス 送信日付
という書式であることが多いようである。メール内での本文とヘッダの区切りは空白行。

Becky!はこの形式のメールファイルをインポート/エクスポート可能である。しかし、インポートの際に、メール本文中にFromではじまる行がある場合、そこで分断されてしまうことがあるので注意。

エンコード

本来は「符号化する」という意味。メール関連用語としては、

  • ファイルをメールに添付するため
  • 日本語などの2byte文字をメールヘッダや本文に記述するため

に、ASCII文字列に変換すること（主にMIME）を指すことが多い。→「デコード」

拡張子（かくちょうし）

ファイル名の末尾に付加されるピリオドで区切られた文字列。通常3文字程度。一般にファイルタイプを反映している。下記はその一例。

.dll
ダイナミックリンクライブラリ（Windowsのシステムファイルや一部のプログラム。Becky!Ver.2のプラグインもこの形式）
.jpg
JPEG形式の画像ファイル（写真を保存する時に用いられることが多い）
.doc
Microsoft WORDのデータ
.xls
Microsoft EXCELのデータ

Windowsでは拡張子ごとに開くアプリケーションが記憶されており（関連付け）、たとえば拡張子が".doc"であるファイルをダブルクリックするとMicrosoft WORDが起動してそのファイルを開くのは、この機能による。

ただし初期状態のWindowsではいくつかの拡張子を表示しない設定になっているので注意が必要。Windowsのバージョンによって異なるが、たとえばWindowsMeでは「マイコンピュータ」の「ツール」-「フォルダ オプション」-「表示」にて「登録されているファイルの拡張子は表示しない」のチェックを外すことで、すべての拡張子が表示されるようになる（推奨）。

拡張子は統一規格が存在するわけではなく、他のアプリケーションのデータファイルと重なってしまうこともある。しかし代表的なものはおおむね対応関係が認知されている。

クライアント

「client」は「依頼人」の意。転じて、コンピュータ関連ではサーバーからサービスを提供される側のこと。つまりBecky!は「メールクライアント」である。いわゆる「メールソフト」や「MUA」とほぼ同義に使われることが多い。

サーバー

「server」は「提供者」の意。転じて、コンピュータ関連では、ある特定のサービスを提供するシステムやコンピュータを意味する。POPやSMTPを提供するものはそれぞれPOPサーバー、SMTPサーバーと呼ばれ、それらメールシステムに関るサーバーを総称してメールサーバーとも呼ぶ。→「クライアント」

ツリービュー

Becky!本体のウィンドウ左側のメールボックス・フォルダを表示している部分のこと。階層関係をツリー状に表示しているため、こう呼ばれる。Becky!ヘルプの「メイン画面」参照。

デコード

エンコードされたデータを元の状態に戻すこと。

プロトコル

複数のコンピュータや機器が互いに通信するための規約（手順・やりとり）のこと。Becky!もPOP、SMTPなどのプロトコルにしたがって、サーバーとメールのやりとりを行っている。

プロトコルログ

Becky!において、サーバーとのメール送受信の際のやりとりを記録したもの。「ツール」-「プロトコルログを取る」を実行すると、それ以降のサーバーとのやりとりがメールボックスアイコン選択時のメッセージビューに残される。

送受信時にトラブルが生じる時の原因究明に役立つ。

ミドルバー

Becky!本体ウィンドウのリストビューとメッセージビューの間にあるバー。表示中のメールの各種情報を表示している。「差出人」などの部分をクリックすると各種情報がさらに表示され、それらの情報を利用して新規/返信メールを書くこともできる。

メッセージビュー

Becky!本体ウィンドウ右下のメール本文を表示するための部分のこと。Becky!ヘルプの「メイン画面」参照。

メーリングリスト

複数の人に同じメールを配送できる仕組み。略してMLと表記・呼称されることも多い。

ある特定の宛先にメールを送ると、そのメールはあらかじめ登録されているメンバー全員に配送される。"Reply-To:"の設定によって、送られてきたメールへの返信はML宛になるようにされている場合も多い。これによって特定多数間の電子会議ともいうべきやりとりが可能になる。

現在、様々な用途に活用されており、活発なコミュニティとして成立しているMLも多く存在する。Becky!にもサポート用を含めた関連MLがある。

リストビュー

Becky!本体ウィンドウ右上のメール一覧を表示するための部分のこと。Becky!ヘルプの「メイン画面」参照。

レジストリ

Windowsの各種設定が保管されているデータベース。システム関連から各アプリケーションの設定まで、様々な情報がここに記録されている。レジストリエディタを使って編集が可能だが、その性質上、うかつにレジストリを書き換えてしまうと、最悪の場合Windowsが起動しなくなることもあり得るので、操作には注意が必要である。

Becky!Ver.2も「全般的な設定」の一部や登録ユーザー情報などをレジストリに記録している。データ保管場所は"HKEY_CURRENT_USER\Software\RIMArts\B2"

なお、レジストリエディタにて任意のキー以下をファイルに書き出し／取り込みが可能である。これを利用するとBecky!の設定をファイルに保存しておくことができる。ただしレジストリファイルの形式もWindowsのバージョンによって違いがあるので要注意。Windows 2000で書き出したレジストリファイルは、形式が変更されているためWindows 95/98/NT4で読み込むことができない（逆は可能）。旧版のWindowsへ設定を移行する場合には、保存時にファイルの種類を「Win9x/NT4レジストリファイル」にしておく必要がある。

レジストリエディタ

レジストリを編集するためのWindows付属のソフト。ただしスタートメニューには登録されていないので、"C:\Windows\regedit.exe"を直接実行する必要がある（スタートメニューの「ファイル名を指定して実行」にて「regedit」を実行すれば起動可能）。


標準のショートカットキー割り当て（機能順）

機能2ストロークキー | KOQ
未使用キー | Ctrl + (1-9)

[メーラー：メイン画面]
 | 送受信 | Ctrl + M |
 | 受信 |  |
 | 送信 |  |
 | リモートメールボックス |  |
 | 巡回 | Ctrl + Shift + M |
 | 新規メール | Ctrl + N | Ctrl + Shift + N
 | 返信先に新規メール |  |
 | 任意アドレスに新規メール |  |
 | 返信 | Ctrl + R | Ctrl + Shift + R
 | 全員に返信 |  |
 | 任意アドレスに返信 |  |
 | 転送 | Ctrl + W | Ctrl + Shift + W
 | リダイレクト |  |
 | 添付して転送 |  |
 | 削除 | Del | Ctrl + D
 | クエリー検索 | Ctrl + H |
 | 関連メール表示 |  |
 | スレッド表示 |  |
 | スレッドツール |  |
 | スレッドを閉じる |  |
 | スレッドを開く |  |
 | ソース表示 |  |
 | ヘッダ表示 |  |
 | 開封済みにする | Ctrl + B |
 | 未開封にする | Ctrl + Shift + B |
 | 直接編集モード |  |
 | 開封済みメールを選択 | Ctrl + Shift + A |
 | 名前の変更 | F2 |
 | メッセージビュー最大化 | Ctrl + Enter |
 | レイアウト変更 | Ctrl + Q ^ L |
 | メーリングリストマネージャ |  |
 | フィルタリングマネージャ |  |
 | 振り分け |  |
 | 前に戻る | Alt + ← |
 | 次に進む | Alt + → |
 | 設定 |  |
 | メールボックス設定 |  |
 | 名前を付けて保存 | Ctrl + S | Ctrl + K ^ S
 | 印刷 | Ctrl + K ^ P |
 | 印刷プレビュー | Ctrl + K ^ R |
 | メールボックス切替 | F4 |
 | プロパティ | Ctrl + P |
[メーラー：メール作成画面]
 | 送信箱に保存 | Ctrl + G |
 | 直ちに送信 | Ctrl + Shift + G |
 | 草稿箱に保存 | Ctrl + T |
 | リマインダ |  |
[エディタ：カレット移動]
 | カレット上 | ↑ |
 | カレット左 | ← |
 | カレット右 | → |
 | カレット下 | ↓ |
 | 一語左 | Ctrl + ← |
 | 一語右 | Ctrl + → |
 | 行頭 | Home |
 | 行末 | End |
 | 左端 | Alt + Home |
 | 右端 | Alt + End |
[エディタ：行編集]
 | バックスペース | BS | Ctrl + H
 | 削除 | Del |
 | コントロールコード | Ctrl + [ |
 | タブ | Tab |
 | 英大小文字列変換 | Ctrl + K ^ L |
 | 英大小文字変換 | Ctrl + L |
 | 行末まで削除 | Ctrl + Del |
 | 行頭まで削除 | Ctrl + BS |
 | 一語バックスペース | Shift + BS |
 | 一語削除 | Shift + Del |
 | 文字繰返し | Alt + Shift + Ins |
 | 検索文字列 | Ctrl + Q ^ I |
 | タイムスタンプ | Ctrl + K ^ T |
 | 改行 | Enter | Ctrl + M
 | 行削除 | Ctrl + E |
 | 空行下挿入 | Shift + Enter |
 | 空行上挿入 | Ctrl + Enter |
 | 行複写 | Ctrl + I |
 | 行マーク | Ctrl + Q ^ K |
 | 行取り出し | Ctrl + U |
 | 上書きモード | Ins |
 | 自動整形モード | Ctrl + K ^ J |
[エディタ：編集]
 | コピー | Ctrl + C | Ctrl + Ins
 | 切り取り | Ctrl + X | Ctrl + K ^ Y
 | 貼り付け | Ctrl + V | Shift + Ins
 | 追加コピー | Ctrl + F8 |
 | 追加カット | Ctrl + F7 |
 | 元に戻す | Ctrl + Z | Alt + BS
 | やり直し | Ctrl + Y | Alt + Shift + BS
 | 繰り返し | Ctrl + R |
 | ステップドゥ | Ctrl + D |
 | 選択開始 | Ctrl + K ^ B |
 | 箱型選択 | Ctrl + K ^ M |
 | 箱貼付 | Ctrl + K ^ I |
 | 変換 |  |
 | 中央揃え |  |
 | 左揃え |  |
 | 右揃え |  |
 | ソート |  |
 | インデント |  |
 | インデント戻す |  |
 | 文字列追加 |  |
 | すべて選択 | Ctrl + A |
 | ファイルにコピー | Ctrl + K ^ C |
 | ファイル貼り付け | Ctrl + K ^ V |
 | ファイルに追加 | Ctrl + K ^ ] |
 | 整形 |  |
 | 非整形 |  |
 | 履歴破棄 | Ctrl + K ^ F |
 | ヒストリー貼り付け | Ctrl + K ^ G |
[エディタ：スクロール]
 | ロールアップ |  |
 | ロールダウン |  |
 | 固定ロールアップ |  |
 | 固定ロールダウン |  |
 | 高速ロールアップ |  |
 | 高速ロールダウン |  |
 | 別ロールアップ | Alt + ↓ |
 | 別ロールダウン | Alt + ↑ |
 | 同時ロールアップ | Alt + Page Down |
 | 同時ロールダウン | Alt + Page Up |
 | ページアップ | Page Down |
 | ページダウン | Page Up |
 | 半ページアップ | Alt + Shift + Page Down |
 | 半ページダウン | Alt + Shift + Page Up |
 | 左スクロール | Alt + ← |
 | 右スクロール | Alt + → |
 | 低速ロールアップ | Ctrl + ↓ |
 | 低速ロールダウン | Ctrl + ↑ |
 | カレット行を上端に | Ctrl + Q ^ W |
 | カレット行を下端に | Ctrl + Q ^ Z |
 | カレット行を中央に | Ctrl + Q ^ D |
[エディタ：検索・行ジャンプ]
 | 文頭 | Ctrl + Q ^ R | Ctrl + Home
 | 文末 | Ctrl + Q ^ C | Ctrl + End
 | 指定行 | Ctrl + J |
 | 前位置 | Ctrl + Q ^ P |
 | 次のマーク | Ctrl + Page Down | Ctrl + Q ^ M
 | 前のマーク | Ctrl + Page Up | Ctrl + Q ^ N
 | マーク消去 | Ctrl + Q ^ \ |
 | 上端へ | Ctrl + Q ^ E |
 | 下端へ | Ctrl + Q ^ X |
 | 対応括弧 | Ctrl + ] |
 | 検索 | Ctrl + F | Ctrl + Q ^ F
 | 後方検索 | Ctrl + Q ^ B |
 | 次候補 | F3 | Ctrl + N
 | 前候補 | Shift + F3 | Ctrl + P
 | 置換 | Ctrl + Q ^ A |
 | 再置換 | Ctrl + Q ^ S |
 | 検索文字列取得 | Ctrl + _ |


標準のショートカットキー割り当て（キー順）

色分けは分類と対応しています。

[メーラー：メイン画面]
[メーラー：メール作成画面]
[エディタ：カレット移動]
[エディタ：編集]
[エディタ：行編集]
[エディタ：スクロール]
[エディタ：検索・行ジャンプ]

Alt + 各種キー
Alt + BS | [エディタ：編集] | 元に戻す
Alt + ↓ | [エディタ：スクロール] | 別ロールアップ
Alt + End | [エディタ：カレット移動] | 右端
Alt + Home | [エディタ：カレット移動] | 左端
Alt + ← | [メーラー：メイン画面] | 前に戻る
Alt + ← | [エディタ：スクロール] | 左スクロール
Alt + Page Down | [エディタ：スクロール] | 同時ロールアップ
Alt + Page Up | [エディタ：スクロール] | 同時ロールダウン
Alt + → | [メーラー：メイン画面] | 次に進む
Alt + → | [エディタ：スクロール] | 右スクロール
Alt + ↑ | [エディタ：スクロール] | 別ロールダウン
Alt + Shift + BS | [エディタ：編集] | やり直し
Alt + Shift + Ins | [エディタ：行編集] | 文字繰返し
Alt + Shift + Page Down | [エディタ：スクロール] | 半ページアップ
Alt + Shift + Page Up | [エディタ：スクロール] | 半ページダウン
Ctrl + アルファベット
Ctrl + A | [エディタ：編集] | すべて選択
Ctrl + B | [メーラー：メイン画面] | 開封済みにする
Ctrl + C | [エディタ：編集] | コピー
Ctrl + D | [メーラー：メイン画面] | 削除
Ctrl + D | [エディタ：編集] | ステップドゥ
Ctrl + E | [エディタ：行編集] | 行削除
Ctrl + F | [エディタ：検索・行ジャンプ] | 検索
Ctrl + G | [メーラー：メール作成画面] | 送信箱に保存
Ctrl + H | [エディタ：行編集] | バックスペース
Ctrl + H | [メーラー：メイン画面] | クエリー検索
Ctrl + I | [エディタ：行編集] | 行複写
Ctrl + J | [エディタ：検索・行ジャンプ] | 指定行
Ctrl + K ^ ] | [エディタ：編集] | ファイルに追加
Ctrl + K ^ B | [エディタ：編集] | 選択開始
Ctrl + K ^ C | [エディタ：編集] | ファイルにコピー
Ctrl + K ^ F | [エディタ：編集] | 履歴破棄
Ctrl + K ^ G | [エディタ：編集] | ヒストリー貼り付け
Ctrl + K ^ I | [エディタ：編集] | 箱貼付
Ctrl + K ^ J | [エディタ：行編集] | 自動整形モード
Ctrl + K ^ L | [エディタ：行編集] | 英大小文字列変換
Ctrl + K ^ M | [エディタ：編集] | 箱型選択
Ctrl + K ^ P | [メーラー：メイン画面] | 印刷
Ctrl + K ^ R | [メーラー：メイン画面] | 印刷プレビュー
Ctrl + K ^ S | [メーラー：メイン画面] | 名前を付けて保存
Ctrl + K ^ T | [エディタ：行編集] | タイムスタンプ
Ctrl + K ^ V | [エディタ：編集] | ファイル貼り付け
Ctrl + K ^ Y | [エディタ：編集] | 切り取り
Ctrl + L | [エディタ：行編集] | 英大小文字変換
Ctrl + M | [エディタ：行編集] | 改行
Ctrl + M | [メーラー：メイン画面] | 送受信
Ctrl + N | [メーラー：メイン画面] | 新規メール
Ctrl + N | [エディタ：検索・行ジャンプ] | 次候補
Ctrl + P | [エディタ：検索・行ジャンプ] | 前候補
Ctrl + P | [メーラー：メイン画面] | プロパティ
Ctrl + Q ^ \ | [エディタ：検索・行ジャンプ] | マーク消去
Ctrl + Q ^ A | [エディタ：検索・行ジャンプ] | 置換
Ctrl + Q ^ B | [エディタ：検索・行ジャンプ] | 後方検索
Ctrl + Q ^ C | [エディタ：検索・行ジャンプ] | 文末
Ctrl + Q ^ D | [エディタ：スクロール] | カレット行を中央に
Ctrl + Q ^ E | [エディタ：検索・行ジャンプ] | 上端へ
Ctrl + Q ^ F | [エディタ：検索・行ジャンプ] | 検索
Ctrl + Q ^ I | [エディタ：行編集] | 検索文字列
Ctrl + Q ^ K | [エディタ：行編集] | 行マーク
Ctrl + Q ^ L | [メーラー：メイン画面] | レイアウト変更
Ctrl + Q ^ M | [エディタ：検索・行ジャンプ] | 次のマーク
Ctrl + Q ^ N | [エディタ：検索・行ジャンプ] | 前のマーク
Ctrl + Q ^ P | [エディタ：検索・行ジャンプ] | 前位置
Ctrl + Q ^ R | [エディタ：検索・行ジャンプ] | 文頭
Ctrl + Q ^ S | [エディタ：検索・行ジャンプ] | 再置換
Ctrl + Q ^ W | [エディタ：スクロール] | カレット行を上端に
Ctrl + Q ^ X | [エディタ：検索・行ジャンプ] | 下端へ
Ctrl + Q ^ Z | [エディタ：スクロール] | カレット行を下端に
Ctrl + R | [メーラー：メイン画面] | 返信
Ctrl + R | [エディタ：編集] | 繰り返し
Ctrl + S | [メーラー：メイン画面] | 名前を付けて保存
Ctrl + T | [メーラー：メール作成画面] | 草稿箱に保存
Ctrl + U | [エディタ：行編集] | 行取り出し
Ctrl + V | [エディタ：編集] | 貼り付け
Ctrl + W | [メーラー：メイン画面] | 転送
Ctrl + X | [エディタ：編集] | 切り取り
Ctrl + Y | [エディタ：編集] | やり直し
Ctrl + Z | [エディタ：編集] | 元に戻す
Ctrl + 各種キー
Ctrl + [ | [エディタ：行編集] | コントロールコード
Ctrl + ] | [エディタ：検索・行ジャンプ] | 対応括弧
Ctrl + _ | [エディタ：検索・行ジャンプ] | 検索文字列取得
Ctrl + BS | [エディタ：行編集] | 行頭まで削除
Ctrl + Del | [エディタ：行編集] | 行末まで削除
Ctrl + ↓ | [エディタ：スクロール] | 低速ロールアップ
Ctrl + End | [エディタ：検索・行ジャンプ] | 文末
Ctrl + Enter | [メーラー：メイン画面] | メッセージビュー最大化
Ctrl + Enter | [エディタ：行編集] | 空行上挿入
Ctrl + F7 | [エディタ：編集] | 追加カット
Ctrl + F8 | [エディタ：編集] | 追加コピー
Ctrl + Home | [エディタ：検索・行ジャンプ] | 文頭
Ctrl + Ins | [エディタ：編集] | コピー
Ctrl + ← | [エディタ：カレット移動] | 一語左
Ctrl + Page Down | [エディタ：検索・行ジャンプ] | 次のマーク
Ctrl + Page Up | [エディタ：検索・行ジャンプ] | 前のマーク
Ctrl + → | [エディタ：カレット移動] | 一語右
Ctrl + ↑ | [エディタ：スクロール] | 低速ロールダウン
Ctrl + Shift + アルファベット
Ctrl + Shift + A | [メーラー：メイン画面] | 開封済みメールを選択
Ctrl + Shift + B | [メーラー：メイン画面] | 未開封にする
Ctrl + Shift + G | [メーラー：メール作成画面] | 直ちに送信
Ctrl + Shift + M | [メーラー：メイン画面] | 巡回
Ctrl + Shift + N | [メーラー：メイン画面] | 新規メール
Ctrl + Shift + R | [メーラー：メイン画面] | 返信
Ctrl + Shift + W | [メーラー：メイン画面] | 転送
Shift + 各種キー
Shift + BS | [エディタ：行編集] | 一語バックスペース
Shift + Del | [エディタ：行編集] | 一語削除
Shift + Enter | [エディタ：行編集] | 空行下挿入
Shift + F3 | [エディタ：検索・行ジャンプ] | 前候補
Shift + Ins | [エディタ：編集] | 貼り付け
各種キー
BS | [エディタ：行編集] | バックスペース
F2 | [メーラー：メイン画面] | 名前の変更
F3 | [エディタ：検索・行ジャンプ] | 次候補
F4 | [メーラー：メイン画面] | SwitchAccount
Del | [メーラー：メイン画面] | 削除
Del | [エディタ：行編集] | 削除
↓ | [エディタ：カレット移動] | カレット下
End | [エディタ：カレット移動] | 行末
Enter | [エディタ：行編集] | 改行
Home | [エディタ：カレット移動] | 行頭
Ins | [エディタ：行編集] | 上書きモードON/OFF
← | [エディタ：カレット移動] | カレット左
Page Down | [エディタ：スクロール] | ページアップ
Page Up | [エディタ：スクロール] | ページダウン
→ | [エディタ：カレット移動] | カレット右
Tab | [エディタ：行編集] | タブ
↑ | [エディタ：カレット移動] | カレット上